F30 No ROOT user
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 11 of 11
  1. #1
    Join Date
    Oct 2005
    Location
    British Columbia, Canada
    Posts
    880
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    F30 No ROOT user

    I am attempting to install F30 and I was successful. My problem is that there appears to be NO root user. How can I get the root user setup. I do not use 'sudo'.
    Robert :)

  2. #2
    Join Date
    Jul 2004
    Location
    Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
    Age
    73
    Posts
    23,715
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F30 No ROOT user

    Use sudo -i and then passwd to set the root password
    Linux & Beer - That TOTALLY Computes!
    Registered Linux User #362651


    Don't use any of my solutions on working computers or near small children.

  3. #3
    Join Date
    Oct 2005
    Location
    British Columbia, Canada
    Posts
    880
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F30 No ROOT user

    Quote Originally Posted by bob
    Use sudo -i and then passwd to set the root password
    Thanks bob
    Yes, that gets me 'sudoed to root' (which I know is the preferred approach) but I can not use ' su -' directly. When I use ' su - ' and the password it doesn't take me to 'root'. How can I get back to using ' su - ' directly?
    Robert :)

  4. #4
    Join Date
    Jul 2004
    Location
    Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
    Age
    73
    Posts
    23,715
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F30 No ROOT user

    Once you've set the root password that way, 'su' or 'su -' should work. Does for me.
    [bob@localhost ~]$ su -
    Password:
    [root@localhost ~]# cd /
    [root@localhost /]# ls
    bin dev home lib64 media opt root sbin sys temp usr
    boot etc lib lost+found mnt proc run srv @System.solv tmp var
    Linux & Beer - That TOTALLY Computes!
    Registered Linux User #362651


    Don't use any of my solutions on working computers or near small children.

  5. #5
    Join Date
    Jul 2004
    Location
    Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
    Age
    73
    Posts
    23,715
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F30 No ROOT user

    Now, if I simply do su - and then ls, here's what I get:
    [bob@localhost ~]$ su -
    Password:
    [root@localhost ~]# ls
    anaconda-ks.cfg
    Here's a couple of screenshots:

    You can see ROOT requires a password to open it, and when opened, the only entry is the 'anaconda-ks.cfg' .
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Screenshot from 2019-05-18 12-34-39.jpg 
Views:	3 
Size:	36.7 KB 
ID:	30343   Click image for larger version. 

Name:	Screenshot from 2019-05-18 12-34-02.jpg 
Views:	3 
Size:	29.3 KB 
ID:	30344  
    Linux & Beer - That TOTALLY Computes!
    Registered Linux User #362651


    Don't use any of my solutions on working computers or near small children.

  6. #6
    Join Date
    Oct 2005
    Location
    British Columbia, Canada
    Posts
    880
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F30 No ROOT user

    Quote Originally Posted by bob
    Now, if I simply do su - and then ls, here's what I get:


    Here's a couple of screenshots:

    You can see ROOT requires a password to open it, and when opened, the only entry is the 'anaconda-ks.cfg' .
    Hi bob
    I get the following when I try ' su - ' :

    [me@ACER-WIFI ~]$ su -
    Password:
    su: Authentication failure
    [me@ACER-WIFI ~]$ su -
    Password:
    su: Authentication failure
    [me@ACER-WIFI ~]$

    I am not sure why?
    Robert :)

  7. #7
    Join Date
    Jul 2004
    Location
    Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
    Age
    73
    Posts
    23,715
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F30 No ROOT user

    How about just 'su' to see if it's a password issue. Of course, once you do 'su', you should be able to do 'su -' immediately after. Crazy thought, but is it asking for your WIFI password?
    Linux & Beer - That TOTALLY Computes!
    Registered Linux User #362651


    Don't use any of my solutions on working computers or near small children.

  8. #8
    Join Date
    Oct 2005
    Location
    British Columbia, Canada
    Posts
    880
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F30 No ROOT user

    Quote Originally Posted by bob
    How about just 'su' to see if it's a password issue. Of course, once you do 'su', you should be able to do 'su -' immediately after. Crazy thought, but is it asking for your WIFI password?
    bob
    I attempted what you suggested, no joy. I ran a few other combos and display the 'anaconda-ks.cfg
    --------------->

    [me@ACER-WIFI ~]$ su
    Password:
    su: Authentication failure
    [me@ACER-WIFI ~]$ sudo -i
    [root@ACER-WIFI ~]# exit
    logout
    [me@ACER-WIFI ~]$ sudo su -
    [root@ACER-WIFI ~]# ls
    anaconda-ks.cfg
    [root@ACER-WIFI ~]# cat anaconda-ks.cfg
    #version=DEVEL
    ignoredisk --only-use=sdd
    # Partition clearing information
    clearpart --all --initlabel
    # Use graphical install
    graphical
    # Use hard drive installation media
    harddrive --dir=None --partition=/dev/mapper/live-base
    # Keyboard layouts
    keyboard --vckeymap=us --xlayouts='us'
    # System language
    lang en_CA.UTF-8

    # Network information
    network --hostname=localhost.localdomain
    #Root password
    rootpw --lock
    # X Window System configuration information
    xconfig --startxonboot
    # Run the Setup Agent on first boot
    firstboot --enable
    # System services
    services --enabled="chronyd"
    # System timezone
    timezone America/Vancouver --isUtc
    # Disk partitioning information
    part /boot --fstype="ext4" --label=BOOT
    part / --fstype="ext4" --ondisk=sdd --size=234160 --label=SLASH
    part swap --fstype="swap" --noformat

    %addon com_redhat_kdump --disable --reserve-mb='128'

    %end

    %anaconda
    pwpolicy root --minlen=6 --minquality=1 --notstrict --nochanges --notempty
    pwpolicy user --minlen=6 --minquality=1 --notstrict --nochanges --emptyok
    pwpolicy luks --minlen=6 --minquality=1 --notstrict --nochanges --notempty
    %end
    [r/-9647\
    root@ACER-WIFI ~]#

    <--------------
    I usually turn ' sudo ' off on my systems, not sure why. I did use my own partitioning structure and I do not use LVM. anaconda used to ask for the installer to setup a ' root ' user but the installer did not ask for it. Maybe I have to add user ' root ' to some group or something. My last install was F24 so I am no doubt behind on the specifics of controlling files and their contents.
    Robert :)

  9. #9
    Join Date
    Jul 2004
    Location
    Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
    Age
    73
    Posts
    23,715
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F30 No ROOT user

    Well, here's the Project's instructions from F30 Troubleshooting. https://docs.fedoraproject.org/en-US...ing/index.html

    The instructions are in the Problems After Installation section.
    Linux & Beer - That TOTALLY Computes!
    Registered Linux User #362651


    Don't use any of my solutions on working computers or near small children.

  10. #10
    Join Date
    Jan 2009
    Location
    New Zealand
    Posts
    86
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F30 No ROOT user

    The first reply sugegsted using passwd after getting root access, should work ok.
    You can more directly just

    sudo passwd

    it will prompt for your password, then for a new password for root.

  11. #11
    Join Date
    Mar 2006
    Posts
    745
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Re: F30 No ROOT user

    Its seems that per the OP 'sudo' is disabled in his system.
    To set a root password in this case the system will have to be booted from a rescue disk, then I believe just issuing passwd will be all that is necessary.
    jbkt23
    Thinkpads Depends on era T23 - X2xx
    AMD & Intel Boxes

Similar Threads

  1. Unable to access phpMyAdmin from my browser? Root user denied and regular user as we
    By cyberdome in forum Installation, Upgrades and Live Media
    Replies: 2
    Last Post: 29th March 2016, 05:28 AM
  2. Replies: 2
    Last Post: 4th October 2008, 10:46 AM
  3. user@domain bounced back to root though user has a mail box
    By nonlin in forum Servers & Networking
    Replies: 9
    Last Post: 8th July 2008, 01:25 PM
  4. Replies: 0
    Last Post: 3rd April 2007, 05:18 AM
  5. Replies: 3
    Last Post: 24th February 2007, 02:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •