Hi,
I have a fedora30 desktop on a dynamic IP behind a cable modem that I'd like to configure to support apache and specifically smokeping. The problem I'm having I believe is with php-fpm. I've installed and configured it, but trying to access it results in a gateway timeout error. I do see entries in the logs when this fails, so I'm sure I'm at least reaching the desktop successfully.

The desktop is on a dynamic IP (192.168.9.110) behind a cable modem with a dynamic IP. I've configured port forwarding for port 8027 to forward to port 8027 on the machine itself where apache is listening. I've also configured port 8022 to forward to port 8022 on the desktop to provide ssh access, and can ssh to it successfully.

I've configured the smokeping.conf apache config to allow any IP to communicate with it for now. I can also reach the default fedora test page successfully.

What is the minimum apache config that is necessary to work with smokeping without configuring a virtual host? I haven't changed the /etc/httpd/conf/httpd.conf, /etc/httpd/conf.d/ssl.conf and /etc/httpd/conf.d/fcgid.conf files from the default. I've just changed the Listen statement in ssl.conf to use 8022 instead of 80.

Here is my /etc/httpd/conf.d/smokeping.conf:
Code:
<Directory "/usr/share/smokeping" >
  Require local
  Require ip 68.195.193 192.168
</Directory>
<Directory "/var/lib/smokeping" >
  Require local
  Require ip 68.195.193 192.168
</Directory>
ScriptAlias /smokeping/sm.cgi  /usr/share/smokeping/cgi/smokeping.fcgi
Alias       /smokeping/images  /var/lib/smokeping/images
Alias       /smokeping         /usr/share/smokeping/htdocs
The /etc/httpd/conf.d/fcgid.conf file is also very simple:

Code:
AddHandler fcgid-script fcg fcgi fpl
FcgidIPCDir /run/mod_fcgid
FcgidProcessTableFile /run/mod_fcgid/fcgid_shm
The /etc/httpd/conf.d/ssl.conf file is also the default, and includes the SetHandler statement to use php-fpm, I believe:

Code:
<IfModule !mod_php5.c>
  <IfModule !mod_php7.c>
    # Enable http authorization headers
    SetEnvIfNoCase ^Authorization$ "(.+)" HTTP_AUTHORIZATION=$1

    <FilesMatch \.(php|phar)$>
        SetHandler "proxy:unix:/run/php-fpm/www.sock|fcgi://localhost"
    </FilesMatch>
  </IfModule>
</IfModule>
Here is my /etc/php-fpm.d/www.conf. It is also very much the default.

Code:
[www]
user = apache
group = apache
listen = /run/php-fpm/www.sock
listen.acl_users = apache,nginx
pm = dynamic
pm.max_children = 5
pm.start_servers = 2
pm.min_spare_servers = 2
pm.max_spare_servers = 3
slowlog = /var/log/php-fpm/www-slow.log
php_admin_value[error_log] = /var/log/php-fpm/www-error.log
php_admin_flag[log_errors] = on
php_value[session.save_handler] = files
php_value[session.save_path]    = /var/lib/php/session
php_value[soap.wsdl_cache_dir]  = /var/lib/php/wsdlcache
The /var/log/php-fpm/www-error.log file is empty. After attempting to reach the system remotely, I see the following message in the apache error_log from my remote IP:

Code:
[Wed May 15 15:42:17.997621 2019] [fcgid:warn] [pid 14476:tid 139916520441600] [client 68.195.199.42:34118] mod_fcgid: read data timeout in 40 seconds
I only have four php packages installed:

Code:
php-cli-7.3.5-1.fc30.x86_64
php-7.3.5-1.fc30.x86_64
php-fpm-7.3.5-1.fc30.x86_64
php-common-7.3.5-1.fc30.x86_64
Of course I have restarted both the php-fpm and httpd services. I'm really hoping someone can tell me what I'm doing wrong to cause it to always timeout on an otherwise idle box.