Default route not correctly added
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 2 of 2

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Oct 2011
    Posts
    221
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default route not correctly added

    Hi,

    I've just installed fedora30 desktop on a friend's computer for him. It was installed and configured here before he brought it to his house and connected it to his cable modem. Previously I had set up port forwarding on his modem from port 8027 to port 8027 on his system for web access and port 8022 to port 8022 on his system for remote ssh access.

    I used the gnome network manager to configure networking and just manually configured ssh to listen on port 8022 instead of the default.

    The problem is that, after bringing it back to his house and putting it online, the default route was not added properly and the system was unreachable until I stepped him through the process of adding it manually.

    This is the command I had him run as root to configure the default route:

    # route add default gw 192.168.9.1 dev enp4s6

    Here is that /etc/sysconfig/network-scripts/ifcfg-Wired_connection_2 config:

    HWADDR=00:0E:0C:3B:35:68
    TYPE=Ethernet
    PROXY_METHOD=none
    BROWSER_ONLY=no
    BOOTPROTO=none
    IPADDR=192.168.9.110
    PREFIX=24
    GATEWAY=192.168.9.1
    DEFROUTE=yes
    IPV4_FAILURE_FATAL=no
    IPV6INIT=yes
    IPV6_AUTOCONF=yes
    IPV6_DEFROUTE=yes
    IPV6_FAILURE_FATAL=no
    IPV6_ADDR_GEN_MODE=stable-privacy
    NAME="Wired connection 2"
    UUID=850cde8f-7dc2-364a-8911-e511cdbea2e4
    ONBOOT=yes
    DNS1=8.8.4.4
    AUTOCONNECT_PRIORITY=-999

    Is there something immediately identifiable that would prevent the default route from working?

    Typically NAME and DEVICE are the name of the device, like enp4s6, but they don't exist in this config. Is that what is missing? I can't easily reboot this machine, so want to be sure before I do it.

  2. #2
    Join Date
    Oct 2006
    Location
    CN99CF Agassiz BC Canada
    Posts
    410
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Default route not correctly added

    Comparing your wired connection with mine, you have the same stanzas as I do.

    In addition to your stanzas, I have MACADDR= with the same Hardware ID as HWADDR= . I don't think this is a material difference.

    It has been a long time since I brought up a machine from scratch. As I remember it, setting the default route must be done as you did, or through the networking section of the install software.

    I think you are good to go at this point with your friend's system.

Similar Threads

  1. DHCP not setting default route correctly
    By james968 in forum Servers & Networking
    Replies: 0
    Last Post: 20th July 2006, 12:23 PM
  2. Default route in FC4
    By huizhu55 in forum Servers & Networking
    Replies: 2
    Last Post: 28th July 2005, 12:19 AM
  3. Trying to route via two default gateways
    By Battery Powered in forum Servers & Networking
    Replies: 27
    Last Post: 18th May 2005, 04:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •