Getting nouveau running on F30
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    Jun 2005
    Posts
    255
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Angry Getting nouveau running on F30

    I upgraded from F29 to F30. I have been struggling with grub2 (but that's another issue…) Here I want to address xorg.

    For some time I have been using the patched NVIDIA files provided by ifnottruethenfalse. After upgrade to F30, this file does not run properly. So I tried first the nvidia drivers provided by negativo17, then the standard nvidia drivers from rpmfusion. None of these produced a usable system.

    The card is an older GeForce FTX 550 Ti.

    As the card is older, nouveau would probably actually be sufficient for me, but I am having a dickens of a time getting it to work. In the course of my experimenting with nvidia, I actually had one time that it actually started nouveau, and I was so stupid as not to leave well enough alone, and I don't know what I did to get it to work.

    I have removed all nvidia rpms and installed nouveau. I have removed the blacklists from modprobe.d.

    Grub is weird (loads a non-working grub, then I go to the command line, type exit, and get a working grub menu), but is trying to pass a blacklist parameter for nouveau as well. I used the 'e' command to remove this kernel option. I also tried adding the option 'nouveau.config=NvBios=PRAMN, with no luck.

    After booting, I get a lovely VGA 640x480 display.

    Inside of this system, I tried # modprobe nouveau. This provides no complaints, but dmesg does not seem to register anything.

    I am getting a little bit despondent. Any ideas of where to go with this?

  2. #2
    Join Date
    Apr 2009
    Location
    central NY, USA
    Posts
    1,233
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Re: Getting nouveau running on F30

    For some time I have been using the patched NVIDIA files provided by ifnottruethenfalse.
    You've been beating yourself up.

    Search the forum for posts about nvidia cards. (I use CentOS and therefore can't be specific). There are available repos that have packages to provide installation and 'auto-updating' of Nvidia drivers - essentially eliminating the need to 'rebuild' every time the kernel changes.

    Research here a bit - hopefully you'll find a solution. ;-)
    Last edited by lightman47; 10th May 2019 at 08:44 PM.
    Change - the only constant.

  3. #3
    Join Date
    Jun 2005
    Posts
    255
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Getting nouveau running on F30

    I fear I have too much cruft from previous installations hanging around. All the automated versions of installing nvidia simply fail, and I can't see what needs to be done.

    Thus, I am trying to just get nouveau working. That would be enough at this point. I'm probably going to end up getting a new computer anyway, but that might take a while, and I'd like to be able to work on something other than a nasty 640x480 screen.

    Code:
    [root@studienpraefekt ~]# rpm -qa |grep nvidia
    [root@studienpraefekt ~]# rpm -qa|grep nouveau
    xorg-x11-drv-nouveau-1.0.15-7.fc30.x86_64
    Xorg -configure generates this:
    Code:
    Section "ServerLayout"
            Identifier     "X.org Configured"
            Screen      0  "Screen0" 0 0
            InputDevice    "Mouse0" "CorePointer"
            InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
            ModulePath   "/usr/lib64/xorg/modules"
            FontPath     "catalogue:/etc/X11/fontpath.d"
            FontPath     "built-ins"
    EndSection
    
    Section "Module"
            Load  "glx"
    EndSection
    Section "InputDevice"
            Identifier  "Keyboard0"
            Driver      "kbd"
    EndSection
    
    Section "InputDevice"
            Identifier  "Mouse0"
            Driver      "mouse"
            Option      "Protocol" "auto"
            Option      "Device" "/dev/input/mice"
            Option      "ZAxisMapping" "4 5 6 7"
    EndSection
    
    Section "Monitor"
           Identifier   "Monitor0"
            VendorName   "Monitor Vendor"
            ModelName    "Monitor Model"
    EndSection
    
    Section "Device"
            ### Available Driver options are:-
            ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
            ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
            ### <percent>: "<f>%"
            ### [arg]: arg optional
            #Option     "SWcursor"                  # [<bool>]
            #Option     "HWcursor"                  # [<bool>]
            #Option     "NoAccel"                   # [<bool>]
            #Option     "ShadowFB"                  # [<bool>]
            #Option     "VideoKey"                  # <i>
            #Option     "WrappedFB"                 # [<bool>]
            #Option     "GLXVBlank"                 # [<bool>]
            #Option     "ZaphodHeads"               # <str>
            #Option     "PageFlip"                  # [<bool>]
            #Option     "SwapLimit"                 # <i>
            #Option     "AsyncUTSDFS"               # [<bool>]
            #Option     "AccelMethod"               # <str>
            #Option     "DRI"                       # <i>
            Identifier  "Card0"
            Driver      "nouveau"
            BusID       "PCI:1:0:0"
    EndSection
    
    Section "Screen"
            Identifier "Screen0"
            Device     "Card0"
            Monitor    "Monitor0"
            SubSection "Display"
                    Viewport   0 0
                    Depth     1
            EndSubSection
            SubSection "Display"
                    Viewport   0 0
                    Depth     4
            EndSubSection
            SubSection "Display"
                    Viewport   0 0
                    Depth     8
            EndSubSection
            SubSection "Display"
                    Viewport   0 0
    
    
                   Viewport   0 0
                    Depth     15
            EndSubSection
            SubSection "Display"
                    Viewport   0 0
                    Depth     16
            EndSubSection
            SubSection "Display"
                    Viewport   0 0
                    Depth     24
            EndSubSection
    EndSection
    The load problem with nouveau is:
    Code:
    [   541.581] (EE) [drm] Failed to open DRM device for pci:0000:01:00.0: -19
    How can I fix this??

Similar Threads

  1. Nouveau fails with external monitor (F16, nouveau, ION)
    By Beastcraft in forum Hardware & Laptops
    Replies: 7
    Last Post: 23rd June 2012, 01:58 PM
  2. Running Nvidia driver alongside Nouveau drivers
    By JeeKTan in forum Using Fedora
    Replies: 0
    Last Post: 5th August 2011, 09:13 AM
  3. Unable to get display running with nouveau
    By Jongi in forum Fedora 13 Development Branch
    Replies: 11
    Last Post: 3rd December 2009, 05:39 AM
  4. Problems when running emacs 22.3 under an X86_64 running FC10
    By dcelta@gmail.co in forum Using Fedora
    Replies: 1
    Last Post: 20th July 2009, 06:07 PM
  5. Replies: 2
    Last Post: 6th April 2008, 03:27 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •