Grub2 boots to prompt, not to menu
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 14 of 14
  1. #1
    Join Date
    Jun 2005
    Posts
    255
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Grub2 boots to prompt, not to menu

    I have been solving lots of annoying little problems with my upgraded F30 system. One annoyance that remains is that grub automatically drops me to a shell at boot. If I type exit, I go back to the menu and can boot normally. But it's annoying to have to do this. How to I restore the automatic loading of the menu? (An Ubuntu site suggests update-grub, but that is not provided by any package on F30.)

  2. #2
    Join Date
    Apr 2009
    Location
    central NY, USA
    Posts
    1,232
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Re: Grub2 boots to prompt, not to menu

    What's in your grub.cfg? (It's location in /boot will depend upon if you have EFI or not).
    Change - the only constant.

  3. #3
    Join Date
    Jun 2005
    Posts
    255
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Grub2 boots to prompt, not to menu

    In /boot/efi there are subdirectories EFI/fedora. Nothing in there at all. [On BIOS boot, the BIOS says something about EFI, though]

    in /boot/grub/i386-pc there are a whole lot of .mod files (and two .lst files), no .cnf files I can find.

    grubenv has:
    Code:
    # GRUB Environment Block
    boot_success=1
    kernelopts=rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1
    saved_entry=05a4f2a9a6fb4d859e0221d6fd17df2a-5.0.13-300.fc30.x86_64

  4. #4
    Join Date
    Mar 2019
    Location
    Colorado USA
    Age
    23
    Posts
    39
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Grub2 boots to prompt, not to menu

    GRUB allows you to switch between the menu and command-line using C and escape, and defaults to the command-line if no menu entries or config are specified.

    To quote the manual:
    "Commands are available to enter a bare command-line by pressing C (which operated exactly like the non-config-file version of GRUB, but allows one to return to the menu if desired by pressing ESC) or to edit any of the boot entries by pressing E."

    Try escape, and if that fails, do like lightman suggests and check grub.cfg.

    Edit: You could try 'find /boot -name grub.cfg' to see if it exists at all.
    Last edited by CPT Gray Wolf; 10th May 2019 at 02:21 PM.

  5. #5
    Join Date
    Jun 2005
    Posts
    255
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Grub2 boots to prompt, not to menu

    Weirdly, while trying to get X working properly, grub started giving me a menu, but this one only has F30 and won't boot. I have to switch to command line and back, then I have the normal menu. I think it has found an erroneous entry on sda, when it should be using sdc.

    Totally unrelated, but actually annoying me even more: Nvidia drivers don't want to work at all. For a brief moment, I had the system up with nouveau, and proceeded to break it again when re-installing Nvidia-340xx from rpmfusion. I now have X booting into a generic VGA mode. I think this is because rpmfusion recommended deleting xorg.conf after removing the Nvidia drivers. What would be the best way to generate a working one for this system?

  6. #6
    Join Date
    Jun 2005
    Posts
    255
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Grub2 boots to prompt, not to menu

    Current situation:

    On start, computer prints two dots (..) and goes to a menu containing F30 and F30-rescue. If one of these is selected, the boot fails before reaching "Welcome to Fedora 30 (Thirty)".

    If instead, I press c, I get a command prompt.
    If I press Escape, I get the same menu back that I had before.
    If I type exit, I get a grub menu populated with F30, the last two F29 kernels and F30-rescue. Here I can successfully boot. The grub lines are populated with a blacklist command for nouveau, so they're using something to generate themselves, and not just magically appearing.

    Ideas?

  7. #7
    Join Date
    Mar 2019
    Location
    Colorado USA
    Age
    23
    Posts
    39
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Grub2 boots to prompt, not to menu

    Quote Originally Posted by mpolo
    Current situation:

    On start, computer prints two dots (..) and goes to a menu containing F30 and F30-rescue. If one of these is selected, the boot fails before reaching "Welcome to Fedora 30 (Thirty)".

    If instead, I press c, I get a command prompt.
    If I press Escape, I get the same menu back that I had before.
    If I type exit, I get a grub menu populated with F30, the last two F29 kernels and F30-rescue. Here I can successfully boot. The grub lines are populated with a blacklist command for nouveau, so they're using something to generate themselves, and not just magically appearing.

    Ideas?
    Hmm... Something smells forked...

    Running theory now: Multiple conflicting GRUB installations.

    I'd try gathering some information:
    1. Try using E to look at the menu entries in both the borked menu and the functional one and see what it says.
    2. Check the UUID of /boot or /boot/efi in /etc/fstab.
    3. Check your BIOS boot order. (A bit of a long shot, but may be worth a check.)
    4. Check what mounts are up after booting.

  8. #8
    Join Date
    Jun 2005
    Posts
    255
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Grub2 boots to prompt, not to menu

    I think grub is on sda (which is (hd2) in grub) and on sdc (which is (hd0,1-3), hence the confusion that landed it on sda). How do I nuke the one on sda (it was made without a proper chroot)

  9. #9
    Join Date
    Mar 2019
    Location
    Colorado USA
    Age
    23
    Posts
    39
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Grub2 boots to prompt, not to menu

    Quote Originally Posted by mpolo
    I think grub is on sda (which is (hd2) in grub) and on sdc (which is (hd0,1-3), hence the confusion that landed it on sda). How do I nuke the one on sda (it was made without a proper chroot)
    First I'd make sure sdc is the first boot drive in the BIOS, that should help. Then make sure that the /boot partiton in fstab is pointing to the correct partition on sdc.

    After that you should be able to use something like fdisk to remove the "bootable" flag from as a, then remove the boot directory from it.

    There may be an easier was. Someone feel free to correct me.

  10. #10
    Join Date
    Apr 2009
    Location
    central NY, USA
    Posts
    1,232
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Re: Grub2 boots to prompt, not to menu

    I too suspect the machine is confused over boot records on multiple drives. As a result, it's unable to find your video drivers - and failing to the text prompt. I believe that when you type exit you drop into the correct boot and all is fine.

    As CPT Gray Wolf suggests, I'd look first in the BIOS to see if it's possible to change the boot order so the correct drive is the first booted. It also sounds like your Nvidia (or whatever video) drivers are working properly and configuring the blacklisting for you; they work when you finally get to the correct drive on which they are installed.

    -just my 2 cents - which may be worth less than that.
    Change - the only constant.

  11. #11
    Join Date
    Jun 2005
    Posts
    255
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Grub2 boots to prompt, not to menu

    I have given up and installed a new machine from scratch. I'm currently copying the last of my files from the old hard drive. In the process, I had to try all three hard drives before I found the one with my lvm groups on it*. Just happy that's over now.

  12. #12
    Join Date
    Oct 2007
    Posts
    39
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Grub2 boots to prompt, not to menu

    I've just installed grub-customizer. Works well, have dual boot and changed Windows (followed by rubbish) to Windows 10. You can change backgrounds etc. Worth a try.

  13. #13
    Join Date
    Jun 2005
    Posts
    255
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Grub2 boots to prompt, not to menu

    Ultimately, I'm going to be much happier with the clean F30 install, though. Lots of stuff that I was kludging around "just work" now.

  14. #14
    Join Date
    Oct 2007
    Posts
    39
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Grub2 boots to prompt, not to menu

    I think the "kludgers" are in the majority when comes to Linux.

Similar Threads

  1. F27 suddenly boots to command prompt
    By theking2 in forum Using Fedora
    Replies: 4
    Last Post: 1st April 2018, 01:21 PM
  2. Fedora 20 only boots to Grub Prompt!
    By illymax in forum Installation, Upgrades and Live Media
    Replies: 2
    Last Post: 8th October 2014, 05:26 PM
  3. [SOLVED]
    F18 boots to grub prompt
    By juheimbu in forum Installation, Upgrades and Live Media
    Replies: 5
    Last Post: 8th March 2013, 03:49 PM
  4. FC2: Boots to Grub Prompt; won't proceed
    By penguinboy in forum EOL (End Of Life) Versions
    Replies: 3
    Last Post: 22nd January 2005, 03:43 PM
  5. Fedora boots, but I only get sh, no login prompt
    By lars_eivind in forum Using Fedora
    Replies: 3
    Last Post: 5th November 2004, 11:24 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •