Keyboard and mouse lag after Upgrade to 30
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 6 of 6
  1. #1
    Join Date
    Dec 2009
    Location
    Shrewsbury, PA
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Unhappy Keyboard and mouse lag after Upgrade to 30

    I upgraded from 28 to 29. No issues. Everything worked as expected.
    Upgraded from 29 to 30 and I can't get anything typed properly anymore as the keyboard acts like a drunken sailor! It will randomly repeat a character and then skip a character. This makes typing a password impossible! I tried changing from gdm to sddm to lightdm - no change. My mouse moves like a slug and my keyboard is maddening refusing to cooperate. I changed the Wayland setting in /etc/gdm/custom.conf to disable it but no fix...

    Is there anything else I can do?

    I doubt this has anything to do with my Home Dir since the system is basically unusable before I can even login!

    If I SSH into the system it works just fine - just locally it sucks out loud! I have no special drivers for anything.... it's an integrated Intel Video card so nothing special.... usb keyboard/mouse so nothing there either.... just weird.....

    I'm checking /var/log/messages but don't see anything worhwhile yet.....

  2. #2
    Join Date
    May 2005
    Posts
    66
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Keyboard and mouse lag after Upgrade to 30

    I have an oddball motherboard and was having the same issue, iommu was disabled in the bios. Turning it on fixed the mouse problem, but killed usb3 in the process.
    I added 2 lines to grub, iommu=soft (fixed the mouse / keyboard issue) and pci=nomsi (brought usb3 back to life) I did leave the bios alone, iommu still disabled there.
    Try adding those 2 lines manually on a reboot to see if it works for you, if it does you can add them to grub.cfg and /etd/default/grub later on.
    Hope it works for you too.
    (it's a hobby, but I like it)

  3. #3
    Join Date
    Dec 2009
    Location
    Shrewsbury, PA
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Thumbs up Re: Keyboard and mouse lag after Upgrade to 30

    Quote Originally Posted by DaleDonofrio
    I have an oddball motherboard and was having the same issue, iommu was disabled in the bios. Turning it on fixed the mouse problem, but killed usb3 in the process.
    I added 2 lines to grub, iommu=soft (fixed the mouse / keyboard issue) and pci=nomsi (brought usb3 back to life) I did leave the bios alone, iommu still disabled there.
    Try adding those 2 lines manually on a reboot to see if it works for you, if it does you can add them to grub.cfg and /etd/default/grub later on.
    Hope it works for you too.
    (it's a hobby, but I like it)
    THANK YOU!!! That completely fixed my issue! I added both lines and I guess I could play with which (if not both) fixed it but not really caring as I have my desktop back!

    I have never ran into this one before - and I've been playing with Linux since before Red Hat.... it's a great hobby that turned into a nice career

    Thanks again. I will put this into my "stuff to know" file for future reference!

  4. #4
    Join Date
    Jun 2019
    Location
    UK
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Keyboard and mouse lag after Upgrade to 30

    I have the exact same issue but the proposed fix didn't work for me. I also don't understand how the proposed fix relates to the problem.

    I also have nouveau=noaccel in grub.cfg (always had trouble with nouveau) but otherwise everything is pretty much "vanilla."

    .: edit :.
    I fixed this without any of the above. I appended 3 to my grub command line so I could boot into terminal and then disabled Wayland in /etc/gdm/custom.conf

    Restart and all fine.
    Last edited by dibstaru; 9th June 2019 at 04:03 PM.

  5. #5
    Join Date
    Aug 2019
    Location
    Philadelphia, PA
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Keyboard and mouse lag after Upgrade to 30

    How do you access the files of your mouse doesn’t work?

  6. #6
    Join Date
    Dec 2009
    Location
    Shrewsbury, PA
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Keyboard and mouse lag after Upgrade to 30

    in my case I SSH'd into the system from another box.... I could make changes, reboot and try locally again and if it still acted weird I'd SSH in and try other settings....

Similar Threads

  1. Replies: 0
    Last Post: 6th May 2013, 07:06 AM
  2. Keyboard & mouse not available in X
    By torrtruk in forum Using Fedora
    Replies: 1
    Last Post: 11th January 2011, 10:02 PM
  3. Upgrade to F11 now mouse and keyboard stuttering
    By tabish121 in forum Using Fedora
    Replies: 1
    Last Post: 28th June 2009, 05:51 PM
  4. Replies: 0
    Last Post: 8th January 2009, 04:33 AM
  5. Keyboard and Mouse Don't Work Therefore Can't Upgrade to FC 5
    By saxmanrex in forum Installation, Upgrades and Live Media
    Replies: 5
    Last Post: 23rd November 2006, 06:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •