[SOLVED] Fuse problem? with latest Fedora 29 update and Fedora 30
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 2 of 2
  1. #1
    Join Date
    Feb 2015
    Location
    Colorado
    Posts
    49
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Fuse problem? with latest Fedora 29 update and Fedora 30

    After the latest Fedora 29 update I installed today, and with Fedora 30 it seems as though fuse is broken.

    Fedora workstation runs fine until I do the following command:
    $ sshfs user@myserver:/server /home/user/Server
    which would make the partition /server on myserver appear as a local partition /home/user/Server on the workstation.
    Now when I do this, Nautilus (Files) takes forever to launch (if at all) and when it eventually does, Nautilus is broken.
    Rhytmbox, and gnome-tweaks also takes a long time to launch if at all.

    ssh works fine, I can ssh into myserver ok and everything looks good.
    On the client workstation, I tried using both Wayland and Gnome on Xorg, still fails either way.

    Now I can't access any of my files on the server. Any suggestions on mounting my server via a different route until fuse is fixed would be appreciated.
    I will try to post a screenshot of the broken Nautilus shortly.
    I try to think, but nothin' happens!

  2. #2
    Join Date
    Feb 2015
    Location
    Colorado
    Posts
    49
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fuse problem? with latest Fedora 29 update and Fedora 30

    Okay, I walked away from the computer and cleared my mind. Then I started going back through my previous troubleshooting steps very slowly.
    In the Original Post, I said I could ssh into the server computer. I had so many theories going through my mind that it didn't even register that I had to enter the password for the server user. That was a red flag I missed. It looked like the ssh keys was at least part of the problem. While I was ssh'ed into the server anyway, I edited the authorized_keys file and removed my old client public key.

    In the client computer as my user, I removed the .ssh folder from my home folder, thus removing all current keys.
    Then i regenerated new ssh keys using ssh-keygen.
    Next I used ssh-copy-id to copy my new id_rsa.pub file to the server computer.
    I used ssh to remotely access the server and voila, no password entry was required.
    in the client computer I entered the sshfs user@myserver:/server /home/user/Server
    and it worked!

    Then for grins, I updated the server to the latest packages, and everything still worked.
    So that again tells me the problem was probably in FUSE and not SSH????

    All's well that ends well.
    I try to think, but nothin' happens!

Similar Threads

  1. Problem with Bluetooth sound after latest update on Fedora 23
    By kimmason in forum Hardware & Laptops
    Replies: 3
    Last Post: 24th April 2016, 07:16 PM
  2. Fedora freezing after latest update.
    By noviceFedora in forum Using Fedora
    Replies: 10
    Last Post: 2nd January 2016, 08:43 PM
  3. Replies: 3
    Last Post: 5th December 2009, 03:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •