Firefox doesn't start with first click on panel icon
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 7 of 7
  1. #1
    Join Date
    Mar 2009
    Location
    East part of The Netherlands
    Posts
    40
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Firefox doesn't start with first click on panel icon

    Hi, I use fedora 29 KDE. On the bottom panel I have several icons to start programs with.
    When I boot, and no matter how long I wait before I click the Firefox icon I see the small logo hanging at the cursor, bouncing for 5 seconds, then disappearing. Firefox doesn't start.
    When I click the icon again it does start and works perfectly.

    What could be a reason for Firefox not starting at the first click? As said, it doesn't matter how long I wait before I click so it's not that the system is still booting.
    Who has an idea?

  2. #2
    Join Date
    Oct 2010
    Location
    Canberra
    Posts
    3,071
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)

    Re: Firefox doesn't start with first click on panel icon

    When firefox is not running (check with ps or the system-monitor program)
    I would start by trying to run firefox from a terminal.
    I would also try starting it using a url with something like "xdg-open something.html" <-- substitute "something" for a known web page.

    User error. Please replace user and try again

  3. #3
    Join Date
    Mar 2019
    Location
    Lysekil
    Posts
    9
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Firefox doesn't start with first click on panel icon

    You can check into the options of the iconthe command to launch firefox only is
    firefox %U
    or there is something diferent. .. just an idea.

  4. #4
    Join Date
    Mar 2009
    Location
    East part of The Netherlands
    Posts
    40
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Firefox doesn't start with first click on panel icon

    Thanks for the help, guys.

    I checked the icon and saw that firefox %u is started.
    In a terminal I did this:
    Code:
    $ ps -aux | grep firefox
    jan       1973  0.0  0.0 215736   820 pts/0    S+   09:30   0:00 grep --colour=auto firefox
    Only the grep instruction is mentioned, in other words Firefox is not running

    Then I started it and I saw a part of the window on screen, minimizing fast into the bottom-left corner where the icon is placed.

    In terminal:
    Code:
    $ ps -aux | grep firefox
    jan       1981 47.4  7.5 1943136 290732 ?      Sl   09:31   0:04 //usr/lib64/firefox/firefox
    jan       2083 16.3  3.9 1661876 150672 ?      Rl   09:31   0:01 /usr/lib64/firefox/firefox -contentproc -childID 1 -isForBrowser -prefsLen 1 -prefMapSize 178874 -parentBuildID 20190401084844 -greomni /usr/lib64/firefox/omni.ja -appomni /usr/lib64/firefox/browser/omni.ja -appdir /usr/lib64/firefox/browser 1981 tab
    jan       2133 59.2  6.7 8141760 258392 ?      Sl   09:31   0:04 /usr/lib64/firefox/firefox -contentproc -childID 2 -isForBrowser -prefsLen 5416 -prefMapSize 178874 -parentBuildID 20190401084844 -greomni /usr/lib64/firefox/omni.ja -appomni /usr/lib64/firefox/browser/omni.ja -appdir /usr/lib64/firefox/browser 1981 tab
    jan       2242  4.6  1.7 1486824 68764 ?       Sl   09:31   0:00 /usr/lib64/firefox/firefox -contentproc -childID 3 -isForBrowser -prefsLen 6232 -prefMapSize 178874 -parentBuildID 20190401084844 -greomni /usr/lib64/firefox/omni.ja -appomni /usr/lib64/firefox/browser/omni.ja -appdir /usr/lib64/firefox/browser 1981 tab
    jan       2268  0.0  0.0 215736   892 pts/0    S+   09:31   0:00 grep --colour=auto firefox
    There is a line above the icon now showing it is active, but the screen is empty.
    Clicking the icon again and the program shows up.

    Minimizing the window is something I did not see before, but it happens so fast it is hardly visible. I can not find a reference to letting Firefox start minimized.

  5. #5
    Join Date
    Oct 2010
    Location
    Canberra
    Posts
    3,071
    Mentioned
    1 Post(s)
    Tagged
    1 Thread(s)

    Re: Firefox doesn't start with first click on panel icon

    Does it also start minimised if you start it with a URL, eg using xdg-open ?

    It might be that it does this when its got nothing to display.

    User error. Please replace user and try again

  6. #6
    Join Date
    Mar 2009
    Location
    East part of The Netherlands
    Posts
    40
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Firefox doesn't start with first click on panel icon

    It normally starts with the starting page, which in my case is a Speed-dial page.
    I'll try it with another page to see if that makes any difference.

  7. #7
    Join Date
    Mar 2009
    Location
    East part of The Netherlands
    Posts
    40
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Firefox doesn't start with first click on panel icon

    No, also with an address instead of %u it does not start the first time I click the icon. Also in terminal it says there is no firefox process running.

Similar Threads

  1. Firefox doesn't start up.
    By convict in forum Using Fedora
    Replies: 3
    Last Post: 5th December 2009, 02:12 PM
  2. Replies: 1
    Last Post: 2nd July 2009, 10:16 AM
  3. trashcan icon in panel doesn't work
    By udovdh in forum Using Fedora
    Replies: 4
    Last Post: 27th January 2008, 01:22 PM
  4. Firefox - Desktop Icon or Panel Update
    By franco53 in forum Installation, Upgrades and Live Media
    Replies: 0
    Last Post: 10th September 2006, 09:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •