amdgpu help (dumped nvidia for amd) - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2005
    0 Post(s)
    0 Thread(s)

    Question amdgpu help (dumped nvidia for amd)

    OK I swapped out an NVIDIA GPU for a rx590. I got it working with a rather simple edit to the grub kernel line, and of course purging anything NVIDIA (essentially dnf remove nvidia* *nouveau*), and added the xorg amdgpu driver.

    Now games, vulkan, wine, applications seem to work OK. But I have an issue where anytime I lock the system, the unlock screen is stupid slow, where the only fix is to reload gnome-shell, and the monitors will not stay asleep, they wake up after a few seconds, stay on for whatever the timeout is, sleep, wake up, repeat ad infinium.

    Since this cropped up AFTER I swapped the GPUs, I figured I would seek the solution. Not finding much online regarding this, so hence I am asking here. I have expanded (to no real change) the kernel parameter line to :

    # grep CMDLINE /etc/default/grub 
    GRUB_CMDLINE_LINUX="rhgb quiet splash usbcore.autosuspend=-1 radeon.cik_support=0 radeon.si_support=1 amdgpu.si_support=1 amdgpu.cik_support=1"
    Should I do something else? I am thinking that its either this or I have some cruft somewhere causing grief. I tried a fresh user and it does it there too. Out of ideas.

    F29 x64 Worskation
    Latest updates and GNOME3 + GDM.

  2. #2
    Join Date
    Dec 2012
    santa barbara, CA
    0 Post(s)
    0 Thread(s)

    Re: amdgpu help (dumped nvidia for amd)

    I have found that the screensaver kicks in even if you don't want it sometimes, and it sometimes conflicts with the power management.
    I would disable that fully, or like I did:
    mv /bin/xscreensaver /bin/xscreensaver.DISABLED
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

  3. #3
    Join Date
    Jul 2005
    0 Post(s)
    0 Thread(s)

    Question Re: amdgpu help (dumped nvidia for amd)

    OK, small but useful update:
    I dont have that binary installed:

    [andrew@schotty-tower-wired ~]$ rpm -qa | grep screensaver
    [andrew@schotty-tower-wired ~]$ ls -altr /bin/xscreensaver
    ls: cannot access '/bin/xscreensaver': No such file or directory
    [andrew@schotty-tower-wired ~]$

    KDE works fine. So this is a GNOME thing. I still have GDM as my greeter, but using Plasma as my DE. Still trying to figure out what got garbled up. Attempting to work this out to avoid a reinstall so close to F30 and RHEL8 dropping.

    Thanks, I am going to keep at this, now that I know this has nothing to do with amdgpu or the kernel, per se. Did quickly find out why I give up on KDE so quickly -- this is a clusterfsk of crap to configure to get the most simple of things done, and still cant figure out where the hell monitor configurations are -- looks like I need to make a custom xorg conf file for this one ... Until I figure this thing all out.

Similar Threads

  1. Possible to mine with amdgpu (non-pro)?
    By tkalfaoglu in forum Using Fedora
    Replies: 0
    Last Post: 30th March 2018, 09:22 PM
  2. Problem with AMDGPU firmware
    By tim8723 in forum Hardware & Laptops
    Replies: 2
    Last Post: 2nd February 2018, 08:16 PM
  3. AMDGPU-PRO Driver for Linux
    By lockheed02 in forum Using Fedora
    Replies: 30
    Last Post: 22nd November 2017, 08:52 AM
  4. [SOLVED]
    Xorg error amdgpu
    By rarity in forum Using Fedora
    Replies: 5
    Last Post: 20th October 2017, 12:16 AM
  5. amdgpu drivers not being used, how do I switch over
    By dyland in forum Hardware & Laptops
    Replies: 4
    Last Post: 29th January 2017, 10:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts