Fedora 29 blanks monitor but leaves backlight on
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 4 of 4
  1. #1
    Join Date
    Jun 2010
    Posts
    17
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Fedora 29 blanks monitor but leaves backlight on

    I've installed Fedora 29 on an Intel NUC8i7BEH with a Dell U2718Q 4k monitor (connected via HDMI). In Settings -> Power -> Blank Screen I've set a time of 15 minutes before my screen blanks. My problem is that after 15 minutes, the screen goes black but the monitor's backlight stays on at full power. I expect a screen blanker to turn off the backlight too but this is not happening. Is there some additional setting I need to make things work as expected? I checked Settings -> Devices -> Displays as well but don't see anything there that looks like it affects power and screen blanking. Is this perhaps one of those hidden features that needs to be turned on with the Tweak tool?

  2. #2
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    1,174
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 29 blanks monitor but leaves backlight on

    maybe you are on Gnome, but in my Xfce it's easy.

    disable Screensaver, search Power Manager, click on Display tab, select "Switch Off after..." x minutes.

    Click image for larger version. 

Name:	Screenshot_2019-04-04_09-46-26.png 
Views:	5 
Size:	11.7 KB 
ID:	30234
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

  3. #3
    Join Date
    Apr 2019
    Location
    India
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 29 blanks monitor but leaves backlight on

    Not a big issue, Try fixing it by disabling the screensaver and reboot your device then check your problem.

  4. #4
    Join Date
    Jun 2010
    Posts
    17
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 29 blanks monitor but leaves backlight on

    By "disable the screensaver" do you mean to set Blank Screen to "Never" in Settings -> Power Management? Tried that but it made things worse because now it neither blanks the screen nor turns off the backlight. At least least with Blank Screen set to a time, it gets me half way there, the screen goes blank, it just leaves the backlight on.

    The only viable work-around I've found is to set the Automatic Suspend setting to "On" and a time similar to the Blank Screen setting. Once the power suspends, the screen backlight turns off too. But it's more of a pain to get it back on because it takes a couple of seconds to un-suspend when I come back. Better than nothing I guess.

Similar Threads

  1. Backlight issues with Fedora 22/23 KDE
    By adelow in forum Hardware & Laptops
    Replies: 4
    Last Post: 8th March 2016, 08:08 PM
  2. Gateway NV7915u - Fedora 13 (No LCD monitor backlight)
    By Rotstein in forum Installation, Upgrades and Live Media
    Replies: 4
    Last Post: 22nd August 2012, 04:06 PM
  3. Fedora 12 on ASUS F8P backlight problem
    By tjmfhl in forum Hardware & Laptops
    Replies: 1
    Last Post: 31st December 2009, 11:02 AM
  4. Replies: 4
    Last Post: 30th November 2007, 09:55 PM
  5. Nvidia from Livna, then X blanks the monitor - Help!
    By Simoo in forum Hardware & Laptops
    Replies: 15
    Last Post: 27th October 2006, 04:12 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •