Cockpit WS: Failed to get connection to xfconfd: Cannot autolaunch D-Bus without X11
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 4 of 4
  1. #1
    Join Date
    Sep 2013
    Location
    HU
    Posts
    88
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Cockpit WS: Failed to get connection to xfconfd: Cannot autolaunch D-Bus without X11

    Hi!
    In a Fedora29, I cannot start the cockpit service:
    Code:
    # systemctl start cockpit
    Job for cockpit.service failed because a fatal signal was delivered causing the control process to dump core.
    See "systemctl status cockpit.service" and "journalctl -xe" for details.
    # systemctl status cockpit
    ● cockpit.service - Cockpit Web Service
       Loaded: loaded (/usr/lib/systemd/system/cockpit.service; static; vendor preset: disabled)
       Active: failed (Result: core-dump) since Mon 2019-04-01 23:59:32 CEST; 26s ago
         Docs: man:cockpit-ws(8)
      Process: 15604 ExecStartPre=/usr/sbin/remotectl certificate --ensure --user=root --group=cockpit-ws --selinux-type=etc_t (code=dumped, signal=TRAP)
    Starting Cockpit Web Service...
    Failed to get connection to xfconfd: Cannot autolaunch D-Bus without X11 $DISPLAY
    cockpit.service: Control process exited, code=dumped status=5
    cockpit.service: Failed with result 'core-dump'.
    Failed to start Cockpit Web Service.
    (selinux: disabled)

    The "echo $DISPLAY" is empty. (The Xorg is working fine: xfce4)
    What is the problem?

  2. #2
    Join Date
    Sep 2013
    Location
    HU
    Posts
    88
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Cockpit WS: Failed to get connection to xfconfd: Cannot autolaunch D-Bus without

    I tried such:

    # systemctl start cockpit.socket
    It is ok.
    When i try connect to server: https://IP_addr:9090

    then it crash...:
    systemctl status cockpit.socket
    ● cockpit.socket - Cockpit Web Service Socket
    Loaded: loaded (/usr/lib/systemd/system/cockpit.socket; enabled; vendor preset: enabled)
    Active: failed (Result: service-start-limit-hit) since Tue 2019-04-02 19:31:58 CEST; 6s ago
    Docs: man:cockpit-ws(8)
    Listen: [::]:9090 (Stream)
    Process: 8724 ExecStopPost=/bin/ln -snf /usr/share/cockpit/motd/inactive.motd /run/cockpit/motd (code=exited, status=0/SUCCESS)
    Process: 8468 ExecStartPost=/bin/ln -snf active.motd /run/cockpit/motd (code=exited, status=0/SUCCESS)
    Process: 8461 ExecStartPost=/usr/share/cockpit/motd/update-motd localhost (code=exited, status=0/SUCCESS)

    Starting Cockpit Web Service Socket.
    Listening on Cockpit Web Service Socket.
    cockpit.socket: Failed with result 'service-start-limit-hit'.

  3. #3
    Join Date
    Aug 2016
    Location
    spring, tx
    Posts
    84
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Cockpit WS: Failed to get connection to xfconfd: Cannot autolaunch D-Bus without

    I've been using cockpit for quite some time and have never seen this behavior (but im not on xfce). I did a little searching and i see a few issues that are similar (seems to be localized to xfce4) but no cockpit related fixes. I'd get with the guys at cockpit (probably via github), or xfce.

  4. #4
    Join Date
    Sep 2013
    Location
    HU
    Posts
    88
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Cockpit WS: Failed to get connection to xfconfd: Cannot autolaunch D-Bus without

    I removed the cert files in /etc/cockpit/ws-certs-d/* and restart cockpit. It seems ok!

Similar Threads

  1. Cockpit web GUI
    By rexrf in forum Servers & Networking
    Replies: 0
    Last Post: 30th October 2016, 06:46 PM
  2. Cockpit
    By glennzo in forum Servers & Networking
    Replies: 4
    Last Post: 23rd February 2015, 01:00 AM
  3. Fedora 14 [Saving connection failed: (0) Can't write connection type 'pppoe']
    By zonshy in forum Guides & Solutions (Not For Questions)
    Replies: 0
    Last Post: 6th December 2010, 05:44 AM
  4. Replies: 6
    Last Post: 7th October 2008, 10:25 AM
  5. Modem connection gives "Connection script failed" error
    By Lo Zeno in forum Servers & Networking
    Replies: 0
    Last Post: 29th May 2008, 07:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •