[SOLVED] Help me to enable "snap" & "flatpak" on my Fedora
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 4 of 4
  1. #1
    Join Date
    Aug 2016
    Location
    Iraq
    Posts
    1,076
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Help me to enable "snap" & "flatpak" on my Fedora

    It was too long since my review to snap & flatpak. I did not enable & install them till now due to reasons:
    1) limited number of applications
    2) no GUI for them.

    But today I review them & found that too many applications added to them (specially snap) ! Also, I discover that GUI for both of them now available via GNOME software center.

    I need to review the following steps if correct or wrong & if need some additional steps or commands:

    A) To enable flatpak:

    sudo dnf install flatpak

    restart PC & that is all.

    Regarding GUI I read that there is a plugin for GNOME software called "gnome-software-plugin-flatpak":
    https://itsfoss.com/flatpak-guide/

    but I did not find it in our Fedora repositories ! Is the GNOME center recent version has no need for such plugin ?

    =====================================
    B) To enable snap:

    sudo dnf install snapd

    sudo dnf install gnome-software-snap

    finally restart PC.

    Is there is need to run "sudo systemctl start snapd" & "sudo systemctl enable snapd" before restart PC or not ??

    Also I found the following:

    To enable classic snap support, enter the following to create a symbolic link between /var/lib/snapd/snap and /snap:

    $ sudo ln -s /var/lib/snapd/snap /snap

    Fedora Silverblue implements a read-only root filesystem and, consequently, cannot allow the above symbolic link to be created. See the following associated GitHub issue for further details: Make it easier to link in or bind folders to root directory?
    see bellow link:
    https://docs.snapcraft.io/installing...on-fedora/6755

    what this mean ? I did not understand any thing ! What is "classic snap support"
    Last edited by User808; 13th February 2019 at 08:50 PM.
    Fedora 30 X64 bit Cinnamon edition on Lenovo ThinkPad e550 with Intel core i7 5500 CPU @ 2.40 GH X 2, RAM = 8 GB, HHD = 1 TB, Hybrid VGA (Intel Corporation HD Graphic 5500 + Radeon R7 M265 2GB)

  2. #2
    Join Date
    Aug 2016
    Location
    Iraq
    Posts
    1,076
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Help me to enable "snap" & "flatpak" on my Fedora

    Hi again. I discovered that "flatpak" is installed on my system by default ! But where is GUI to brows flatpak applications ?? GNOME software center currently on my system not show flatpak application !

    Please, I need GUI for flatpak ....
    Fedora 30 X64 bit Cinnamon edition on Lenovo ThinkPad e550 with Intel core i7 5500 CPU @ 2.40 GH X 2, RAM = 8 GB, HHD = 1 TB, Hybrid VGA (Intel Corporation HD Graphic 5500 + Radeon R7 M265 2GB)

  3. #3
    Join Date
    Dec 2008
    Posts
    4
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Help me to enable "snap" & "flatpak" on my Fedora

    1. snap
    sudo dnf -y install snapd
    sudo systemctl enable --now snapd.socket
    sudo ln -s /var/lib/snapd/snap /snap
    reboot

    2. flatpak
    download and start https://flatpak.org/setup/Fedora/

  4. #4
    Join Date
    Aug 2016
    Location
    Iraq
    Posts
    1,076
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Help me to enable "snap" & "flatpak" on my Fedora

    Quote Originally Posted by helja
    1. snap
    sudo dnf -y install snapd
    sudo systemctl enable --now snapd.socket
    sudo ln -s /var/lib/snapd/snap /snap
    reboot

    2. flatpak
    download and start https://flatpak.org/setup/Fedora/
    Many thanks ! Your method is correct & I was wrong when I did not trust you because you used "socket" instead ".service"

    I discovered the following link which used same method:
    https://computingforgeeks.com/instal...-29-fedora-28/

    But there is issue: please see this:
    https://forums.fedoraforum.org/showt...!-Please-help-!

    It seem that there is an issue related to ".service" & for that Fedora developers use ".socket" instead ".service" BUT WHY THEY DID NOT REMOVE ".service" unit totally ?

    Please read above link & see comment #5 from me within it. I'm suffering now from same repeated SElinux alert, but snap packages are all can be dealt from within GNOME software ! The output of "systemctl status snapd.socket" is okay as following:

    Code:
    $ systemctl status snapd.socket
    ● snapd.socket - Socket activation for snappy daemon
       Loaded: loaded (/usr/lib/systemd/system/snapd.socket; enabled; vendor preset>
       Active: active (listening) since Fri 2019-02-15 17:27:05 GMT; 17min ago
       Listen: /run/snapd.socket (Stream)
               /run/snapd-snap.socket (Stream)
        Tasks: 0 (limit: 4915)
       Memory: 0B
       CGroup: /system.slice/snapd.socket
    
    Feb 15 17:27:05 localhost.localdomain systemd[1]: Starting Socket activation fo>
    Feb 15 17:27:05 localhost.localdomain systemd[1]: Listening on Socket activatio>
    lines 1-11/11 (END)
    However, I suffer from the following repeated SElinux alert:

    Code:
    SELinux is preventing umount from getattr access on the filesystem /.
    
    *****  Plugin catchall (100. confidence) suggests   **************************
    
    If you believe that umount should be allowed getattr access on the  filesystem by default.
    Then you should report this as a bug.
    You can generate a local policy module to allow this access.
    Do
    allow this access for now by executing:
    # ausearch -c 'umount' --raw | audit2allow -M my-umount
    # semodule -X 300 -i my-umount.pp
    
    Additional Information:
    Source Context                system_u:system_r:snappy_t:s0
    Target Context                system_u:object_r:fs_t:s0
    Target Objects                / [ filesystem ]
    Source                        umount
    Source Path                   umount
    Port                          <Unknown>
    Host                          localhost.localdomain
    Source RPM Packages           
    Target RPM Packages           
    Policy RPM                    <Unknown>
    Selinux Enabled               True
    Policy Type                   targeted
    Enforcing Mode                Enforcing
    Host Name                     localhost.localdomain
    Platform                      Linux localhost.localdomain 4.20.7-100.fc28.x86_64
                                  #1 SMP Wed Feb 6 19:17:09 UTC 2019 x86_64 x86_64
    Alert Count                   6
    First Seen                    2019-02-15 17:18:32 GMT
    Last Seen                     2019-02-15 17:32:43 GMT
    Local ID                      f6d50869-9ae4-428c-96c0-94d952de5772
    
    Raw Audit Messages
    type=AVC msg=audit(1550251963.682:414): avc:  denied  { getattr } for  pid=5898 comm="umount" name="/" dev="loop0" ino=2 scontext=system_u:system_r:snappy_t:s0 tcontext=system_u:object_r:fs_t:s0 tclass=filesystem permissive=1
    
    
    Hash: umount,snappy_t,fs_t,filesystem,getattr
    I tried:
    Code:
    sudo systemctl stop snapd.service
    then
    Code:
    sudo systemctl disable snapd.service
    then
    reboot my PC but error remain !!

    I will lebel this thread as "solved" because snap applications now enabled & usable but I suffer from the above alert ! Can you, kindly, help further to fix this ?
    Fedora 30 X64 bit Cinnamon edition on Lenovo ThinkPad e550 with Intel core i7 5500 CPU @ 2.40 GH X 2, RAM = 8 GB, HHD = 1 TB, Hybrid VGA (Intel Corporation HD Graphic 5500 + Radeon R7 M265 2GB)

Similar Threads

  1. Replies: 2
    Last Post: 7th June 2018, 03:12 PM
  2. Help me to enable "snap" on my Fedora
    By User808 in forum Using Fedora
    Replies: 2
    Last Post: 12th February 2018, 10:05 PM
  3. Replies: 5
    Last Post: 16th February 2013, 07:54 PM
  4. Replies: 1
    Last Post: 21st November 2011, 04:09 AM
  5. Replies: 0
    Last Post: 23rd May 2005, 04:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •