F29 unstable unless nouveau.modeset=0 - how to fix?
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 6 of 6
  1. #1
    Join Date
    Feb 2016
    Location
    USA
    Posts
    49
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    F29 unstable unless nouveau.modeset=0 - how to fix?

    Running newly installed F29 and updated to latest: 4.20.6

    If I hit 'e' at boot and edit the linux line to include "nouveau.modeset=0" I get a semi-working Fedora. (Why only "semi"? see bottom of post)

    If I don't perform that edit, the system is erratic and nearly unusable. If I open a terminal and run sudo vi on a file, nothing seems to happen (never asked for a password). Mouse is erratic, choosing "Settings" from the top-right menu yields the spinning thing that can simply vanish with no window opening or the system totally hangs. I cannot even TopMenu|PowerDown - having to revert to holding down the power button to get it to shutdown. To be clear, the edit step above seems to fix this problem.

    So is there a better fix, or failing that - how does one make that setting permanent?

    I edited the etc/default/grub file with perturbations of various incantations I've found Googling but none of them seem to work.
    (nouveau.modeset=0 rd.driver.blacklist=nouveau modprobe.blacklist=nouveau)
    I test my attempts by rebooting, skipping the 'e' step above - always getting the erratic Fedora

    As for the previously mentioned semi-working Fedora - I get lots of "Oops we're sorry" warnings thrown at me at boot
    BOOT_IMAGE=/boot/vmlinuz-4.20.6-200.fc29.x86_64
    or if I choose the previous version
    BOOT_IMAGE=/boot/vmlinuz-4.18.16-300.fc29.x86_64
    and references to a tainted kernel.

    I have no idea if the nouveau issue and the "oops" issue are related.

    -Mike

    https://forums.fedoraforum.org/showt...93#post1818993

  2. #2
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    7,156
    Mentioned
    6 Post(s)
    Tagged
    1 Thread(s)

    Re: F29 unstable unless nouveau.modeset=0 - how to fix?

    please refer to this page. it will help you set up the proprietary NVIDIA driver instead of nouveau. pay attention to the optimus notes though as you have switchable graphics according to your inxi output.

  3. #3
    Join Date
    Aug 2007
    Posts
    466
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F29 unstable unless nouveau.modeset=0 - how to fix?

    I edited the etc/default/grub file with perturbations of various incantations I've found Googling but none of them seem to work.
    (nouveau.modeset=0 rd.driver.blacklist=nouveau modprobe.blacklist=nouveau)
    I test my attempts by rebooting, skipping the 'e' step above - always getting the erratic Fedora
    Do you run grub2-mkconfig to generate a new grub.cfg each time you make a change to the /etc/default/grub file? This file is just an input for grub2-mkconfig. Unless you generate a new grub.cfg that uses the new inputs changing this file is meaningless.

    If you generate a new grub.cfg you don't need the 'e' step as all changes made to /etc/default/grub are included and made permanent.

  4. #4
    Join Date
    Feb 2016
    Location
    USA
    Posts
    49
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F29 unstable unless nouveau.modeset=0 - how to fix?

    Thanks for the leads...

    After editing etc/default/grub, I ran grub2-mkconfig, but that doesn't add nouveau.modeset=0 to what is displayed when I use the 'e' option at boot. And, therefore, I still end up with the useless F29.

    However, looking into the help from the rpmfusion NVIDIA page, I tried the command:

    sudo grubby --update-kernel=ALL --args="nouveau.modeset=0" seems do what I was asking - that is, to get that setting run at boot without needing the 'e' and yielding a working F29.

    So I guess that's OK for now...

    Why am I seeing the Oops messages?

  5. #5
    Join Date
    Aug 2007
    Posts
    466
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F29 unstable unless nouveau.modeset=0 - how to fix?

    After editing etc/default/grub, I ran grub2-mkconfig, but that doesn't add nouveau.modeset=0 to what is displayed when I use the 'e' option at boot. And, therefore, I still end up with the useless F29.
    I didn't mention this explicitly but you need to specify the output file with -o when running grub2-mkconfig. It would be different with an EFI system and a legacy BIOS system. The date on the grub.cfg file should change to the current time.

    EFI: grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

    BIOS: grub2-mkconfig -o /boot/grub2/grub.cfg

    https://fedoraproject.org/wiki/GRUB_..._configuration
    Last edited by amiga; 13th February 2019 at 05:07 PM.

  6. #6
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    1,177
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: F29 unstable unless nouveau.modeset=0 - how to fix?

    If you're not sure where grub.cfg is:
    Code:
    su -
    find /boot/ -print | grep grub.cfg
    hehe
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

Similar Threads

  1. nvidia modeset question
    By bobx001 in forum Installation, Upgrades and Live Media
    Replies: 0
    Last Post: 22nd February 2018, 06:56 PM
  2. Radeon Modeset Causes System to Hang
    By Xavier13 in forum Hardware & Laptops
    Replies: 2
    Last Post: 17th November 2016, 02:24 PM
  3. Replies: 1
    Last Post: 13th May 2014, 11:04 AM
  4. modeset/KMS troubles with ASUS VS248
    By NaVVy in forum Hardware & Laptops
    Replies: 0
    Last Post: 13th January 2012, 11:58 AM
  5. kernel-PAE-2.6.33-0.14.rc3.git4 modeset on nv11
    By SlowJet in forum Fedora 13 Development Branch
    Replies: 1
    Last Post: 23rd January 2010, 05:05 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •