After kernel update (4.20.3), system won't allow login
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 10 of 10
  1. #1
    Join Date
    Jan 2013
    Location
    Ventura, CA
    Posts
    432
    Linux (Fedora) Firefox 65.0

    After kernel update (4.20.3), system won't allow login

    I have three computers with fedora 29. About a week or so ago (after system upgrade), system boots up to command-line; there is no GUI login any more. When I try to log in, I get this error message:
    Code:
    cannot make/remove an entry for the specified session
    After some googling, I tend to think that the problem is with PAM. I haven't run into any fedora users with this problem, however. Some people have stated that commenting out "session required pam_loginuid.so" in /etc/pam.d/login and/or in /etc/pam.d/sshd would solve the problem. I haven't done that because I don't know how that would affect security on my machine.

    On my HP Pavilion laptop with uefi boot, I ran into a slightly different problem (after updating kernel to 4.20.4); the system boots up to command-line (no GUI login) and when I supply the correct user name and password, the system states that the password is wrong. I have tried to login as root, but I get the same error message (the same is true for my other two systems).

    I am using xfce4 on all machines.

    On one machine I just reinstalled fedora 29 from an up-to-date respin which solved the login problem. Fortunately I have dual boot on all machines (with Archlinux which is running without problems).

    I would like to hear some opinions as to why my login is borked.
    Last edited by donatom; 11th February 2019 at 06:15 PM.

  2. #2
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    1,087
    Linux (Fedora) Firefox 65.0

    Re: After kernel update (4.20.3), system won't allow login

    Hmm, I just upgraded to FC29:
    # uname -a
    Linux nova 4.20.6-200.fc29.x86_64 #1 SMP Thu Jan 31 15:50:43 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

    and I use LXDM -> Xfce, and all works perfect.
    What display manager are you using ? Lightdm ? Gdm ?
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

  3. #3
    Join Date
    Jan 2013
    Location
    Ventura, CA
    Posts
    432
    Linux (Fedora) Firefox 65.0

    Re: After kernel update (4.20.3), system won't allow login

    Quote Originally Posted by bobx001
    What display manager are you using ? Lightdm ? Gdm ?
    Code:
    [donatom@myfedora ~]$ ps -ef | grep '/[X]'
    root       816   792  2 07:40 tty1     00:03:42 /usr/libexec/Xorg -core -noreset :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt1 -novtswitch
    As you can see, I am using lightdm -- not sure if that is the same as lxdm -- but I don't think that the dm is the problem. My system was working well -- the login problem came out of the blue.

  4. #4
    Join Date
    Jan 2013
    Location
    Ventura, CA
    Posts
    432
    Linux (Fedora) Firefox 65.0

    Re: After kernel update (4.20.3), system won't allow login

    I actually have a fourth fedora 29 install which uses the Fluxbox desktop and which, of course, has no display manager. This installation logs in normally. I can't explain this. Perhaps some one else can.

  5. #5
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    1,087
    Linux (Fedora) Firefox 65.0

    Re: After kernel update (4.20.3), system won't allow login

    question.
    if you press say CTRL-ALT-F4 , and log into the console, can you log in ?
    if so, log in as root, and type: systemctl set-default multi-user.target
    then reboot, and when at the console log in, go ahead and log in as your regular user
    once you are logged in, type "startx".
    so some stuff in your session, i.e. modify your panel, etc. Then log out and reboot, and see if you can log in again.
    if you can, then log in as root, type systemctl set-default graphical.target
    reboot again, and see if everything works.
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

  6. #6
    Join Date
    Jan 2013
    Location
    Ventura, CA
    Posts
    432
    Linux Firefox 65.0

    Re: After kernel update (4.20.3), system won't allow login

    Quote Originally Posted by bobx001
    if you press say CTRL-ALT-F4 , and log into the console, can you log in ?
    No, there is only a login terminal; I have tried to log in as user and as root. I get the same error. Pressing CTRL-ALT-F4 or F3 or F2 does nothing. Thanks for the suggestion.

    Looks like I will have to play around with the /etc/pam.d/login file (or the /etc/pam.d/sshd file).

  7. #7
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    1,087
    Linux (Fedora) Firefox 65.0

    Re: After kernel update (4.20.3), system won't allow login

    That's very odd, something got definitely "borked".
    On the local console, sshd would not play a role.
    However, what happens if you try to ssh in from another computer ?
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

  8. #8
    Join Date
    Jan 2013
    Location
    Ventura, CA
    Posts
    432
    Linux (Fedora) Firefox 65.0

    Re: After kernel update (4.20.3), system won't allow login

    Quote Originally Posted by bobx001
    However, what happens if you try to ssh in from another computer ?
    I haven't enabled sshd as a service (for security reasons), so I probably won't be able to ssh into them. I have chrooted into one to update the system, but that did not solve the problem.

    I will try to ssh into them this evening. Thanks.

  9. #9
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    1,087
    Linux (Fedora) Firefox 65.0

    Re: After kernel update (4.20.3), system won't allow login

    The only other thing I would do is to load a Live USB stick, and mount your root partitions and go "fix stuff".
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

  10. #10
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    1,087
    Linux (Fedora) Firefox 65.0

    Re: After kernel update (4.20.3), system won't allow login

    Additional info, reading into your problem on the web, I found that there are other people with the PAM issue running around, and one thing that has ALWAYS bothered me is those darned "authentication" dialog boxes which appear every once in a while, example when I launch opera..... bang, I get prompted for a password *twice* (one is from opera, the other is apparently gnome-keyring), but this video card I got is too quick, so I never see it, and the dialog box quickly hides behind all other windows, does not even show in the window-buttons list, and opera fails to work, until I find the darned dialog.

    So, what I did now to solve that problem and get rid of one constant headache is the following:
    commented out this line in /etc/pamd.d/lxdm (which is my login manager).
    Code:
    #session    optional    pam_gnome_keyring.so auto_start
    I have now logged rebooted, logged back in, and tested opera, and so far so good, no evil self-hiding dialog box, only the opera keyring, but not the gnome-keyring. halleluyah
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

Similar Threads

  1. no login after update to kernel -3.7.6-102
    By JValeck in forum Using Fedora
    Replies: 26
    Last Post: 12th March 2013, 12:13 AM
  2. Can't login with kernel update and NVIDIA
    By billquinn in forum Using Fedora
    Replies: 28
    Last Post: 21st May 2012, 07:41 AM
  3. no login possible after aborted kernel update
    By libelle in forum Using Fedora
    Replies: 0
    Last Post: 10th September 2011, 09:37 PM
  4. Replies: 10
    Last Post: 15th December 2010, 11:05 PM
  5. Login problem after kernel update
    By paulvitic in forum Using Fedora
    Replies: 4
    Last Post: 2nd July 2008, 08:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •