Hello everyone,

I have been using Linux distributions for quite sometime now (Ubuntu 18.04 earlier and Fedora 29 now). Their are two major issues which I am facing with Fedora 29 and no matter what I try, it just doesn't solve.

The issue is that after I installed the proprietary Nvidia drivers for my GPU using this method https://rpmfusion.org/Howto/NVIDIA, the splash screen automatically changed to text plymouth (grey screen with 3 white dots). I tried to change it to "charge". I followed method1https://fedoramagazine.org/howto-cha...lymouth-theme/ and method2 https://www.if-not-true-then-false.c...vidia-guide/2/. I also tried certain other methods but they were all very similar to the above two methods. However, it didn't change a thing. I also noticed that my GRUB resolution just wouldn't change, no matter the code in the grub file. It was stuck at a default resolution which I could not get to change. The configuration of the GRUB file is this:

Click image for larger version. 

Name:	Screenshot from 2019-02-09 20-16-24.png 
Views:	11 
Size:	70.1 KB 
ID:	30065

I then decided to check the supported resolutions using the terminal at grub but to my surprise, I kept getting the message "Can't find command" for vbeinfo and videoinfo which is really strange. I would like to notify that even when I was using Ubuntu, no matter what I tried, it just wouldn't accept my native resolution in the grub menu which wasn't the case earlier, i.e the grub resolution was at native resolution but then after some days and I don't know exactly when, grub stopped supporting my native resolution. However, do note that videoinfo used to work then and showed the highest supported resolution as 1280x1024 (I don't know why because earlier it was running fine at 1920x1080).

I have been trying to look for any possible help to rectify these issues but none have worked. It is really frustrating to not be able to rectify these petty issues. The issues are summarized as follows:

1. Cannot seem to find a way to change splash screen to default plymouth theme after Nvidia drivers installation.
2. GRUB resolution won't change no matter what I write in the config file.
3. GRUB menu terminal says, "Can't find command" for the following syntax - vbeinfo, videoinfo during boot up.

Note: Secure boot is disabled and I have a dual boot system (Windows 10 and Fedora 29) both installed as UEFI platforms.

I am very desperate to solve this problem as it is driving me crazy and would really really appreciate any help regarding this issue.

Thanking in advance.