Inspiron 17 7000 - Fedora gets "No bootable devices found"
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 4 of 4
  1. #1
    Join Date
    Feb 2019
    Location
    California
    Posts
    1
    Mac OS X 10.14.2 Chrome 71.0.3578.98

    Inspiron 17 7000 - Fedora gets "No bootable devices found"

    Just got the brand new Dell Inspiron 7786 (2-in-1) (17 incher) with an empty disk.

    For work and development I wanted to Install Fedora 29 linux. After running a live version I came to conclusion that the distro is perfect for the system (wifi, bluetooth, touchscreen, etc).

    Partitioning Setup before install
    Click image for larger version. 

Name:	IMG_6241.jpg 
Views:	7 
Size:	64.0 KB 
ID:	30055

    Partitioning Setup after install
    Click image for larger version. 

Name:	Screenshot from 2019-02-06 18-59-30.png 
Views:	9 
Size:	91.3 KB 
ID:	30056

    When I'm trying to boot, I get "No bootable devices found".
    Click image for larger version. 

Name:	IMG_6246.jpg 
Views:	8 
Size:	63.7 KB 
ID:	30057
    Click image for larger version. 

Name:	IMG_6245.jpg 
Views:	5 
Size:	68.4 KB 
ID:	30058
    F12 menu shows this thing ^^^

    Click image for larger version. 

Name:	IMG_6243.jpg 
Views:	6 
Size:	96.5 KB 
ID:	30059

    UEFI Options do now show any boot options...

    Tried to install Ubuntu, but had the same issues... Looks like there is a bootable partition on the Linux side, but it is not seen by the BIOS.

    If anybody could provide some help or tips in the right direction, I would really appreciate. I haven't used PC's for like 12 years and returning from Mac (not really returning, but expanding back to Linux)... Do I need to install GRUB? Isn't installed by default (used to be at least about 7-9 years ago)?

    PS. I'm planning to run Linux by itself without any dual-boot options, etc.


    Pavel

  2. #2
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    6,799
    Linux Firefox 65.0

    Re: Inspiron 17 7000 - Fedora gets "No bootable devices found"

    enable legacy boot if your Dell allows it or start again with a GPT layout. your system is EFI so is looking for an EFI partition which you don't currently have with the nvme setup in MBR mode.

  3. #3
    Join Date
    Feb 2018
    Location
    Terra
    Posts
    19
    Linux (Fedora) Chrome 72.0.3626.81

    Re: Inspiron 17 7000 - Fedora gets "No bootable devices found"

    I agree with antikythera: You are missing an EFI partition. Be aware, that the good old times of a master boot record and Bios are over. Today we have EFI and Secure Boot. You can, to make your setup working, turn on legacy booting. But I would recommend, reinstalling and letting the setup tool do the partitioning. This way you can later enjoy the blessings of secure boot. ;-) I'd also recommend to turn on encryption of your LVM, to protext your data if your Laptop is stolen.

    Attached are two screenshots of how the standard partition layout of Fedora 29 looks if you have EFI on and chose to encrypt your data.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	EFI1.png 
Views:	6 
Size:	38.3 KB 
ID:	30061   Click image for larger version. 

Name:	EFI2.png 
Views:	5 
Size:	40.2 KB 
ID:	30062  

  4. #4
    Join Date
    Jul 2005
    Posts
    946
    Windows NT 10.0 Firefox 64.0

    Re: Inspiron 17 7000 - Fedora gets "No bootable devices found"

    Also, if there is a bios setting for Sata Operation, set it to AHCI not RAID and see if that helps.
    ======
    Doug G
    ======

Similar Threads

  1. Can't access "lost+found" or "root" in "Computer" directory
    By jeb3121 in forum Installation, Upgrades and Live Media
    Replies: 5
    Last Post: 27th November 2013, 04:36 PM
  2. "No Bootable device found" after installing F11
    By fuser in forum Installation, Upgrades and Live Media
    Replies: 4
    Last Post: 16th June 2009, 06:06 PM
  3. "no valid devices found"
    By originality in forum Installation, Upgrades and Live Media
    Replies: 0
    Last Post: 28th November 2008, 05:11 PM
  4. Fedora 5 "no valid devices were found...."
    By sketchmasterx in forum Installation, Upgrades and Live Media
    Replies: 3
    Last Post: 19th April 2006, 02:55 PM
  5. Replies: 4
    Last Post: 12th May 2004, 11:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •