[SOLVED] FC29 - HPLip woes
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 2 of 2
  1. #1
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    1,087
    Linux (Fedora) Firefox 65.0

    FC29 - HPLip woes

    Hello guys,

    just FRESH-installed FC29 in a semi-new laptop for my wife, and I can't get Xsane to work with the HP MFP 1522 I have. It works perfectly fine in all my other comps here at home.

    Basically, after installing hplip, and hplip-gui, and running "hp-setup", I can see the printer connected on the Network, and it goes ahead and downloads the plugin, asks me to click on the licence Agreement, and it says Success.
    Click image for larger version. 

Name:	Screenshot_2019-02-06_13-31-44.png 
Views:	1 
Size:	35.6 KB 
ID:	30043

    However, after clicking on OK, I get this:
    Click image for larger version. 

Name:	Screenshot_2019-02-06_13-32-11.jpg 
Views:	3 
Size:	145.7 KB 
ID:	30044

    If I go into the CUPS management, and I set up the Printer, it works fine in cups:
    Click image for larger version. 

Name:	Screenshot_2019-02-06_13-18-46.png 
Views:	3 
Size:	106.5 KB 
ID:	30045

    However, that only works well for Printing.
    When I try to use Xsane to scan something, it does not find the "scanner" (which is the same as the Printer).
    Click image for larger version. 

Name:	Screenshot_2019-02-06_13-19-28.png 
Views:	2 
Size:	33.6 KB 
ID:	30046

    And the HP Device Manager stays empty.
    Click image for larger version. 

Name:	Screenshot_2019-02-06_13-24-00.png 
Views:	2 
Size:	72.2 KB 
ID:	30047

    Any clues guys ?
    If I run "hp-plugin" from the command line, it says all is successful, however, the Device list stays empty.
    Even after successive reboots. Cups is fine, but not the HP device manager, which makes this unable to scan.
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

  2. #2
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    1,087
    Linux (Fedora) Firefox 65.0

    Re: FC29 - HPLip woes

    W000h0000

    solved it, it was a bloody nightmare, but it's done.
    The KEY to the whole connundrum is that HPlip asks you to install the system as a specific user, not as root. And even though the user I used was set up as an "Administrator", the hp-setup program could not access the PPD files in the /etc/cups/ppd/ folder.
    It actually downloads and writes the files there (obviously using sudo), however when trying to read those files , it fails as a regular user. LOL.

    In my case I actually had to go to hplipopensource.com, download the newest 3.19... package, run the thing manually, it destroyed everything, but after like 30 mins of cursing, I found something called "Diagnose Driver" in the HP device manager. And somehow, I was able to get a message that it could not read the ppd's. Once I corrected this:
    Click image for larger version. 

Name:	Screenshot_2019-02-06_14-22-41.png 
Views:	6 
Size:	148.2 KB 
ID:	30048
    Click image for larger version. 

Name:	Screenshot_2019-02-06_14-23-31.png 
Views:	4 
Size:	137.4 KB 
ID:	30049

    And re-ran everything, I was able to finally get a proper Queue:
    Click image for larger version. 

Name:	Screenshot_2019-02-06_14-26-58.png 
Views:	6 
Size:	183.3 KB 
ID:	30050

    and then Xsane finally started:
    Click image for larger version. 

Name:	Screenshot_2019-02-06_14-27-44.jpg 
Views:	4 
Size:	161.6 KB 
ID:	30051

    It's time for a well deserved
    Click image for larger version. 

Name:	20190122_155253.jpg 
Views:	5 
Size:	133.8 KB 
ID:	30052
    (not my favorite, but it'll do, and it's imported straight from source)
    Last edited by bobx001; 6th February 2019 at 04:00 PM.
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

Similar Threads

  1. Kernel 4.19.15-300.fc29 broke bluetooth HIDP
    By pstrang in forum Hardware & Laptops
    Replies: 7
    Last Post: 29th January 2019, 06:52 PM
  2. [FC29] no sound from a generic usb headset
    By wodel in forum Hardware & Laptops
    Replies: 1
    Last Post: 2nd January 2019, 03:09 PM
  3. [SOLVED]
    F29 (4.18.16-300.fc29.x86_64, Workstation): NFS fails
    By ThumbTack in forum Servers & Networking
    Replies: 4
    Last Post: 15th November 2018, 09:46 AM
  4. [SOLVED]
    [FC29] Upgrade 28 -> 29 SELinux alrert
    By Ex_Soft in forum Installation, Upgrades and Live Media
    Replies: 1
    Last Post: 7th November 2018, 06:49 AM
  5. hplip, SELinux and cups woes
    By DoubleVision in forum Using Fedora
    Replies: 2
    Last Post: 20th July 2008, 06:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •