Fedora 29 - system going into suspend itself
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 11 of 11
  1. #1
    Join Date
    Feb 2018
    Location
    Ireland
    Posts
    7
    Linux Firefox 60.0

    Fedora 29 - system going into suspend itself

    Hi Guys,

    I just notice this issue few days ago, system going into suspend after some time. I did not check what is the time period, but I'm sure I turn off all suspend action for both (battery/power source). Double checked all power settings etc. Not sure what else I can do

    And what is more annoying is, to restore system I need to do alt+ctrl+F1 or any other F. Usually I could press power button and was fine.

    Regards

  2. #2
    Join Date
    Feb 2005
    Location
    London, UK
    Posts
    811
    Linux (Fedora) Chrome 71.0.3578.98

    Re: Fedora 29 - system going into suspend itself

    Do you use xscreensaver? I had a similar issue and resolved it by running xscreensaver-demo and turning off the power management and quick off option in the advanced tab.

  3. #3
    Join Date
    Feb 2018
    Location
    Ireland
    Posts
    7
    Linux Firefox 60.0

    Re: Fedora 29 - system going into suspend itself

    @HaydnH

    Good point I will check this tonight. Thank you.

  4. #4
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    1,087
    Linux (Fedora) Firefox 65.0

    Re: Fedora 29 - system going into suspend itself

    Also check: systemctl status upower

    and post findings. You may want to also disable it temporarily, i.e. systemctl stop upower, and see if it goes into Suspend after doing that.
    Question, is that a laptop ?
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

  5. #5
    Join Date
    Feb 2018
    Location
    Ireland
    Posts
    7
    Linux (Fedora) Firefox 65.0

    Re: Fedora 29 - system going into suspend itself

    Hi Guys, sorry for delay but just have some time for test,

    So, in xscreensaver-demo I turned off all. I mean xscreensaver was disabled, and after the same period of time system went to suspend.

    About second oprtion:
    systemctl status upower is active (running) do I disabled and double check if it's really -> Active: inactive (dead)

    after about some time I check and system went to suspend again. I was only bring it back by ctr+alt+Fx
    After that I check and status was Active: active (running)

    Not sure what else I can test

  6. #6
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    1,087
    Linux (Fedora) Firefox 65.0

    Re: Fedora 29 - system going into suspend itself

    hmmm, so something is turning on your upower, maybe logind ? or upower just re-enabled itself ater the Resume.
    can you do
    cat /etc/systemd/logind.conf
    and post it here ?

    also, if you switch out of GUI, i.e. press CTRL-ALT-F3 , and log in as root in the console, and just leave it there, does it still go into suspend ?
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

  7. #7
    Join Date
    Aug 2011
    Location
    Minnesota
    Posts
    655
    Linux Chrome 72.0.3626.96

    Re: Fedora 29 - system going into suspend itself

    Looks at your power management settings.
    Fedora 29 x86_64 on Vertex IV SSD / Inland SSD || Gigabyte B450 AORUS M || AMD Ryzen 2600 || AORUS Radeon™ RX570 4G || 16 GB DDR4-3200 || Emachines T5452 carcass
    Fedora 28 x84_64 on 500GB Seagate Barracuda

  8. #8
    Join Date
    Feb 2018
    Location
    Ireland
    Posts
    7
    Linux (Fedora) Firefox 65.0

    Re: Fedora 29 - system going into suspend itself

    [karcio@localhost ~]$ cat /etc/systemd/logind.conf
    # This file is part of systemd.
    #
    # systemd is free software; you can redistribute it and/or modify it
    # under the terms of the GNU Lesser General Public License as published by
    # the Free Software Foundation; either version 2.1 of the License, or
    # (at your option) any later version.
    #
    # Entries in this file show the compile time defaults.
    # You can change settings by editing this file.
    # Defaults can be restored by simply deleting this file.
    #
    # See logind.conf(5) for details.

    [Login]
    #NAutoVTs=6
    #ReserveVT=6
    #KillUserProcesses=no
    #KillOnlyUsers=
    #KillExcludeUsers=root
    #InhibitDelayMaxSec=5
    #HandlePowerKey=poweroff
    #HandleSuspendKey=suspend
    #HandleHibernateKey=hibernate
    #HandleLidSwitch=suspend
    #HandleLidSwitchExternalPower=suspend
    #HandleLidSwitchDocked=ignore
    #PowerKeyIgnoreInhibited=no
    #SuspendKeyIgnoreInhibited=no
    #HibernateKeyIgnoreInhibited=no
    #LidSwitchIgnoreInhibited=yes
    #HoldoffTimeoutSec=30s
    #IdleAction=ignore
    #IdleActionSec=30min
    #RuntimeDirectorySize=10%
    #RemoveIPC=yes
    #InhibitorsMax=8192
    #SessionsMax=8192
    [karcio@localhost ~]$

  9. #9
    Join Date
    Feb 2018
    Location
    Ireland
    Posts
    7
    iOS  12.1.4 (iPhone) Safari 12.0

    Re: Fedora 29 - system going into suspend itself

    Checking switch GUI with root now

  10. #10
    Join Date
    Feb 2018
    Location
    Ireland
    Posts
    7
    Linux (Fedora) Firefox 65.0

    Re: Fedora 29 - system going into suspend itself

    Quote Originally Posted by bobx001
    also, if you switch out of GUI, i.e. press CTRL-ALT-F3 , and log in as root in the console, and just leave it there, does it still go into suspend ?
    No, it does not, I can leave for long time and does not go to suspend

  11. #11
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    1,087
    Linux (Fedora) Firefox 65.0

    Re: Fedora 29 - system going into suspend itself

    Interestingly, I have a small problem myself, which maybe related to this in some way, but then again, it may not be.
    I just fresh-installed FC29 in my wife's laptop (in a new SSD), and I am running LXDM-Xfce there.

    She usually shuts the machine off at night, and boots it up every day in the morning.
    What I have seen is that the Power Manager settings are *not* working, UNLESS, I actually go into the Dialog Box, and set my behaviour "again".
    i.e. I want her Display to switch off after say 3 to 5 mins of inactivity. Like so:
    Click image for larger version. 

Name:	Power_Management_Failure_Screenshot_2019-02-10_20-58-31.png 
Views:	4 
Size:	168.4 KB 
ID:	30072

    If I open this dialog, change the time, and close it, voilla , it works.

    However, if she boots up, logs in, and never touches that dialog box, then it does not work. The Display stays on forever....
    Maybe someone has seen this here ? or maybe I should open a new topic about it.

    I don't know if this is related to your issue, however, I am suspecting the "upowerd" in both cases.
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

Similar Threads

  1. Suspend always in system menu
    By theking2 in forum Using Fedora
    Replies: 3
    Last Post: 15th February 2014, 09:14 AM
  2. System not responsive after resuming from suspend
    By MuadNu in forum Hardware & Laptops
    Replies: 0
    Last Post: 12th September 2010, 11:50 PM
  3. Replies: 0
    Last Post: 11th December 2009, 08:42 AM
  4. System cannot come back from suspend
    By markrobt in forum Hardware & Laptops
    Replies: 3
    Last Post: 13th October 2008, 05:44 AM
  5. Waking up system from suspend
    By john.mahaffey in forum Using Fedora
    Replies: 1
    Last Post: 17th January 2007, 05:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •