I don't fully know what I'm doing, but I have been able to get USB images to boot easily in the past.

I'm trying to get SystemRescueCD burned to a USB stick. I'm trying two 16G flash drives. Both had just been working fine and booting OS images. I've tried booting from two different computers. Secure Boot is turned off, legacy on with USB as the first device to boot to. The OS (.img) image is fine as I was able to run it in Gnome Boxes with no issue.

I tried formatting the sticks to fat32 both with GParted and via the command line (mkfs.msdos -F 32 /dev/sdc). I've tried several different OS images.

I've been using the following command:


Here is the command I've been issuing:

# umount /dev/sdb
# dd if=systemrescuecd-x86-5.3.2.iso of=/dev/sdb status=progress

The output is:

109560320 bytes (110 MB, 104 MiB) copied, 7 s, 15.7 MB/125579776 bytes (126 MB, 120 MiB) copied, 8 s, 15.7 MB/141795840 bytes (142 MB, 135 MiB) copied, 9 s, 15.8 MB/157569536 bytes (158 MB, 150 MiB) copied, 10 s, 15.8 MB170390016 bytes (170 MB, 162 MiB) copied, 11 s, 15.5 MB182006272 bytes (182 MB, 174 MiB) copied, 12 s, 15.2 MB193528320 bytes (194 MB, 185 MiB) copied, 13 s, 14.9 MB205296128 bytes (205 MB, 196 MiB) copied, 14 s, 14.7 MB217084416 bytes (217 MB, 207 MiB) copied, 15 s, 14.5 MB228835840 bytes (229 MB, 218 MiB) copied, 16 s, 14.3 MB240427520 bytes (240 MB, 229 MiB) copied, 17 s, 14.1 MB252277248 bytes (252 MB, 241 MiB) copied, 18 s, 14.0 MB264004096 bytes (264 MB, 252 MiB) copied, 19 s, 13.9 MB275866112 bytes (276 MB, 263 MiB) copied, 20 s, 13.8 MB288256512 bytes (288 MB, 275 MiB) copied, 21 s, 13.7 MB300208640 bytes (300 MB, 286 MiB) copied, 22 s, 13.6 MB310985216 bytes (311 MB, 297 MiB) copied, 23 s, 13.5 MB322765312 bytes (323 MB, 308 MiB) copied, 24 s, 13.4 MB335180288 bytes (335 MB, 320 MiB) copied, 25 s, 13.4 MB347271680 bytes (347 MB, 331 MiB) copied, 26 s, 13.4 MB360022528 bytes (360 MB, 343 MiB) copied, 27 s, 13.3 MB371331584 bytes (371 MB, 354 MiB) copied, 28 s, 13.3 MB383046144 bytes (383 MB, 365 MiB) copied, 29 s, 13.2 MB394789376 bytes (395 MB, 377 MiB) copied, 30 s, 13.2 MB406454784 bytes (406 MB, 388 MiB) copied, 31 s, 13.1 MB418165248 bytes (418 MB, 399 MiB) copied, 32 s, 13.1 MB430133760 bytes (430 MB, 410 MiB) copied, 33 s, 13.0 MB442204672 bytes (442 MB, 422 MiB) copied, 34 s, 13.0 MB453984768 bytes (454 MB, 433 MiB) copied, 35 s, 13.0 MB465494528 bytes (465 MB, 444 MiB) copied, 36 s, 12.9 MB477434368 bytes (477 MB, 455 MiB) copied, 37 s, 12.9 MB488604160 bytes (489 MB, 466 MiB) copied, 38 s, 12.9 MB500081152 bytes (500 MB, 477 MiB) copied, 39 s, 12.8 MB511562240 bytes (512 MB, 488 MiB) copied, 40 s, 12.8 MB523067904 bytes (523 MB, 499 MiB) copied, 41 s, 12.8 MB535024128 bytes (535 MB, 510 MiB) copied, 42 s, 12.7 MB546980352 bytes (547 MB, 522 MiB) copied, 43 s, 12.7 MB558133760 bytes (558 MB, 532 MiB) copied, 44 s, 12.7 MB569418240 bytes (569 MB, 543 MiB) copied, 45 s, 12.7 MB581554688 bytes (582 MB, 555 MiB) copied, 46 s, 12.6 MB/s
1144376+0 records in
1144376+0 records out
585920512 bytes (586 MB, 559 MiB) copied, 147.179 s, 4.0 MB/s

Strangely, the dd program starts at 110 MB right at the beginning. Not sure why.

When I try to boot the USB, the computer prints out:

No boot device found. Press any key to reboot the machine.

Both computers cannot boot both USB sticks. I've tried zeroing them out using:

dd bs=12M if=/dev/zero of=/dev/sdb status=progress

I followed both tutorials here:

https://www.maketecheasier.com/repai...b-drive-linux/

https://www.lifewire.com/fix-a-broke...-linux-4116970

Any ideas?