[SOLVED] Can't login to KDE Plasma
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 4 of 4
  1. #1
    Join Date
    Apr 2011
    Posts
    86
    Linux (Fedora) Firefox 64.0

    Can't login to KDE Plasma

    Hi,
    Since a few days I can't log in to the KDE plasma workspace, more precisely after a "dnf update". Also sddm greeter is behaving in a weird way. This is exactly what happens:
    - The sddm greeter complains about modules not being installed (org.kde.plasma.core, org.kde.plasma.extras, ...)
    - After typing my password everything seems to be OK but at the end I get a black screen with a mouse pointer and nothing else.

    Things I've tried for solving it based on my search on the web:
    - To reinstall the whole @kde-desktop-environment
    - To move a few hide directories (.cache .kde .config .local) for generating new ones on next login
    - To create a new user account and making sddm to autolog to this account

    Nothing changed.

    Any ideas will be appreciated. Thank you very much in advance!

  2. #2
    Join Date
    Aug 2007
    Posts
    315
    Linux (Fedora) Firefox 61.0

    Re: Can't login to KDE Plasma

    You could try booting into text mode (runlevel 3) multi-user.target without using sddm and using startx to start the GUI.

  3. #3
    Join Date
    Apr 2011
    Posts
    86
    Linux (Fedora) Firefox 64.0

    Re: Can't login to KDE Plasma

    Quote Originally Posted by amiga
    You could try booting into text mode (runlevel 3) multi-user.target without using sddm and using startx to start the GUI.
    Thank you for your advice! I did it but I still can't start KDE, the good new is at least I can use LXDE as a GUI. Is there a log I should check for getting more information about the cause of the problem?

  4. #4
    Join Date
    Apr 2011
    Posts
    86
    Linux (Fedora) Firefox 64.0

    Re: Can't login to KDE Plasma

    I found useful information with journalctl, then I realized there was a versions conflict between "freeworld" and regular Fedora packages which made the last update to be incomplete. i solved the dependencies problem by using "--best --allowerasing" flags and then I should to reinstall several KDE and plasma components. KDE works again!

Similar Threads

  1. [SOLVED]
    Plasma 5.14.x in F29 Soon? Or Ever?
    By Cygnia in forum Fedora Spins & Remixes
    Replies: 3
    Last Post: 9th December 2018, 12:22 AM
  2. KDE Plasma: Cannot login into 2nd user with sddm
    By Bequimao in forum Using Fedora
    Replies: 2
    Last Post: 12th September 2017, 03:51 PM
  3. Plasma 5
    By shmouftler in forum Rawhide
    Replies: 1
    Last Post: 14th July 2016, 08:16 AM
  4. Fedora 17 x86_64 Plasma Crash on Login
    By bharris in forum Using Fedora
    Replies: 2
    Last Post: 4th May 2013, 04:53 AM
  5. after upgrade to F8 only X-login, but failing to login, returns to login screen
    By angro in forum Installation, Upgrades and Live Media
    Replies: 1
    Last Post: 26th November 2007, 09:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •