Bumblebee unable to start discrete graphics card on Fedora 29
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    Jan 2019
    Location
    Scotland
    Posts
    1
    Linux (Fedora) Firefox 64.0

    Bumblebee unable to start discrete graphics card on Fedora 29

    As the title says I'm having issues getting Bumblebee working with Fedora 29 on my laptop.

    My laptop is a Dell G5 and I've followed the setup instructions for Bumblebee and completed them without much issue.

    However when I try to test it it seems that the dedicated card is not accessible:

    primusrun glxspheres

    Code:
    /usr/bin/primusrun: line 45: exec: glxspheres: not found

    I've been doing a lot of digging for this and I did find one thread with someone describing the same symptoms I'm seeing albeit it not for Fedora, as such the solution they came up with is not useable for me as unless I'm mistaken F29 doesn't use TLP.

    Output from the diagnostics I've run are below, they are mostly from advice in the linked thread.

    A check to make sure Bumblebee is loading correctly.

    systemctl status bumblebeed

    Code:
    ● bumblebeed.service - Bumblebee C Daemon
       Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor preset: disabled)
       Active: active (running) since Tue 2019-01-01 15:46:40 GMT; 3h 52min ago
     Main PID: 915 (bumblebeed)
        Tasks: 1 (limit: 4915)
       Memory: 2.4M
       CGroup: /system.slice/bumblebeed.service
               └─915 /usr/sbin/bumblebeed
    
    Jan 01 15:46:40 localhost.localdomain systemd[1]: Started Bumblebee C Daemon.
    Jan 01 15:46:40 localhost.localdomain bumblebeed[915]: [    6.438085] [INFO]/usr/sbin/bumblebeed 3.2.1 s>
    Jan 01 15:56:55 localhost.localdomain bumblebeed[915]: [  621.067712] [ERROR]Could not enable discrete g>
    Jan 01 16:13:52 localhost.localdomain bumblebeed[915]: [ 1638.032344] [ERROR]Could not enable discrete g>
    Jan 01 16:23:02 localhost.localdomain bumblebeed[915]: [ 2188.698027] [ERROR]Could not enable discrete g>
    Jan 01 16:31:05 localhost.localdomain bumblebeed[915]: [ 2670.951348] [ERROR]Could not enable discrete g>
    lines 1-15/15 (END)

    A check to make sure Nvidia is disabled by default.

    cat /proc/acpi/bbswitch

    Code:
    0000:01:00.0 OFF

    A check of the kernel buffer for bbswitch

    dmesg | grep bbswitch

    Code:
    [    6.435292] bbswitch: loading out-of-tree module taints kernel.
    [    6.435321] bbswitch: module verification failed: signature and/or required key missing - tainting kernel
    [    6.435499] bbswitch: version 0.8
    [    6.435558] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
    [    6.435564] bbswitch: Found discrete VGA device 0000:01:00.0: \_SB_.PCI0.PEG0.PEGP
    [    6.435616] bbswitch: detected an Optimus _DSM function
    [    6.435686] bbswitch: Succesfully loaded. Discrete card 0000:01:00.0 is on
    [    6.437847] bbswitch: disabling discrete graphics
    [  620.459914] bbswitch: enabling discrete graphics
    [ 1637.691445] bbswitch: enabling discrete graphics
    [ 2188.356265] bbswitch: enabling discrete graphics
    [ 2670.608766] bbswitch: enabling discrete graphics
    [ 9175.342692] bbswitch: enabling discrete graphics

    The output from optirun when it fails.

    optirun -v glxgears

    Code:
    [ 9967.259227] [INFO]Response: No - error: Could not enable discrete graphics card
    
    [ 9967.259281] [ERROR]Cannot access secondary GPU - error: Could not enable discrete graphics card
    
    [ 9967.259313] [ERROR]Aborting because fallback start is disabled.

    And just in case I'm going mad a check to mke sure I definitely have a GPU.

    lspci | grep -E "VGA|3D"

    Code:
    00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile)
    01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] (rev ff)

    Has anyone faced similar problems to this? Or is there anything else I can try to find a solution?

    I also had some issues after install where the OS was freezing after login, I managed to resolve it by following the guidance here.

    Thanks in advance for any help you can give, also apologies if it takes me a bit to respond to any requests, we have a two month old so finding time to work on my laptop is a rare thing.

  2. #2
    Join Date
    Apr 2009
    Location
    central NY, USA
    Posts
    1,181
    Linux Firefox 60.0

    Re: Bumblebee unable to start discrete graphics card on Fedora 29

    Again - I run CentOS 7 (circa Fedora 19-ish with updates), so my Fedora help may turn out to be not helpful at all

    I have a G3. Bumblebee for me was the second half of my video drivers issue, after the install of the correct Nvidia drivers (kmod-nvidia). As I understand it, Bumblebee works with the Nvidia drivers to decide when/how to switch between the Nvidia/Intel cards. Until a recent CentOS kernel update, it worked perfectly. That recent CentOS kernel update 'picked up' the whole video issue and negated any need for the Nvidia and Bumblebee drivers which I've now disabled.

    I told you that to tell you this:

    Here's my "help" call on the CentOS forum, including the bumblebee config settings that got it working for me.

    https://www.centos.org/forums/viewto...p?f=47&t=68130

    My problem turned out to be that my G3 was newer than the kernel - until the update. Always a "danger" when buying new technology. I had NO wireless until the kernel update as well.

    P.S. Love the G3, my network 'toolbox' !
    Change - the only constant.

  3. #3
    Join Date
    Jan 2019
    Location
    Los Angeles
    Posts
    3
    Windows 7 Firefox 64.0

    Re: Bumblebee unable to start discrete graphics card on Fedora 29

    It's interesting information.

Similar Threads

  1. F24 bumblebee don't detect intelHD graphics
    By nprog89 in forum Hardware & Laptops
    Replies: 5
    Last Post: 28th September 2016, 10:47 AM
  2. Cannot reach discrete card on Asus N56VJ
    By twohot in forum Hardware & Laptops
    Replies: 1
    Last Post: 26th December 2013, 01:33 AM
  3. Fedora 19 installation hangs - Nvidia discrete graphics.
    By PiElle in forum Installation, Upgrades and Live Media
    Replies: 3
    Last Post: 9th July 2013, 10:26 PM
  4. [Hybrid Graphics] How to turn off discrete gpu using acpi_call via graphic interface
    By marcoDallas in forum Guides & Solutions (Not For Questions)
    Replies: 4
    Last Post: 5th May 2013, 07:57 PM
  5. [SOLVED]
    Disable nVidia Optimus discrete card
    By joseph1802 in forum Hardware & Laptops
    Replies: 1
    Last Post: 29th December 2012, 10:19 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •