package mariadb-connector-c-3.0.2-15.fc27.x86_64 requires mariadb-libs
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 5 of 5
  1. #1
    Join Date
    Mar 2011
    Posts
    90
    Linux (Fedora) Firefox 63.0

    package mariadb-connector-c-3.0.2-15.fc27.x86_64 requires mariadb-libs

    Hi,

    Code:
    #dnf upgrade --refresh
    returns

    Code:
     Problem: package mariadb-connector-c-3.0.2-15.fc27.x86_64 requires mariadb-libs, but none of the providers can be installed
      - installed package mysql-community-libs-compat-5.7.22-1.fc26.x86_64 obsoletes mariadb-libs provided by mariadb-libs-3:10.2.19-1.fc27.i686
      - installed package mysql-community-libs-compat-5.7.22-1.fc26.x86_64 obsoletes mariadb-libs provided by mariadb-libs-3:10.2.19-1.fc27.x86_64
      - installed package mysql-community-libs-compat-5.7.22-1.fc26.x86_64 obsoletes mariadb-libs provided by mariadb-libs-3:10.2.9-3.fc27.i686
      - installed package mysql-community-libs-compat-5.7.22-1.fc26.x86_64 obsoletes mariadb-libs provided by mariadb-libs-3:10.2.9-3.fc27.x86_64
      - cannot install the best update candidate for package mariadb-connector-c-3.0.2-4.fc27.x86_64
      - problem with installed package mysql-community-libs-compat-5.7.22-1.fc26.x86_64
    what does it mean? do I need to fix anything?
    As far as I have checked, I may access databases
    Thanks
    mario

  2. #2
    Join Date
    Oct 2011
    Posts
    1,907
    Linux Chrome 69.0.3497.100

    Re: package mariadb-connector-c-3.0.2-15.fc27.x86_64 requires mariadb-libs

    Hmm weird, I cant't find that particular package anywhere, where does it come from?

    Code:
    $ sudo dnf list installed mysql-community-libs-compat

  3. #3
    Join Date
    Apr 2009
    Location
    central NY, USA
    Posts
    1,181
    Linux Firefox 60.0

    Re: package mariadb-connector-c-3.0.2-15.fc27.x86_64 requires mariadb-libs

    While I run CentOS, I had to disable the mysql-community repos - they just messed up a lot of stuff all the time!

    I then switched from workbench to phpMyAdmin through the repos and it works beautifully.
    Change - the only constant.

  4. #4
    Join Date
    Mar 2011
    Posts
    90
    Linux (Fedora) Firefox 64.0

    Re: package mariadb-connector-c-3.0.2-15.fc27.x86_64 requires mariadb-libs

    Hi
    I upgraded up to F29.
    dnf upgrade --refresh does not return any msg. Issues solved somehow. Thanks, sorry for your time.
    I use both workbench and phpMyAdmin.
    greetings
    mario

    ps
    # dnf info mysql-community-libs-compat
    Last metadata expiration check: 0:03:15 ago on Wed 02 Jan 2019 03:38:04 PM CET.
    Installed Packages
    Name : mysql-community-libs-compat
    Version : 5.7.22
    Release : 1.fc26
    Arch : x86_64
    Size : 9.6 M
    Source : mysql-community-5.7.22-1.fc26.src.rpm
    Repo : @System
    From repo : mysql57-community
    Summary : Shared compat libraries for MySQL 5.6.37 database client applications
    URL : http://www.mysql.com/
    License : Copyright (c) 2000, 2018, Oracle and/or its affiliates. All rights reserved. Under GPLv2 license as shown in the Description field.
    Description : This package contains the shared compat libraries for MySQL 5.6.37 client
    : applications.
    how do I update it to F29? should I?

  5. #5
    Join Date
    Oct 2014
    Location
    Texas, USA
    Posts
    65
    Linux (Fedora) Chrome 71.0.3578.98

    Re: package mariadb-connector-c-3.0.2-15.fc27.x86_64 requires mariadb-libs

    Quote Originally Posted by mario960
    Hi
    I upgraded up to F29.
    dnf upgrade --refresh does not return any msg. Issues solved somehow. Thanks, sorry for your time.
    I use both workbench and phpMyAdmin.
    greetings
    mario

    ps

    how do I update it to F29? should I?
    I wouldn't update mysql packages unless absolutely necessary. mariadb-libs should take care of the needed libraries.
    You might try uninstalling mysql-community and all its dependencies to see if it breaks mariadb, but I have no problems with mariadb and have never enabled the mysql-community repo nor installed any packages from it.
    If I remember correctly that repo and those packages were an attempt to keep mysql active and mainstream when fedora switched to mariadb.

Similar Threads

  1. fedora 28 - old version of mysql connector - mariadb-compat
    By tonypmartin in forum Installation, Upgrades and Live Media
    Replies: 2
    Last Post: 25th May 2018, 06:14 AM
  2. mariadb-gssapi-server-3:10.2.14-1.fc27.x86_64 conflicts
    By TNWestTex in forum Installation, Upgrades and Live Media
    Replies: 0
    Last Post: 6th April 2018, 01:44 AM
  3. MariaDB question
    By JuanKman94 in forum Programming & Packaging
    Replies: 3
    Last Post: 8th July 2013, 02:28 AM
  4. MariaDB + mysql-libs Conflict
    By dolphinaura in forum Using Fedora
    Replies: 2
    Last Post: 12th September 2012, 11:50 PM
  5. perl-Video-DVDRip.x86_64 requires 32bit libs?
    By neekofab in forum Using Fedora
    Replies: 14
    Last Post: 22nd August 2005, 11:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •