Hello all,

I have a clean install of F29 XFCE. I configured power management to Suspend after 15 minutes. It did, but I couldn't get the system to wake up by simply pressing a key on the USB keyboard.

I fixed that by creating /etc/udev/rules.d/90-mcewakeup.rules and adding the following:
Code:
SUBSYSTEM=="usb", ATTRS{idVendor}=="046d", ATTRS{idProduct}=="c30a" RUN+="/bin/sh -c 'echo enabled > /sys$env{DEVPATH}/../power/wakeup'"[
I found the idVendor and idProduct of my wired keyboard in lsusb.

Code:
Bus 002 Device 002: ID 0bda:0151 Realtek Semiconductor Corp. Mass Storage Device (Multicard Reader)
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 003: ID 03f0:094a HP, Inc Optical Mouse [672662-001]
Bus 008 Device 002: ID 046d:c30a Logitech, Inc. iTouch Composite
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 1737:0077 Linksys WUSB54GC v3 802.11g Adapter [Ralink RT2070L]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
So that works! I tested the configuration by waiting 15 minutes to watch the computer suspend, indicated on this old Dell by blinking the power button on the front panel. I press a key on the keyboard after the computer is suspended, and it wakes up just fine.

All worked, until it suspends for a long period of time. It won't wake up at all in the morning. The keyboard won't wake it up. The power button on the front panel is still blinking, indicating it's suspended. The only way to turn it back on is to press the power button.

The optical light on the USB mouse goes on. The Caps/Num lock lights do not, nor do they go on or off when I press caps or num lock. The only thing I can do is press and hold the power button to power off, and then power it up again.

The I looked at the BIOS settings. ACPI suspend type was set to S3 (STR). I tried switching it to S1 (POS) but the computer never shuts off. It basically just blanks the screen. So I switched it back.

I did some more digging, and tried adding the following to /etc/default/grub
Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1 acpi_enforce_resources=lax"
Code:
grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg
Now it can wake from the keyboard, but the screen never comes back on.

So I’m stuck with a system that will suspend, and if I wake it up inside of some unknown timeframe, it works fine. After some unknown timeframe, and it won’t boot up correctly. It doesn’t seem to be hibernating, as the button is still blinking, indicating (I believe) that the system is still suspended.

I’d appreciate any input, or ideas of places to look. Thanks in advance!