[SOLVED] I have update conflicts, what I have to do ?
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 11 of 11
  1. #1
    Join Date
    Aug 2016
    Location
    Iraq
    Posts
    966
    Linux (Fedora) Firefox 64.0

    I have update conflicts, what I have to do ?

    Hi.
    I have a conflicts in update of my system:

    Code:
    sudo dnf upgrade
    Last metadata expiration check: 0:05:43 ago on Thu 20 Dec 2018 04:32:48 AM GMT.
    Dependencies resolved.
    
     Problem 1: cannot install the best update candidate for package hplip-3.18.6-10.fc28.x86_64
      - nothing provides libnetsnmp.so.35()(64bit) needed by hplip-3.18.6-11.fc28.x86_64
     Problem 2: cannot install the best update candidate for package hplip-libs-3.18.6-10.fc28.x86_64
      - nothing provides libnetsnmp.so.35()(64bit) needed by hplip-libs-3.18.6-11.fc28.x86_64
     Problem 3: cannot install the best update candidate for package libsane-hpaio-3.18.6-10.fc28.x86_64
      - nothing provides libnetsnmp.so.35()(64bit) needed by libsane-hpaio-3.18.6-11.fc28.x86_64
     Problem 4: package hplip-gui-3.18.6-11.fc28.x86_64 requires libsane-hpaio(x86-64) = 3.18.6-11.fc28, but none of the providers can be installed
      - cannot install the best update candidate for package hplip-gui-3.18.6-10.fc28.x86_64
      - nothing provides libnetsnmp.so.35()(64bit) needed by libsane-hpaio-3.18.6-11.fc28.x86_64
     Problem 5: package hplip-libs-3.18.6-10.fc28.x86_64 requires hplip-common(x86-64) = 3.18.6-10.fc28, but none of the providers can be installed
      - cannot install both hplip-common-3.18.6-11.fc28.x86_64 and hplip-common-3.18.6-10.fc28.x86_64
      - problem with installed package hplip-libs-3.18.6-10.fc28.x86_64
      - cannot install the best update candidate for package hplip-common-3.18.6-10.fc28.x86_64
      - nothing provides libnetsnmp.so.35()(64bit) needed by hplip-libs-3.18.6-11.fc28.x86_64
    ================================================================================
     Package                  Arch     Version                      Repository
                                                                               Size
    ================================================================================
    Upgrading:
     cdrskin                  x86_64   1.5.0-1.fc28                 updates   115 k
     cinnamon-themes          noarch   1:1.7.7-1.fc28               updates   662 k
     cpp                      x86_64   8.2.1-6.fc28                 updates   9.8 M
     cryptsetup               x86_64   2.0.6-1.fc28                 updates   171 k
     cryptsetup-libs          x86_64   2.0.6-1.fc28                 updates   324 k
     fedora-release           noarch   28-6                         updates    27 k
     gcc                      x86_64   8.2.1-6.fc28                 updates    23 M
     gcc-c++                  x86_64   8.2.1-6.fc28                 updates    12 M
     gcc-gdb-plugin           x86_64   8.2.1-6.fc28                 updates   138 k
     ibus                     x86_64   1.5.19-9.fc28                updates   6.1 M
     ibus-gtk2                x86_64   1.5.19-9.fc28                updates    60 k
     ibus-gtk3                x86_64   1.5.19-9.fc28                updates    60 k
     ibus-libs                x86_64   1.5.19-9.fc28                updates   263 k
     ibus-setup               noarch   1.5.19-9.fc28                updates    95 k
     ibus-wayland             x86_64   1.5.19-9.fc28                updates    56 k
     inxi                     noarch   3.0.28-1.fc28                updates   282 k
     java-openjdk             x86_64   1:11.0.1.13-8.rolling.fc28   updates   200 k
     java-openjdk-headless    x86_64   1:11.0.1.13-8.rolling.fc28   updates    38 M
     libburn                  x86_64   1.5.0-1.fc28                 updates   173 k
     libgcc                   x86_64   8.2.1-6.fc28                 updates    99 k
     libgfortran              x86_64   8.2.1-6.fc28                 updates   659 k
     libgomp                  x86_64   8.2.1-6.fc28                 updates   211 k
     libisofs                 x86_64   1.5.0-1.fc28                 updates   221 k
     libpaper                 x86_64   1.1.24-23.fc28               updates    43 k
     libquadmath              x86_64   8.2.1-6.fc28                 updates   189 k
     libsmbclient             x86_64   2:4.8.8-0.fc28               updates   136 k
     libsolv                  x86_64   0.7.2-1.fc28                 updates   389 k
     libstdc++                x86_64   8.2.1-6.fc28                 updates   471 k
     libstdc++-devel          x86_64   8.2.1-6.fc28                 updates   2.1 M
     libwbclient              x86_64   2:4.8.8-0.fc28               updates   110 k
     libxcrypt                x86_64   4.4.1-1.fc28                 updates   116 k
     libxcrypt-devel          x86_64   4.4.1-1.fc28                 updates    32 k
     mint-themes              noarch   1:1.7.7-1.fc28               updates   310 k
     mint-themes-gtk3         noarch   1:1.7.7-1.fc28               updates   325 k
     mint-y-icons             noarch   1.3.3-1.fc28                 updates    61 M
     mint-y-theme             noarch   1:1.7.7-1.fc28               updates   3.1 M
     pam                      x86_64   1.3.1-13.fc28                updates   746 k
     perl-threads-shared      x86_64   1.59-1.fc28                  updates    47 k
     rsyslog                  x86_64   8.39.0-1.fc28                updates   702 k
     samba-client             x86_64   2:4.8.8-0.fc28               updates   623 k
     samba-client-libs        x86_64   2:4.8.8-0.fc28               updates   4.9 M
     samba-common             noarch   2:4.8.8-0.fc28               updates   204 k
     samba-common-libs        x86_64   2:4.8.8-0.fc28               updates   169 k
     setroubleshoot           x86_64   3.3.19-1.fc28                updates   131 k
     setroubleshoot-plugins   noarch   3.3.10-1.fc28                updates   365 k
     setroubleshoot-server    x86_64   3.3.19-1.fc28                updates   393 k
     zchunk-libs              x86_64   0.9.17-1.fc28                updates    46 k
    Skipping packages with conflicts:
    (add '--best --allowerasing' to command line to force their upgrade):
     hplip-common             x86_64   3.18.6-11.fc28               updates   110 k
    Skipping packages with broken dependencies:
     hplip                    x86_64   3.18.6-11.fc28               updates    16 M
     hplip-gui                x86_64   3.18.6-11.fc28               updates   1.3 M
     hplip-libs               x86_64   3.18.6-11.fc28               updates   204 k
     libsane-hpaio            x86_64   3.18.6-11.fc28               updates   127 k
    
    Transaction Summary
    ================================================================================
    Upgrade  47 Packages
    Skip      5 Packages
    
    Total download size: 168 M
    Is this ok [y/N]: N
    Operation aborted.
    What I have to do ? Just waiting ?
    Fedora 28 X64 bit Cinnamon edition on Lenovo ThinkPad e550 with Intel core i7 5500 CPU @ 2.40 GH X 2, RAM = 8 GB, HHD = 1 TB, Hybrid VGA (Intel Corporation HD Graphic 5500 + Radeon R7 M265 2GB)

  2. #2
    Join Date
    Oct 2011
    Posts
    1,906
    Linux Chrome 69.0.3497.100

    Re: I have update conflicts, what I have to do ?

    https://bodhi.fedoraproject.org/upda...018-b60fdc1998
    https://bodhi.fedoraproject.org/upda...018-e7d66d4d3f
    Quote Originally Posted by augenauf
    Package needs net-snmp-libs.x86_64 1:5.8-3.fc28, which is still in testing, so

    Code:
    sudo dnf update --enablerepo=updates-testing hplip*
    will do the job and install the hplip update
    Last edited by srakitnican; 20th December 2018 at 06:56 PM.

  3. #3
    Join Date
    Jul 2014
    Location
    EU
    Posts
    315
    Linux Pale Moon 28.2.2

    Re: I have update conflicts, what I have to do ?

    Hello, I have the same problem. What is the risk like of using updates-testing repo ? I don't want break another parts of system.

  4. #4
    Join Date
    Oct 2011
    Posts
    1,906
    Linux Chrome 69.0.3497.100

    Re: I have update conflicts, what I have to do ?

    If you need to ask that question, maybe it is better if you wait until it gets into a stable repository. There is generally no risk if you know what you are doing and know how to revert the packages to a previous state. updates-testing repo should not be enabled permanently, but only temporary for a specific package(s) as it's shown in a command above. Even then, one should be careful to examine the output of the command when the dependencies are resolved so that it doesn't mess up other components.

  5. #5
    Join Date
    Jul 2005
    Age
    58
    Posts
    1,206
    Linux Chrome 72.0.3626.28

    Re: I have update conflicts, what I have to do ?

    Unless you particularly care about hplip and friends and want to update everything else, just do a

    dnf update --skip-broken

    or if you're impatient and brave, throw a -y on there to blaze ahead without asking if it should.

  6. #6
    Join Date
    Aug 2016
    Location
    Iraq
    Posts
    966
    Linux (Fedora) Firefox 64.0

    Re: I have update conflicts, what I have to do ?

    I upgraded for 2 times by the usual method: after see alert & asked continue or not? I typed "y" - as usual every time upgrade -
    After each time I used my printer to print, & it worked without any problem ! I did not enable or use "test" repositories at all !
    It seem that DNF had been developed well to be cleaver enough in this situations !
    Fedora 28 X64 bit Cinnamon edition on Lenovo ThinkPad e550 with Intel core i7 5500 CPU @ 2.40 GH X 2, RAM = 8 GB, HHD = 1 TB, Hybrid VGA (Intel Corporation HD Graphic 5500 + Radeon R7 M265 2GB)

  7. #7
    Join Date
    Jul 2014
    Location
    EU
    Posts
    315
    Linux (Fedora) Firefox 64.0

    Re: I have update conflicts, what I have to do ?

    Code:
    sudo dnf upgrade --best --allowerasing
    Error: 
     Problem: cannot install the best update candidate for package libsane-hpaio-3.18.6-11.fc28.x86_64
      - problem with installed package libsane-hpaio-3.18.6-11.fc28.x86_64
      - package libsane-hpaio-3.18.6-12.fc28.x86_64 requires libnetsnmp.so.30()(64bit), but none of the providers can be installed
      - cannot install the best update candidate for package net-snmp-libs-1:5.8-3.fc28.x86_64
      - cannot install both net-snmp-libs-1:5.7.3-38.fc28.x86_64 and net-snmp-libs-1:5.8-3.fc28.x86_64
      - cannot install both net-snmp-libs-1:5.7.3-36.fc28.x86_64 and net-snmp-libs-1:5.8-3.fc28.x86_6sudo dnf upgrade --best --allowerasing
    Error: 
     Problem: cannot install the best update candidate for package libsane-hpaio-3.18.6-11.fc28.x86_64
      - problem with installed package libsane-hpaio-3.18.6-11.fc28.x86_64
      - package libsane-hpaio-3.18.6-12.fc28.x86_64 requires libnetsnmp.so.30()(64bit), but none of the providers can be installed
      - cannot install the best update candidate for package net-snmp-libs-1:5.8-3.fc28.x86_64
      - cannot install both net-snmp-libs-1:5.7.3-38.fc28.x86_64 and net-snmp-libs-1:5.8-3.fc28.x86_64
      - cannot install both net-snmp-libs-1:5.7.3-36.fc28.x86_64 and net-snmp-libs-1:5.8-3.fc28.x86_644
    Code:
    sudo dnf update --enablerepo=updates-testing hplip*
     Problem: package hplip-libs-3.18.6-12.fc28.x86_64 requires libnetsnmp.so.30()(64bit), but none of the providers can be installed
      - cannot install both net-snmp-libs-1:5.7.3-38.fc28.x86_64 and net-snmp-libs-1:5.8-3.fc28.x86_64
      - cannot install both net-snmp-libs-1:5.7.3-36.fc28.x86_64 and net-snmp-libs-1:5.8-3.fc28.x86_64
      - cannot install the best update candidate for package hplip-libs-3.18.6-11.fc28.x86_64
      - problem with installed package net-snmp-libs-1:5.8-3.fc28.x86_64

  8. #8
    Join Date
    Apr 2011
    Location
    Rainham, Essex, UK
    Posts
    346
    Linux (Fedora) Chrome 70.0.3538.110

    Re: I have update conflicts, what I have to do ?

    Unless you have printer/scanner/aio that would only just be covered by the new version hplip you may as well sit on it (with --skip-broken) until it leaves testing. Bleeding edge is great - broken edge not so...

  9. #9
    Join Date
    Jul 2014
    Location
    EU
    Posts
    315
    Linux Firefox 60.9

    Re: I have update conflicts, what I have to do ?

    Quote Originally Posted by satanselbow
    Unless you have printer/scanner/aio that would only just be covered by the new version hplip you may as well sit on it (with --skip-broken) until it leaves testing. Bleeding edge is great - broken edge not so...
    I can wait for stable update.

  10. #10
    Join Date
    Aug 2016
    Location
    Iraq
    Posts
    966
    Linux (Fedora) Firefox 64.0

    Re: I have update conflicts, what I have to do ?

    The issue have been solved since days ago ! Do you received the update from usual repositories ?
    Fedora 28 X64 bit Cinnamon edition on Lenovo ThinkPad e550 with Intel core i7 5500 CPU @ 2.40 GH X 2, RAM = 8 GB, HHD = 1 TB, Hybrid VGA (Intel Corporation HD Graphic 5500 + Radeon R7 M265 2GB)

  11. #11
    Join Date
    Jul 2014
    Location
    EU
    Posts
    315
    Linux Pale Moon 28.2.2

    Re: I have update conflicts, what I have to do ?

    Quote Originally Posted by User808
    The issue have been solved since days ago ! Do you received the update from usual repositories ?
    Yes I do.

    The message you have entered is too short. Please lengthen your message to at least 10 characters.

Similar Threads

  1. update conflicts
    By kornelix in forum Installation, Upgrades and Live Media
    Replies: 2
    Last Post: 18th December 2006, 07:12 PM
  2. Conflicts on yum update
    By frxshmxn in forum Using Fedora
    Replies: 0
    Last Post: 20th April 2006, 10:58 PM
  3. Update conflicts...
    By viciouslime in forum Using Fedora
    Replies: 13
    Last Post: 25th February 2006, 10:20 PM
  4. Conflicts while trying to update apt
    By Pumkinut in forum Using Fedora
    Replies: 2
    Last Post: 21st March 2005, 03:27 PM
  5. Conflicts using 'yum update'
    By jafro in forum Using Fedora
    Replies: 1
    Last Post: 15th November 2004, 06:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •