f28 to 29 upgrade causing sleep mode
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2007
    Posts
    41
    Mac OS X 10.12.2 Chrome 70.0.3538.110

    f28 to 29 upgrade causing sleep mode

    HI,
    After upgrading f28 to f29, immediately after logging in, it goes into power-save or sleep mode.
    I tried single user mode and logging in as root, then systemctrl mask suspend.target
    and systemctl mask sleep.target which does get round it and takes me to the desktop on reboot target from single user mode.

    But this doesn't seem to permanently mask sleep.

    How would I permanently disable sleep and suspend on f29?

    mask UNITů
    Mask one or more units, as specified on the command line. This will link these unit files to /dev/null, making it impossible to start them. This is a stronger version of disable, since it prohibits all kinds of activation of the unit, including enablement and manual activation. Use this option with care. This honors the --runtime option to only mask temporarily until the next reboot of the system. The --now option may be used to ensure that the units are also stopped. This command expects valid unit names only, it does not accept unit file paths.

  2. #2
    Join Date
    Dec 2017
    Location
    Finland
    Posts
    20
    Linux (Fedora) Firefox 63.0

    Re: f28 to 29 upgrade causing sleep mode

    Could you try to boot the F29 live CD/USB, will that logon or also enter some power-save mode?

  3. #3
    Join Date
    Aug 2007
    Posts
    41
    Linux (Fedora) Firefox 64.0

    Re: f28 to 29 upgrade causing sleep mode

    Quote Originally Posted by jhearon
    HI,
    After upgrading f28 to f29, immediately after logging in, it goes into power-save or sleep mode.
    I tried single user mode and logging in as root, then systemctrl mask suspend.target
    and systemctl mask sleep.target which does get round it and takes me to the desktop on reboot target from single user mode.

    But this doesn't seem to permanently mask sleep.

    How would I permanently disable sleep and suspend on f29?

    mask UNITů
    Mask one or more units, as specified on the command line. This will link these unit files to /dev/null, making it impossible to start them. This is a stronger version of disable, since it prohibits all kinds of activation of the unit, including enablement and manual activation. Use this option with care. This honors the --runtime option to only mask temporarily until the next reboot of the system. The --now option may be used to ensure that the units are also stopped. This command expects valid unit names only, it does not accept unit file paths.

    -------------------------
    More on this issue...

    Fedora Settings GUI for Power. Power Saving, Blank screen keeps resetting to 0 seconds, although I tried manually setting it to Never.

    Other things I've tried:

    1. masking (per above) doesn't seem to work permanently for reboot. If I go into single user mode and unmask, then mask suspend.target, and sleep.target again, it will work to move past the login screen to gnome desktop.

    2. Tried this approach from Stack Exchange to add to .bash_profile, but strangely the system keeps deleting this from the .bash_profile (odd?)

    # Inhibit idle sleep. This background process waits for the current shell to exit.
    nohup systemd-inhibit --who=Bash --why="Byobu running" tail --pid=$$ -f /dev/null &

    3. Listed power settings keys using
    >gsettings list-recursively org.gnome.settings-daemon.plugins.power

    org.gnome.settings-daemon.plugins.power power-button-action 'suspend'
    org.gnome.settings-daemon.plugins.power idle-dim true
    org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type 'suspend'
    org.gnome.settings-daemon.plugins.power sleep-inactive-battery-timeout 1200
    org.gnome.settings-daemon.plugins.power sleep-inactive-battery-type 'suspend'
    org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout 0
    org.gnome.settings-daemon.plugins.power ambient-enabled true
    org.gnome.settings-daemon.plugins.power idle-brightness 30

    ...and tried to set idle-dim to false
    >gsettings set org.gnome.settings-daemon.plugins.power idle-dim false

    but get
    dconf-WARNING **: 09:16:20.942: failed to commit changes to dconf: The connection is closed

    4. tried to edit via gui using dconf-editor, but it won't set idle-dim to off. Just bounces back to on.

    5. Investigated the machine's bios settings to see if was something in there. Nope.


    Geez. I feel like I'm loosing control here with the system overriding all my efforts to stop the machine from blanking or idling, or going into sleep mode...whatever it's doing just after the login where I get a black screen with white letters saying "sleep mode" instead of the desktop. Really weird.

    Jim

Similar Threads

  1. Replies: 3
    Last Post: 11th August 2017, 02:40 AM
  2. hardware sleep mode gone?
    By rholme in forum Using Fedora
    Replies: 6
    Last Post: 19th May 2014, 12:38 PM
  3. F13 LiveCD goes into sleep mode
    By ssivil in forum Installation, Upgrades and Live Media
    Replies: 0
    Last Post: 26th May 2010, 03:29 PM
  4. How to wakeup from sleep mode when trying to ssh in.
    By Speed.Freak in forum Using Fedora
    Replies: 5
    Last Post: 13th December 2008, 04:24 AM
  5. Sleep Mode With Fc5
    By budo in forum Mac Chat
    Replies: 1
    Last Post: 8th April 2006, 02:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •