GP106 is disabled after suspend/sleep
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    Mar 2014
    Location
    U.S.
    Posts
    55
    Linux (Fedora) Firefox 63.0

    GP106 is disabled after suspend/sleep

    I have a problem with my display port loosing it's sound after suspend or sleep. Not sure which. Every time I come back to my computer and get back in it will be disabled in the sound preferences. This can be solved at minimum by logging out and in the user but I'm trying to figure out what the problem is and make it not be an issue. Edit: It might also have to do with the screensaver or other power settings.

    When returning from these modes or potentially similar ones I go into sound preferences and select, 'Hardware', and select, 'GP106 High Definition Audio Controller'. It says 'Disabled' and 'Off'. If I select, 'Profile' under the, 'Settings for the selected device:' it only has off as an option and not the other options normally available.

    Does anyone know what has disabled this or how to reenable it or stop it from being disabled to start with?

    Actually, now it's working again even though it says disabled in, 'Hardware'. I'm not sure how to describe this behavior. It's availabe in 'output' also and it's working from that possibly. But when I start something in firefox it's not giving sound. And it still doesn't have full options for the hardware in hardware settings. Edit: now it's giving sound from firefox. Maybe this has changed from a recent update or something.

    The only working/used sound is from the video card atm.

    Code:
    $ sudo inxi -Fxmz
    System:    Host: ********* Kernel: 4.19.6-200.fc28.x86_64 x86_64 bits: 64 compiler: gcc 
               v: 8.2.1 Desktop: MATE 1.20.3 Distro: Fedora release 28 (Twenty Eight) 
    Machine:   Type: Desktop Mobo: Gigabyte model: GA-970A-D3 v: x.x serial: N/A BIOS: Award v: F12 
               date: 09/03/2013 
    Memory:    RAM: total: 15.66 GiB used: 6.73 GiB (43.0%) 
               Array-1: capacity: 16 GiB slots: 4 EC: None max module size: 4 GiB note: est. 
               Device-1: A0 size: 4 GiB speed: 1600 MT/s type: Unknown 
               Device-2: A1 size: 4 GiB speed: 1600 MT/s type: Unknown 
               Device-3: A2 size: 4 GiB speed: 1600 MT/s type: Unknown 
               Device-4: A3 size: 4 GiB speed: 1600 MT/s type: Unknown 
    CPU:       Topology: 6-Core model: AMD Phenom II X6 1100T bits: 64 type: MCP arch: K10 L2 cache: 3072 KiB 
               flags: lm nx pae sse sse2 sse3 sse4a svm bogomips: 39866 
               Speed: 805 MHz min/max: 800/3300 MHz Core speeds (MHz): 1: 805 2: 3711 3: 805 4: 805 5: 805 6: 805 
    Graphics:  Device-1: NVIDIA GP106 [GeForce GTX 1060 3GB] driver: nvidia v: 410.78 bus ID: 01:00.0 
               Display: server: Fedora Project X.org 1.19.6 driver: nvidia resolution: 1920x1080~60Hz 
               OpenGL: renderer: GeForce GTX 1060 3GB/PCIe/SSE2 v: 4.6.0 NVIDIA 410.78 direct render: Yes 
    Audio:     Device-1: Advanced Micro Devices [AMD/ATI] SBx00 Azalia driver: snd_hda_intel v: kernel 
               bus ID: 00:14.2 
               Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel v: kernel bus ID: 01:00.1 
               Device-3: Creative Labs EMU10k2/CA0100/CA0102/CA10200 [Sound Blaster Audigy Series] 
               driver: snd_emu10k1 v: kernel bus ID: 05:06.0 
               Sound Server: ALSA v: k4.19.6-200.fc28.x86_64 
    Sensors:   System Temperatures: cpu: 46.0 C mobo: 38.0 C gpu: nvidia temp: 49 C 
               Fan Speeds (RPM): cpu: 0 fan-1: 4354 fan-3: 0 fan-5: 0 
               Voltages: 12v: N/A 5v: 2.94 3.3v: N/A vbat: 3.31 
    Info:      Processes: 294 Uptime: 1d 3h 10m Init: systemd runlevel: 5 Compilers: gcc: 8.2.1 Shell: bash 
               v: 4.4.23 inxi: 3.0.26
    removed some info like hdd's and network to cut this down.
    Last edited by FedoraUser101; 9th December 2018 at 09:41 AM.

  2. #2
    Join Date
    Dec 2018
    Location
    Australia
    Posts
    1
    Linux (Fedora) Chrome 71.0.3578.98

    Re: GP106 is disabled after suspend/sleep

    I'm having the same issue. Just installed Fedora 29. First time using Fedora and I'm liking! However every time I wake my PC from Suspend there is no audio. Sometimes when I go to sound settings I find it is selected to "Digital Output (S/PDIF) - Built In Audio" when it should be selected on "HDMI / DisplayPort - GM204 High Definition Audio". Note: These are the only two sound devices I have available.

    Also there was one other time where sound would not work at all. I selected HDMI output but when I adjust the volume the OSD would always state it was S/PDIF being adjusted even though I had reselected HDMI in settings. Had to reboot.

    Any help would be awesome!

    Paul.

  3. #3
    Join Date
    Mar 2014
    Location
    U.S.
    Posts
    55
    Linux (Fedora) Firefox 63.0

    Re: GP106 is disabled after suspend/sleep

    I found a temp solution I think. I am now using the onboard sound. It doesn't seem to have this problem. I think I tried both the other display ports and an old add in PCI sound card. Although I don't remember if the sound card had this issue. I was also testing a problem with a game making my sound go bad after a while of playing a game and might have been testing that. My display port or something actually blew out or somehow disabled my in monitor speakers. Not sure if that is related or not. I now have the on board sound going through the moniter(a relay) and to some desktop speakers. This obviously doesn't give light or solve the main issue though.

    At one point the sound would come back in some circumstances just from removing and readding the display port at the back of the video card. There were several other oddities too. Not sure what to make of it. I can't even test it now because the speakers blew out. I wonder if this is from the sound quality being too high for the speakers. I was reading something like this. Or is it likely something else?
    Last edited by FedoraUser101; 16th December 2018 at 08:29 PM.

Similar Threads

  1. tap to click disabled on sleep
    By dnbwise in forum Using Fedora
    Replies: 0
    Last Post: 25th July 2008, 07:00 PM
  2. Accidently disabled service for sleep/suspend.
    By ZeusZon in forum Using Fedora
    Replies: 0
    Last Post: 30th October 2006, 08:13 PM
  3. Sleep/Suspend/Hibernate
    By chrisndebb in forum Using Fedora
    Replies: 2
    Last Post: 4th June 2006, 05:38 AM
  4. how to sleep/suspend on desktop?
    By dedded in forum Using Fedora
    Replies: 19
    Last Post: 8th October 2005, 05:51 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •