Trouble with GeForce6 akmod EOL
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 4 of 4
  1. #1
    Join Date
    Oct 2012
    Location
    Portland, Oregon
    Posts
    156
    Linux Chrome 71.0.3578.80

    Trouble with GeForce6 akmod EOL

    I had the shock of my life when trying to install F29 on my machine. First, XFCE live image would crash when entering in graphics mode. I tried with a stick and a DVD, the same. Then i desperately switched to LXDE, only to find numerous bugs and inconveniences, too many to list. While trying to find workarounds, i found the sad news about akmod not being maintained beyond 27 for GeForce6-7. Also coincidentally could not find a driver beyond 27 at nvidia site. So i came back to XFCE 27 and to my surprise akmod in their repo for 27 would only want kernel 4.18. My question is. Since F27 started with 4.13, that means 28 must had been working at a certain time with 4.18 as well. However compiled for F28 with the module for nvidia 304 missing. Why???

    I really don't understand what is to be maintained at a driver for a hardware that doesn't change. I see. It's the kernel that changes and "overgrows" the driver. Or the akmod. But since 4.18 was working with 28, and 304 works with 4.18 why they say it doesn't work beyond 27?
    MS-7309, Athlon 64 x2 4450e, 3G RAM, GeForce 6150SE nForce 430, LG24M37H, XFCE, 27, 4.18.19-100.fc27, akmod-nvidia-304xx.x86_64.304.137-4.fc27, Proudly powered by Fedora since 2011.

  2. #2
    Join Date
    Oct 2012
    Location
    Portland, Oregon
    Posts
    156
    Linux Chrome 71.0.3578.80

    Re: Trouble with GeForce6 akmod EOL

    BTW could anybody recommend me a cheap humble card for web browsing that i could use on my hardware listed in the signature. That would work with an nvidia native driver of course.
    MS-7309, Athlon 64 x2 4450e, 3G RAM, GeForce 6150SE nForce 430, LG24M37H, XFCE, 27, 4.18.19-100.fc27, akmod-nvidia-304xx.x86_64.304.137-4.fc27, Proudly powered by Fedora since 2011.

  3. #3
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    6,598
    Linux Chrome 70.0.3538.77

    Re: Trouble with GeForce6 akmod EOL

    If you want NVIDIA specifically then opting for a pascal card (GT1030 or GTX1050 to a maximum GTX1050ti) anything else would be overkill for your stated needs. you'd then be using current NVIDIA proprietary drivers. nouveau support isn't fully completed yet for pascal cards unless they have simply neglected updating the feature matrix page. It's not been touched since 2017 so it could be the case they have actually finished the outstanding tasks.

    what concerns me slightly are the instructions for your motherboard and card compatibility list. it may be worth asking on the MSI forum what other users with your legacy motherboard have been able to fit successfully if they upgraded the GPU recently

  4. #4
    Join Date
    Aug 2007
    Posts
    309
    Linux Firefox 52.0

    Re: Trouble with GeForce6 akmod EOL

    Have you tried the NVidia .run file with dkms for auto-compilation ? This is the 304 one for the GeForce 6150SE nForce 430

    https://www.nvidia.com/Download/driv...x/123709/en-us

    I have used the .run files for years. You will need to have the kernel headers and devel packages among others.

    A good guide in the ifnot true then false guide

    https://www.if-not-true-then-false.c...e-installation

    Also coincidentally could not find a driver beyond 27 at nvidia site.
    Where does it say this and does it refer to Fedora 27 specifically ? The NVidia site doesn't seem to refer to any Linux distributions specifically.

Similar Threads

  1. akmod f23
    By dwarthog in forum Using Fedora
    Replies: 1
    Last Post: 9th December 2015, 10:49 PM
  2. F23 and akmod
    By mpajoh in forum Using Fedora
    Replies: 0
    Last Post: 4th November 2015, 03:52 PM
  3. kmod vs akmod
    By mathan in forum Hardware & Laptops
    Replies: 13
    Last Post: 27th January 2014, 04:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •