Hibernate not working after upgrade from 28 to 29, Dell XPS 13 9365
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 5 of 5
  1. #1
    Join Date
    Jul 2005
    Posts
    19
    Linux (Fedora) Firefox 63.0

    Hibernate not working after upgrade from 28 to 29, Dell XPS 13 9365

    I have a Dell XPS 13 (9365) and I'm trying to get hibernation working. I had it working on Fedora 28. I could run systemctl hibernate, and the system state would be written to the swap partition and restored at the next boot. After upgrading to Fedora 29, when I try to run systemctl hibernate, it fails and prints an error message
    Code:
    Failed to hibernate system via logind: Resume not configured, can't hibernate
    I don't understand this. I never saw this particular message on Fedora 28. Searching the web for it turned up nothing.
    My /etc/default/grub includes GRUB_CMDLINE_LINUX="resume=/dev/mapper/fedora-swap..." and that option does show up in /proc/cmdline.
    /etc/fstab includes /dev/mapper/fedora-swap swap swap defaults 0 0 and the swap partition is being used. So as far as I can tell, hibernate and resume are configured. Secure boot is disabled in the BIOS.

    Does anyone know what this message means and how to fix hibernation?

  2. #2
    Join Date
    Jun 2005
    Location
    Montreal, Que, Canada
    Posts
    5,481
    Linux Firefox 63.0

    Re: Hibernate not working after upgrade from 28 to 29, Dell XPS 13 9365

    Yes to your question!

    During your upgrade, you may have reformatted a swap partition. In so doing it's UUID value has changed.
    Check you disks, do you have more than one swap partition?

    Check /etc/fstab to determine which swap partition id is used.
    Check /etc/default/grub to determine the value of resume=UUID= That value will be used by grub to identify the resume partition.

    set the resume=UUID= to that other unused swap partition, or create a second swap partition of equal size.
    Set that new UUID value into the resume=UUID= and follow up with grub2-mkconfig to recreate the grub.cfg file. My system predates UEFI so I use grub2-mkconfig /boot/grub2/grub.cfg.

    The grub.cfg picks up the resume=UUID= from /etc/default/grub.

    Alternatively, edit the grub.cfg and overwrite the resume=UUID= in the menus for your system with that second swapfile's UUID value
    Leslie in Montreal

    Interesting web sites list
    http://forums.fedoraforum.org/showth...40#post1697840

  3. #3
    Join Date
    Jul 2013
    Location
    Colorado USA
    Posts
    4
    Linux (Fedora) Chrome 68.0.3440.106

    Re: Hibernate not working after upgrade from 28 to 29, Dell XPS 13 9365

    Same problem here. UUID of swap did not change during upgrade (nor did it during previous F27-->F28 upgrade of same system). Appears that it may be a systemd problem(?); downgrading systemd appears to have restored hibernate functionality (see this thread: https://bugzilla.redhat.com/show_bug.cgi?id=1645870 -- comment 10 shows command to downgrade systemd).

    Quote Originally Posted by garrett
    I have a Dell XPS 13 (9365) and I'm trying to get hibernation working. I had it working on Fedora 28. I could run systemctl hibernate, and the system state would be written to the swap partition and restored at the next boot. After upgrading to Fedora 29, when I try to run systemctl hibernate, it fails and prints an error message
    Code:
    Failed to hibernate system via logind: Resume not configured, can't hibernate
    I don't understand this. I never saw this particular message on Fedora 28. Searching the web for it turned up nothing.
    My /etc/default/grub includes GRUB_CMDLINE_LINUX="resume=/dev/mapper/fedora-swap..." and that option does show up in /proc/cmdline.
    /etc/fstab includes /dev/mapper/fedora-swap swap swap defaults 0 0 and the swap partition is being used. So as far as I can tell, hibernate and resume are configured. Secure boot is disabled in the BIOS.

    Does anyone know what this message means and how to fix hibernation?

  4. #4
    Join Date
    Jul 2005
    Posts
    19
    Linux (Fedora) Firefox 63.0

    Re: Hibernate not working after upgrade from 28 to 29, Dell XPS 13 9365

    Mine also was not a UUID mismatch -- I referred to the swap partition by /dev item. Downgrading systemd seems to have made it work. The bugzilla report mentioned that a fix is in the works, and it looks like the next update to systemd will include it.

  5. #5
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    948
    Linux (Fedora) Firefox 63.0

    Re: Hibernate not working after upgrade from 28 to 29, Dell XPS 13 9365

    execute as root:
    Code:
    blkid
    in my case i never use LVM, so I get:
    Code:
    /dev/nvme0n1p1: UUID="d6b23b82-201f-4d7f-a76e-17a259779a5a" TYPE="swap" PARTUUID="6e186d07-01"
    change your /etc/default/grub to contain: resume=UUID=**your UUID here** instead of /dev/mapper......

    I reckon the LVM is a half-thought out system whereas it always hits against some chicken-egg scenarios. It bit me in the a** once too many times , so I never ever use it, and never will.
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

Similar Threads

  1. F16 Kernels 3.6.* cause hibernate to freeze on Dell E6410
    By aaronsloman in forum Hardware & Laptops
    Replies: 7
    Last Post: 25th March 2012, 01:07 AM
  2. F16 Suspend & Hibernate issues on Dell Latitude E6400
    By RavanH in forum Hardware & Laptops
    Replies: 3
    Last Post: 9th December 2011, 12:36 PM
  3. F10 Hibernate not working on a Dell Vostro 1400
    By MuadNu in forum Hardware & Laptops
    Replies: 7
    Last Post: 21st January 2009, 02:44 PM
  4. FC6: Hibernate, Suspend / Dell
    By ruig in forum Hardware & Laptops
    Replies: 3
    Last Post: 28th June 2007, 09:37 AM
  5. hibernate FC4 on Dell 600m
    By milosilak in forum Hardware & Laptops
    Replies: 9
    Last Post: 2nd August 2005, 03:48 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •