Changes in screen brightness every 2 minutes
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    Nov 2018
    Location
    Chile
    Posts
    4
    Linux (Fedora) Chrome 70.0.3538.77

    Changes in screen brightness every 2 minutes

    Hello, so I installed Fedora 29 on my notebook, everything has been running flawlessly except for a REALLY annoying "detail".
    Screen brightness seems to randomly go up or down on its own every two minutes (the glider with the sun above it appears on screen).

    I searched on google and found something on MSI notebooks and this issue (https://ubuntuforums.org/showthread....2314161&page=2), which provides a way to ignores these random messages with an x11 quirk file.

    Does anyone know how to create a quirk file for libinput to ignore these messages?, Im almost entirely certain this is the problem as I have the exact same symptoms and output as the guy in the linked forum post.

    Please help me figure out a solution to this problem, I really dont want to go back to Windows.

    Edit:// Figured a workaround running evtest --grab /dev/input/event12 > /dev/null 2>&1 & , event12 corresponds to Video_Bus which sends random EV_KEYS for some reason. Does anyone know a fix that doesnt involve running a sketchy script at startup?
    Last edited by Tirpitz; 8th November 2018 at 06:48 AM.

  2. #2
    Join Date
    Jun 2004
    Location
    Maryland, US
    Posts
    7,406
    Linux (Fedora) Firefox 63.0

    Re: Changes in screen brightness every 2 minutes

    Linux power handling usually has a feature where it has a power profile that behaves one way on AC power and another on battery. The idea is that you're more likely not to be using the screen after X seconds of no mouse or keyboard usage. So the screen dims to save power until the mouse or keyboard is used again. Obviously that can be annoying if it guesses too soon and you're just looking at the screen.

    You can go into the system settings tool and find "Power" and uncheck the "Dim screen" checkbox in one or both of "AC Power" mode and "On Battery".
    In KDE you're probably also want to turn off "Screen Energy Saving"

    This covers the Gnome power manager:

    Gnome Power Manager: https://help.gnome.org/users/gnome-p...rences.html.en

    The attached snap is the KDE power widgit:
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	power.png 
Views:	5 
Size:	101.5 KB 
ID:	29911  
    Last edited by marko; 8th November 2018 at 07:31 AM.

  3. #3
    Join Date
    Nov 2018
    Location
    Chile
    Posts
    4
    Linux (Fedora) Chrome 70.0.3538.77

    Re: Changes in screen brightness every 2 minutes

    Hello marko and thanks for replying, I did try playing with power settings to no avail. Typing evtest --grab /dev/input/event12 (second Video Bus in the list) shows random EV_KEYS events which seem to be the problem.

Similar Threads

  1. Replies: 7
    Last Post: 17th July 2015, 06:36 PM
  2. [SOLVED]
    Screen is blanking out after x minutes.
    By theAdmiral in forum Using Fedora
    Replies: 17
    Last Post: 28th April 2010, 04:04 AM
  3. Screen-blank after 10 minutes
    By subcon in forum Using Fedora
    Replies: 16
    Last Post: 25th April 2005, 03:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •