[SOLVED] F29 Can Not Install Oracle JDK rpm
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 6 of 6
  1. #1
    Join Date
    Jan 2007
    Location
    WA
    Posts
    272
    Windows NT 10.0 Chrome 70.0.3538.77

    F29 Can Not Install Oracle JDK rpm

    I have an app that depends on Oracle's jdk-8u191-linux-x64.rpm which installs on Fedora 28 but not on Fedora 29. I tried to figure out why it is failing but have not been able to. I downloaded the latest rpm from Oracle and I run the following:

    Code:
    [serv01] dnf install jdk-8u191-linux-x64.rpm
    Last metadata expiration check: 1:18:42 ago on Thu 01 Nov 2018 10:54:13 AM PDT.
    Error:
     Problem: conflicting requests
      - nothing provides /bin/basename needed by jdk1.8-2000:1.8.0_191-fcs.x86_64
      - nothing provides /bin/cp needed by jdk1.8-2000:1.8.0_191-fcs.x86_64
      - nothing provides /bin/ls needed by jdk1.8-2000:1.8.0_191-fcs.x86_64
      - nothing provides /bin/mkdir needed by jdk1.8-2000:1.8.0_191-fcs.x86_64
      - nothing provides /bin/mv needed by jdk1.8-2000:1.8.0_191-fcs.x86_64
      - nothing provides /bin/pwd needed by jdk1.8-2000:1.8.0_191-fcs.x86_64
      - nothing provides /bin/sort needed by jdk1.8-2000:1.8.0_191-fcs.x86_64
    /bin is a link to /usr/bin, but it's not looking there. Anyone know what the problem is and how to fix it?

    edit: I did check bugzilla as well and didn't find anything.
    Last edited by pnelsonsr; 1st November 2018 at 09:20 PM.

  2. #2
    Join Date
    Feb 2012
    Location
    Belgium
    Posts
    4
    Linux (Fedora) Firefox 63.0

    Re: F29 Can Not Install Oracle JDK rpm

    Try using rpm directly:
    Code:
    rpm -ivh jdk-8u191-linux-x64.rpm

  3. #3
    Join Date
    Oct 2004
    Location
    UK
    Posts
    115
    Linux (Fedora) Chrome 70.0.3538.77

    Re: F29 Can Not Install Oracle JDK rpm

    and for jdk-11.0.1_linux-x64_bin.rpm -
    Seems dnf is generally preferred?

  4. #4
    Join Date
    Jan 2007
    Location
    WA
    Posts
    272
    Windows NT 10.0 Chrome 70.0.3538.77

    Re: F29 Can Not Install Oracle JDK rpm

    @tchang -> Thanks! I have been using dnf so long I didn't even think of trying rpm. Yes this worked to get it installed. I'll have to do some testing now but again thanks!

    @DaveP -> where did you read that?

  5. #5
    Join Date
    Feb 2016
    Location
    Colombia
    Posts
    1
    Linux (Fedora) Firefox 63.0

    Re: F29 Can Not Install Oracle JDK rpm

    Quote Originally Posted by tchang
    Try using rpm directly:
    Code:
    rpm -ivh jdk-8u191-linux-x64.rpm
    it not work for me...

    error: open of jdk-8u191-linux-x64.rpm failed: No such file or directory

  6. #6
    Join Date
    May 2018
    Location
    UK
    Posts
    57
    Linux (Fedora) Firefox 63.0

    Re: F29 Can Not Install Oracle JDK rpm

    Quote Originally Posted by mcjarod
    it not work for me...

    error: open of jdk-8u191-linux-x64.rpm failed: No such file or directory
    Well that's about as obvious an error as you can get. You don't have the rpm package in the directory you are running rpm from. Did you download it first? Note that for jdk the recommended method is simply to install the Fedora provided version for jdk 8.

    dnf install java-1.8.0-openjdk

    To see additional packages

    dnf list java-1.8.0-openjdk*

    You only need the Oracle version if for some reason the Fedora provided one doesn't work with a specific application - and yes I know there are some things that explicitly need the Oracle version.

    Edit: I notice there is now an 8u192 just released at Oracle so if you are installing the Oracle version then that's the one you should probably go for. Available at https://www.oracle.com/technetwork/j...s-2133151.html - scroll down for 192.
    Last edited by hogweed; 11th November 2018 at 04:44 PM.

Similar Threads

  1. F10 Oracle 11g install
    By Biltmore in forum Using Fedora
    Replies: 1
    Last Post: 8th April 2009, 02:43 PM
  2. Oracle 9i install FC5
    By motabar in forum Linux Chat
    Replies: 0
    Last Post: 26th June 2006, 09:28 AM
  3. Oracle does not install on FC5
    By giulix in forum Using Fedora
    Replies: 4
    Last Post: 5th April 2006, 09:55 AM
  4. install oracle on FC1
    By sameershaik in forum EOL (End Of Life) Versions
    Replies: 0
    Last Post: 25th August 2005, 04:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •