[SOLVED] Fedora 29: Openbox pipe-menu is broken ('Error: Invalid output from pipe-menu')
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 5 of 5
  1. #1
    Join Date
    Oct 2018
    Location
    Germany
    Posts
    3
    Linux Firefox 63.0

    Fedora 29: Openbox pipe-menu is broken ('Error: Invalid output from pipe-menu')

    Hello Community,

    I just installed Fedora 29 and Openbox (selected 'Fedora Custom Operating System' and added group base-x + openbox manually) using the Fedora-Workstation-netinst-x86_64-29-1.2.ISO and the pipe-menu is broken and when I'm trying to click on one of the entries, no sub-menu or program-entries are shown and I get an error-message like

    Invalid output from pipe-menu "/usr/libexec/openbox-xdg-menu
    /etc/openbox/terminals"
    The menu works fine out of the box without the need to configure anything in Fedora 28. But with 29, the menu is broken (and it stops working, when I upgrade from 28 to 29. So maybe itís a bug?).

    thx.

  2. #2
    Join Date
    Oct 2018
    Location
    Germany
    Posts
    3
    Linux Firefox 63.0

    Re: Fedora 29: Openbox pipe-menu is broken ('Error: Invalid output from pipe-menu')

    So it indeed seems to be a bug that has already been reported.

    https://bugzilla.redhat.com/show_bug.cgi?id=1624651

    A commentator suggest (#10) downgrading python3-pyxdg-0.26-1.fc29.noarch to python3-pyxdg-0.25-16.fc29.noarch to solve the problem, but as this package is no longer in the repositories and I donít know how to do this, Iíll stick with Fedora 28 for now.

  3. #3
    Join Date
    May 2012
    Location
    NC
    Posts
    2,265
    Linux (Ubuntu) Firefox 63.0

    Re: Fedora 29: Openbox pipe-menu is broken ('Error: Invalid output from pipe-menu')

    I've run into the same issue. It's also in the F29 LXDE release.

    The older python3-pyxdg package appears to be on Koji here. I haven't yet downgraded the shipping package to it.

    EDIT: Tried the downgrade in live mode. It restored the right-click menu immediately. (sudo dnf downgrade ./python3-pyxdg-0.25-16.fc29.noarch.rpm)
    Last edited by joncr; 1st November 2018 at 12:13 PM.

  4. #4
    Join Date
    Oct 2018
    Location
    Germany
    Posts
    3
    Linux Firefox 63.0

    Thumbs up Re: Fedora 29: Openbox pipe-menu is broken ('Error: Invalid output from pipe-menu')

    That was easy. Thank you very much, joncr!

  5. #5
    Join Date
    May 2012
    Location
    NC
    Posts
    2,265
    Linux (Fedora) Firefox 63.0

    Re: Fedora 29: Openbox pipe-menu is broken ('Error: Invalid output from pipe-menu')

    FYI: This is fixed in python3-pyxdg-0.26-2, currently in Rawhide and in F29 update-testing. When it moves to the updates repo, a normal update will pull it in.

Similar Threads

  1. Replies: 0
    Last Post: 1st November 2011, 05:48 AM
  2. broken pipe error
    By brenda pink in forum Using Fedora
    Replies: 1
    Last Post: 24th September 2011, 05:57 PM
  3. RSYNC Broken pipe error
    By fw12 in forum Using Fedora
    Replies: 0
    Last Post: 5th March 2007, 08:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •