[SOLVED] Gigabyte 970A chipset motherboards - BIOS settings affect wlan adaptor and stability - Page 2
FedoraForum.org - Fedora Support Forums and Community
Page 2 of 2 FirstFirst 1 2
Results 16 to 20 of 20
  1. #16
    Join Date
    Dec 2013
    United Kingdom
    Linux Chrome 70.0.3538.77

    Re: Installing development tools from iso

    okay thanks for posting the findings and solution. out of interest what motherboard model and chipset are you using just in case anyone else experiences the same issue? also would you mind if I altered the thread heading to match the actual cause and move it to the hardware section?

  2. #17
    Join Date
    Oct 2016
    Boston Ma
    Windows NT 6.3 Firefox 63.0

    Re: Installing development tools from iso

    The motherboard is a Gigabyte GA 970 Gaming SLI, here is a link to the website.


    I tried enabling USB 3 support but had the same issue. If this fits better in the Hardware section, then move the thread.

  3. #18
    Join Date
    Jun 2004
    Maryland, US
    Linux (Fedora) Firefox 63.0

    Re: Installing development tools from iso

    Quote Originally Posted by abk4523
    I know I am all over the map looking for a solution, so I decided to try installing the tools from the install iso. I found instructions here: https://www.techbrown.com/configure-...edora-28.shtml, but they seem outdated. They refer to a folder called "gopal" which does not appear on the iso. Does anyone know any specific .ppm names and or file names I can search for to find the correct folders?

    Errr, "gopal" is the guy's name ( Gopal Raha ) hence his home directory == "/home/gopal" and so on. The instructions would work if you sub in your directories. He was using his home area to work on his files.
    It would probably be better to put the files under /mnt/ by replacing his copy steps II and III with:
    cp -a /run/media/<your username>/"Fedora 28 x86_64"  /mnt/
    substitute my example "Fedora 28 x86_64" with whatever the mount gets named, it depends on what iso you have.
    Replace 'yum' for 'dnf', they behave the same as far as making a local repo. The idea is you make a repo file in /etc/yum.repos.d/ that has its 'baseurl' line that points to file:///<path to iso directory>/ ....etc
    where you put your rpm files and do your dnf operations from there to install the Development Tools. To be consistent with his instructions, call the repo "fedoradvd" (note his example repo file at that page is wrong and lacks the [ ] label, the below is what it should look like:

    name=FedoraDVD $releasever - $basearch
    baseurl=file:///mnt/"Fedora 28 x86_64"
    also, to avoid a lot of "can't not reach server" errors, you should do your package installs with:
    dnf install --disablerepo=\*  --enablerepo=fedoradvd  "Development Tools"
    that is, disable all repos, then opt into just the localrepo.

    BTW, his instructions are somewhat clueless, I'm sure there's a better "how to make a local repo" how-to out there. He says you have to run 'createrepo', that's incorrect since the repo in the iso has all the necessary metadata. The other step he has you should skip is "rm /etc/yum.repos.d/*' and just use the --disablerepo=\* option to turn off the other repos. So in short you can skip his steps (IV, V and VI)
    Last edited by marko; 29th October 2018 at 01:30 AM.

  4. #19
    Join Date
    Feb 2009
    Linux (Fedora) Firefox 62.0

    Re: Installing development tools from iso


    I have a similar motherboard GA-970A-DSP FX using many of the same chip components as your MB. I found that using the hardware IOMMU resulted in stability issues. In brief the IOMMU maps device addresses to memory addresses.

    If you disable the IOMMU device in the BIOS settings, your system will use the "trampoline" approach to I/O mapping. I found this to be much more stable in supporting my hardware chipsets.
    Laptop: Toshiba / Intel B960 2.20Ghz x2/ 4GB/ 320GB SataII/ Intel HD/ fc29.x86_64
    Tower: GigaByte (970A) / AMD FX 8320 3.5Ghz x8/ 16GB/ 9TB Sata III/ AMD 6770HD/ fc29.x86_64
    Bookshelf: Shuttle DS61 (H61)/ i3-3225 3.3Ghz x2/ 16GB/ 320GB Sata II/ Intel HD 4000/ fc29.x86_64
    Embedded: BeagleBone Blk / ARM AM3358 1 GHz x1/ 512MB/ 2GB eMMC/ PowerVR SGX530/ fc27.armv7hl

  5. #20
    Join Date
    Dec 2013
    United Kingdom
    Linux Chrome 70.0.3538.77

    Re: Gigabyte 970A chipset motherboards - BIOS settings affect wlan adaptor and stabil

    thanks it's been moved, re-titled and stuck. the thread forms a handy reference with those solutions

Page 2 of 2 FirstFirst 1 2

Similar Threads

  1. [SOLVED]
    Gigabyte Motherboards and Hardware
    By hotsauce in forum Hardware & Laptops
    Replies: 19
    Last Post: 7th July 2013, 09:00 PM
  2. IOMMU on Gigabyte GA-970A-UD3
    By tashirosgt in forum Hardware & Laptops
    Replies: 9
    Last Post: 4th May 2012, 03:01 PM
  3. Changing out Motherboards - BIOS Boot to UEFI
    By seewhyphotos in forum Installation, Upgrades and Live Media
    Replies: 7
    Last Post: 24th January 2012, 11:15 PM
  4. Replies: 12
    Last Post: 9th June 2011, 01:33 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts