RPM Installation ploblem
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 7 of 7
  1. #1
    Join Date
    Oct 2018
    Location
    seoul
    Posts
    3
    Windows NT 10.0 Chrome 69.0.3497.100

    RPM Installation ploblem

    I am installing 9i DB on Fedora 11
    I'm installing rpm, but yum is not.
    rpm -ivh libstdc ++ - 4.4.0-4.i586.rpm There was a problem during installation.

    [root@oracle57 package]# rpm -ivh libstdc++-4.4.0-4.i586.rpm
    warning: libstdc++-4.4.0-4.i586.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID d22e77f2
    error: Failed dependencies:
    ld-linux.so.2 is needed by libstdc++-4.4.0-4.i586
    ld-linux.so.2(GLIBC_2.3) is needed by libstdc++-4.4.0-4.i586
    libc.so.6 is needed by libstdc++-4.4.0-4.i586
    libc.so.6(GLIBC_2.0) is needed by libstdc++-4.4.0-4.i586
    libc.so.6(GLIBC_2.1) is needed by libstdc++-4.4.0-4.i586
    libc.so.6(GLIBC_2.1.3) is needed by libstdc++-4.4.0-4.i586
    libc.so.6(GLIBC_2.2) is needed by libstdc++-4.4.0-4.i586
    libc.so.6(GLIBC_2.3) is needed by libstdc++-4.4.0-4.i586
    libc.so.6(GLIBC_2.3.2) is needed by libstdc++-4.4.0-4.i586
    libc.so.6(GLIBC_2.4) is needed by libstdc++-4.4.0-4.i586
    libgcc_s.so.1 is needed by libstdc++-4.4.0-4.i586
    libgcc_s.so.1(GCC_3.0) is needed by libstdc++-4.4.0-4.i586
    libgcc_s.so.1(GCC_3.3) is needed by libstdc++-4.4.0-4.i586
    libgcc_s.so.1(GCC_4.2.0) is needed by libstdc++-4.4.0-4.i586
    libgcc_s.so.1(GLIBC_2.0) is needed by libstdc++-4.4.0-4.i586
    libm.so.6 is needed by libstdc++-4.4.0-4.i586
    libm.so.6(GLIBC_2.0) is needed by libstdc++-4.4.0-4.i586

    So rpm -ivh libstdc++-devel-4.4.0-4.x86_64.rpm , rpm -ivh glibc-2.10.1-2.x86_64.rpm Installation does not work.
    I need help.

  2. #2
    Join Date
    Mar 2011
    Location
    /
    Posts
    5,199
    Windows 7 Chrome 69.0.3497.100

    Re: RPM Installation ploblem

    Fedora 11?! That's old!

    You will have to manually track down dependencies ... Sadly, there is no easier way. Something like this -

    Code:
    rpm -ivh libstdc++-devel-4.4.0-4.x86_64.rpm glibc-2.10.1-2.x86_64.rpm

  3. #3
    Join Date
    Mar 2011
    Location
    /
    Posts
    5,199
    Windows 7 Chrome 69.0.3497.100

    Re: RPM Installation ploblem

    Also, moved to EOL version

  4. #4
    Join Date
    Oct 2018
    Location
    seoul
    Posts
    3
    Windows NT 10.0 Mozilla OS-Browser Compatible

    I have a question.

    I do not want to install yum, but I want to install it manually.

    Can I get a list of what Fedora 11 RPMs need?

  5. #5
    PabloTwo's Avatar
    PabloTwo is offline "Registered User" T-Shirt Winner
    Join Date
    Mar 2007
    Location
    Seville, FL
    Posts
    7,829
    Linux Chrome 69.0.3497.100

    Re: RPM Installation ploblem

    By using such an old release of Fedora you are making life very difficult for yourself. The normal yum repositories are not where they used to be as defined in your /etc/yum.repos.d/ fedora repo files. They have been archived to another location.

    There is no "list" of dependency packages for any given rpm package. The dependencies of an rpm package are contained in metadata within the rpm package itself. Most of the dependencies described therein are not the package name that provides the dependency but rather a "resource", such as "libgcc_s.so.1(GCC_4.2.0)" which is not a package name, but in this case the package name can be deduced to be "libgcc", provided you get the correct version.

    You will also encounter that needed dependencies for one package will often times have dependencies of there own. Depending on what you are installing, that dependency chain can get rather long. Yum, when functional, can resolve dependencies and bring them in from working repositories. Otherwise, trying to install everything needed via the rpm command can quickly, and often, become what we call "dependency hell".

    If you feel you must progress with using F11, you will find the 32 bit rpm packages in the archives here.
    Last edited by PabloTwo; 9th October 2018 at 07:32 PM.

  6. #6
    Join Date
    Jul 2004
    Location
    Colton, NY; Junction of Heaven & Earth (also Routes 56 & 68).
    Age
    73
    Posts
    23,606
    Linux (Fedora) Firefox 62.0

    Re: I have a question.

    We're about to release F29, so you should know that F11 is not worth your efforts. It's too old to be used. Why not install a current version?
    (also, to tidy up the Forum, moved the thread to EOL)
    Linux & Beer - That TOTALLY Computes!
    Registered Linux User #362651


    Don't use any of my solutions on working computers or near small children.

  7. #7
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    6,592
    Windows NT 10.0 Chrome 69.0.3497.100

    Re: RPM Installation ploblem

    further tidying by merging the two rpm/yum related topics

Similar Threads

  1. Fedora Core 7 MPlayer ploblem =\
    By perdimonokl in forum Using Fedora
    Replies: 7
    Last Post: 30th July 2007, 05:57 AM
  2. Replies: 9
    Last Post: 25th December 2006, 12:52 AM
  3. Need help: mplayer ploblem
    By subratabera in forum Using Fedora
    Replies: 2
    Last Post: 19th October 2006, 06:18 PM
  4. FC3 installation Proliant DL360 G4 Fails to boot after installation
    By digitalhuman in forum EOL (End Of Life) Versions
    Replies: 4
    Last Post: 14th January 2006, 12:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •