dnf problem after upgrade in place to fedora 29 pre beta
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 11 of 11
  1. #1
    Join Date
    Jul 2013
    Location
    NZ
    Posts
    441
    Linux (Fedora) Firefox 62.0

    dnf problem after upgrade in place to fedora 29 pre beta

    dnf crashes with seg fault after upgrading. I followed the workaround in the rawhide bug below and the problem is solved.

    https://bugzilla.redhat.com/show_bug.cgi?id=1600917

  2. #2
    Join Date
    Oct 2011
    Posts
    1,895
    Linux Chrome 68.0.3440.106

    Re: dnf problem after upgrade in place to fedora 29 pre beta


  3. #3
    Join Date
    Jul 2013
    Location
    NZ
    Posts
    441
    Linux (Fedora) Firefox 62.0

    Re: dnf problem after upgrade in place to fedora 29 pre beta

    If I'm reading it right then this bug has been accepted as a Beta release blocker so I assume that means it will be getting attention. At least there is an easy workaround.

  4. #4
    Join Date
    Oct 2005
    Location
    Puerto Rico
    Posts
    594
    Linux (Fedora) Firefox 62.0

    Re: dnf problem after upgrade in place to fedora 29 pre beta

    Hi, after upgrading to F29 I'm getting some errors from dnf:
    Code:
    Last metadata expiration check: 0:00:53 ago on Wed 26 Sep 2018 08:39:43 AM EDT.
    Dependencies resolved.
    
     Problem 1: cannot install the best update candidate for package bubblewrap-0.3.0-2.fc29.x86_64
      - package bubblewrap-0.3.0-2.module_2123+73a9ef6f.x86_64 is excluded
     Problem 2: cannot install the best update candidate for package eog-3.28.3-1.fc29.x86_64
      - package eog-3.28.3-1.module_2123+73a9ef6f.x86_64 is excluded
     Problem 3: cannot install the best update candidate for package exempi-2.4.5-3.fc29.x86_64
      - package exempi-2.4.5-3.module_2123+73a9ef6f.x86_64 is excluded
     Problem 4: cannot install the best update candidate for package libnghttp2-1.33.0-1.fc29.x86_64
      - package libnghttp2-1.33.0-1.module_2177+2526c218.x86_64 is excluded
     Problem 5: cannot install the best update candidate for package libpeas-1.22.0-9.fc29.x86_64
      - package libpeas-1.22.0-9.module_2123+73a9ef6f.x86_64 is excluded
     Problem 6: cannot install the best update candidate for package libpeas-gtk-1.22.0-9.fc29.x86_64
      - package libpeas-gtk-1.22.0-9.module_2123+73a9ef6f.x86_64 is excluded
     Problem 7: cannot install the best update candidate for package libpeas-loader-python3-1.22.0-9.fc29.x86_64
      - package libpeas-loader-python3-1.22.0-9.module_2123+73a9ef6f.x86_64 is excluded
     Problem 8: cannot install the best update candidate for package perl-HTTP-Tiny-0.076-1.fc29.noarch
      - package perl-HTTP-Tiny-0.076-1.module_2073+eebc5b71.noarch is excluded
     Problem 9: cannot install the best update candidate for package perl-Thread-Queue-3.13-1.fc29.noarch
      - package perl-Thread-Queue-3.13-1.module_2073+eebc5b71.noarch is excluded
    Nothing to do.
    Complete!
    Would this be related to this bug? I searched bugzilla but found nothing to the point.

  5. #5
    Join Date
    Jun 2005
    Location
    Montreal, Que, Canada
    Posts
    5,539
    Linux Firefox 61.0

    Re: dnf problem after upgrade in place to fedora 29 pre beta

    Quote Originally Posted by Boricua
    Hi, after upgrading to F29 I'm getting some errors from dnf:
    Code:
    Last metadata expiration check: 0:00:53 ago on Wed 26 Sep 2018 08:39:43 AM EDT.
    Dependencies resolved.
    
     Problem 1: cannot install the best update candidate for package bubblewrap-0.3.0-2.fc29.x86_64
      - package bubblewrap-0.3.0-2.module_2123+73a9ef6f.x86_64 is excluded
     Problem 2: cannot install the best update candidate for package eog-3.28.3-1.fc29.x86_64
      - package eog-3.28.3-1.module_2123+73a9ef6f.x86_64 is excluded
     Problem 3: cannot install the best update candidate for package exempi-2.4.5-3.fc29.x86_64
      - package exempi-2.4.5-3.module_2123+73a9ef6f.x86_64 is excluded
     Problem 4: cannot install the best update candidate for package libnghttp2-1.33.0-1.fc29.x86_64
      - package libnghttp2-1.33.0-1.module_2177+2526c218.x86_64 is excluded
     Problem 5: cannot install the best update candidate for package libpeas-1.22.0-9.fc29.x86_64
      - package libpeas-1.22.0-9.module_2123+73a9ef6f.x86_64 is excluded
     Problem 6: cannot install the best update candidate for package libpeas-gtk-1.22.0-9.fc29.x86_64
      - package libpeas-gtk-1.22.0-9.module_2123+73a9ef6f.x86_64 is excluded
     Problem 7: cannot install the best update candidate for package libpeas-loader-python3-1.22.0-9.fc29.x86_64
      - package libpeas-loader-python3-1.22.0-9.module_2123+73a9ef6f.x86_64 is excluded
     Problem 8: cannot install the best update candidate for package perl-HTTP-Tiny-0.076-1.fc29.noarch
      - package perl-HTTP-Tiny-0.076-1.module_2073+eebc5b71.noarch is excluded
     Problem 9: cannot install the best update candidate for package perl-Thread-Queue-3.13-1.fc29.noarch
      - package perl-Thread-Queue-3.13-1.module_2073+eebc5b71.noarch is excluded
    Nothing to do.
    Complete!
    Would this be related to this bug? I searched bugzilla but found nothing to the point.

    try this first

    sudo dnf update bubblewrap --skip --allow --best

    If that does not work, then

    sudo dnf remove bubblewrap*
    sudo dnf install bubblewrap*

    I am not sure that you can use dnf reinstall bubblewrap*
    Leslie in Montreal

    Interesting web sites list
    http://forums.fedoraforum.org/showth...40#post1697840

  6. #6
    Join Date
    Oct 2005
    Location
    Puerto Rico
    Posts
    594
    Linux (Fedora) Firefox 62.0

    Re: dnf problem after upgrade in place to fedora 29 pre beta

    Thanks for your quick response. Unfortunately, it didn't work. Here's what I got:
    Code:
    [francisco@main ~]$ sudo dnf update bubblewrap --skip --allow --best
    [sudo] password for francisco: 
    Copr repo for telegram owned by rommon          214  B/s | 345  B     00:01    
    Failed to synchronize cache for repo 'rommon-telegram', ignoring this repo.
    Last metadata expiration check: 0:36:47 ago on Wed 26 Sep 2018 08:39:43 AM EDT.
    Dependencies resolved.
    Nothing to do.
    Complete!
    Code:
    [francisco@main ~]$ sudo dnf remove bubblewrap*
    Dependencies resolved.
    ================================================================================
     Package                                Arch    Version          Repository
                                                                               Size
    ================================================================================
    Removing:
     bubblewrap                             x86_64  0.3.0-2.fc29     @System   91 k
    Removing dependent packages:
     cheese                                 x86_64  2:3.30.0-2.fc29  @System  438 k
     cheese-libs                            x86_64  2:3.30.0-2.fc29  @System  2.3 M
     chrome-gnome-shell                     x86_64  10.1-3.fc29      @System   61 k
     eog                                    x86_64  3.28.3-1.fc29    @System   10 M
     evince                                 x86_64  3.30.0-2.fc29    @System  9.2 M
     evince-nautilus                        x86_64  3.30.0-2.fc29    @System   23 k
     evolution                              x86_64  3.30.0-1.fc29    @System   15 M
     evolution-ews                          x86_64  3.30.0-1.fc29    @System  1.3 M
     evolution-ews-langpacks                noarch  3.30.0-1.fc29    @System  910 k
     evolution-help                         noarch  3.30.0-1.fc29    @System   13 M
     evolution-langpacks                    noarch  3.30.0-1.fc29    @System   35 M
     flatpak                                x86_64  1.0.2-1.fc29     @System  4.0 M
     flatpak-libs                           x86_64  1.0.2-1.fc29     @System  911 k
     fwupd                                  x86_64  1.1.2-1.fc29     @System  4.5 M
     gdm                                    x86_64  1:3.30.0-3.fc29  @System  2.3 M
     gnome-clocks                           x86_64  3.30.0-3.fc29    @System  1.4 M
     gnome-contacts                         x86_64  3.30-1.fc29      @System  1.6 M
     gnome-control-center                   x86_64  3.30.0-1.fc29    @System   20 M
     gnome-desktop3                         x86_64  3.30.0-2.fc29    @System  2.6 M
     gnome-documents                        x86_64  3.30.0-1.fc29    @System  2.2 M
     gnome-documents-libs                   x86_64  3.30.0-1.fc29    @System  1.4 M
     gnome-font-viewer                      x86_64  3.30.0-1.fc29    @System  731 k
     gnome-initial-setup                    x86_64  3.29.92-1.fc29   @System  2.6 M
     gnome-photos                           x86_64  3.30.0-1.fc29    @System  4.8 M
     gnome-session                          x86_64  3.30.0-1.fc29    @System  1.5 M
     gnome-session-wayland-session          x86_64  3.30.0-1.fc29    @System  7.4 k
     gnome-session-xsession                 x86_64  3.30.0-1.fc29    @System   15 k
     gnome-settings-daemon                  x86_64  3.30.0-1.fc29    @System  5.2 M
     gnome-shell                            x86_64  3.30.0-8.fc29    @System  7.3 M
     gnome-shell-extension-background-logo  noarch  3.24.0-6.fc29    @System   58 k
     gnome-shell-extension-common           noarch  3.30.0-1.fc29    @System  593 k
     gnome-shell-extension-user-theme       noarch  3.30.0-1.fc29    @System  6.8 k
     gnome-software                         x86_64  3.30.0-1.fc29    @System  9.1 M
     gnome-tweaks                           noarch  3.30.0-1.fc29    @System  1.4 M
     mutter                                 x86_64  3.30.0-1.fc29    @System   12 M
     pitivi                                 x86_64  0.99-4.fc29      @System  9.2 M
     python2-notify                         x86_64  0.1.1-36.fc28    @System   73 k
     totem                                  x86_64  1:3.26.2-1.fc29  @System  7.7 M
     totem-nautilus                         x86_64  1:3.26.2-1.fc29  @System   40 k
     xdg-desktop-portal                     x86_64  1.0.2-1.fc29     @System  1.5 M
     xdg-desktop-portal-gtk                 x86_64  1.0.2-1.fc29     @System  725 k
    
    Transaction Summary
    ================================================================================
    Remove  42 Packages
    Freed space: 192 M
    Is this ok [y/N]: 
    Operation aborted.
    Code:
    [francisco@main ~]$ sudo dnf reinstall bubblewrap*
    Copr repo for telegram owned by rommon          214  B/s | 345  B     00:01    
    Failed to synchronize cache for repo 'rommon-telegram', ignoring this repo.
    Last metadata expiration check: 0:37:54 ago on Wed 26 Sep 2018 08:39:43 AM EDT.
    Dependencies resolved.
    ================================================================================
     Package            Arch           Version                 Repository      Size
    ================================================================================
    Reinstalling:
     bubblewrap         x86_64         0.3.0-2.fc29            fedora          46 k
    
    Transaction Summary
    ================================================================================
    
    Total download size: 46 k
    Installed size: 91 k
    Is this ok [y/N]: y
    Downloading Packages:
    bubblewrap-0.3.0-2.fc29.x86_64.rpm               31 kB/s |  46 kB     00:01    
    --------------------------------------------------------------------------------
    Total                                            14 kB/s |  46 kB     00:03     
    Running transaction check
    Transaction check succeeded.
    Running transaction test
    Transaction test succeeded.
    Running transaction
      Preparing        :                                                        1/1 
      Reinstalling     : bubblewrap-0.3.0-2.fc29.x86_64                         1/2 
      Cleanup          : bubblewrap-0.3.0-2.fc29.x86_64                         2/2 
      Running scriptlet: bubblewrap-0.3.0-2.fc29.x86_64                         2/2 
      Verifying        : bubblewrap-0.3.0-2.fc29.x86_64                         1/2 
      Verifying        : bubblewrap-0.3.0-2.fc29.x86_64                         2/2 
    
    Reinstalled:
      bubblewrap-0.3.0-2.fc29.x86_64                                                
    Complete!
    Code:
    [francisco@main ~]$ sudo dnf update
    Copr repo for telegram owned by rommon          211  B/s | 345  B     00:01    
    Failed to synchronize cache for repo 'rommon-telegram', ignoring this repo.
    Last metadata expiration check: 0:38:14 ago on Wed 26 Sep 2018 08:39:43 AM EDT.
    Dependencies resolved.
    
     Problem 1: cannot install the best update candidate for package bubblewrap-0.3.0-2.fc29.x86_64
      - package bubblewrap-0.3.0-2.module_2123+73a9ef6f.x86_64 is excluded
     Problem 2: cannot install the best update candidate for package eog-3.28.3-1.fc29.x86_64
      - package eog-3.28.3-1.module_2123+73a9ef6f.x86_64 is excluded
     Problem 3: cannot install the best update candidate for package exempi-2.4.5-3.fc29.x86_64
      - package exempi-2.4.5-3.module_2123+73a9ef6f.x86_64 is excluded
     Problem 4: cannot install the best update candidate for package libnghttp2-1.33.0-1.fc29.x86_64
      - package libnghttp2-1.33.0-1.module_2177+2526c218.x86_64 is excluded
     Problem 5: cannot install the best update candidate for package libpeas-1.22.0-9.fc29.x86_64
      - package libpeas-1.22.0-9.module_2123+73a9ef6f.x86_64 is excluded
     Problem 6: cannot install the best update candidate for package libpeas-gtk-1.22.0-9.fc29.x86_64
      - package libpeas-gtk-1.22.0-9.module_2123+73a9ef6f.x86_64 is excluded
     Problem 7: cannot install the best update candidate for package libpeas-loader-python3-1.22.0-9.fc29.x86_64
      - package libpeas-loader-python3-1.22.0-9.module_2123+73a9ef6f.x86_64 is excluded
     Problem 8: cannot install the best update candidate for package perl-HTTP-Tiny-0.076-1.fc29.noarch
      - package perl-HTTP-Tiny-0.076-1.module_2073+eebc5b71.noarch is excluded
     Problem 9: cannot install the best update candidate for package perl-Thread-Queue-3.13-1.fc29.noarch
      - package perl-Thread-Queue-3.13-1.module_2073+eebc5b71.noarch is excluded
    Nothing to do.
    Complete!
    It looks that the only option would be to uninstall bubblewrap with all its dependencies , and then install.

  7. #7
    Join Date
    Apr 2005
    Location
    Owatonna, Minnesota
    Posts
    143
    Linux Firefox 56.2.3

    Re: dnf problem after upgrade in place to fedora 29 pre beta

    This is not a recommended procedure, but it's one I've used when faced with similar situations. My first step is to download a copy of the currently installed version package I'm going to delete. Then I use rpm -e --nodeps to remove the package I want to upgrade. Then I install the upgrade, using either dnf (if no additional packages are going to be removed) or rpm. Again, this is not recommended and can definitely lead to a broken system (I speak from experience!). YMMV
    RockDoctor
    Registered Linux user #360200

  8. #8
    Join Date
    Oct 2005
    Location
    Puerto Rico
    Posts
    594
    Linux (Fedora) Firefox 62.0

    Re: dnf problem after upgrade in place to fedora 29 pre beta

    I actually uninstalled bubblewrap with all its dependencies and then reinstalled most of them, except for the following which I don't really needed:
    Code:
    cheese-2:3.30.0-2.fc29.x86_64                                                 
      evolution-help-3.30.0-1.fc29.noarch                                           
      gnome-clocks-3.30.0-3.fc29.x86_64                                             
      gnome-contacts-3.30-1.fc29.x86_64                                             
      gnome-documents-3.30.0-1.fc29.x86_64                                          
      gnome-documents-libs-3.30.0-1.fc29.x86_64                                     
      gnome-font-viewer-3.30.0-1.fc29.x86_64                                        
      gnome-initial-setup-3.29.92-1.fc29.x86_64                                     
      gnome-photos-3.30.0-1.fc29.x86_64                                             
      gnome-shell-extension-background-logo-3.24.0-6.fc29.noarch                    
      python2-notify-0.1.1-36.fc28.x86_64                                           
      totem-1:3.26.2-1.fc29.x86_64                                                  
      totem-nautilus-1:3.26.2-1.fc29.x86_64
    Then, I ran dnf clean all and dnf update, and got the same result

  9. #9
    Join Date
    Oct 2005
    Location
    Puerto Rico
    Posts
    594
    Linux (Fedora) Firefox 62.0

    Re: dnf problem after upgrade in place to fedora 29 pre beta

    Quote Originally Posted by rockdoctor
    This is not a recommended procedure, but it's one I've used when faced with similar situations. My first step is to download a copy of the currently installed version package I'm going to delete. Then I use rpm -e --nodeps to remove the package I want to upgrade. Then I install the upgrade, using either dnf (if no additional packages are going to be removed) or rpm. Again, this is not recommended and can definitely lead to a broken system (I speak from experience!). YMMV
    Hmmm... I will consider your solution, which makes perfect sense, but considering the odds I will wait for a while to see what future updates bring, before trying it.

  10. #10
    Join Date
    Oct 2011
    Posts
    1,895
    Linux Chrome 68.0.3440.106

    Re: dnf problem after upgrade in place to fedora 29 pre beta

    No, do not use --nodeps. --nodeps is useful in some cases, but not in this one. Also this has nothing to do with the original bug. See the devel mailing list thread for clues: https://www.spinics.net/lists/fedora...msg248008.html, https://www.spinics.net/lists/fedora...msg248031.html

  11. #11
    Join Date
    Oct 2005
    Location
    Puerto Rico
    Posts
    594
    Linux (Fedora) Firefox 62.0

    Re: dnf problem after upgrade in place to fedora 29 pre beta

    Quote Originally Posted by srakitnican
    No, do not use --nodeps. --nodeps is useful in some cases, but not in this one. Also this has nothing to do with the original bug. See the devel mailing list thread for clues: https://www.spinics.net/lists/fedora...msg248008.html, https://www.spinics.net/lists/fedora...msg248031.html
    Yep, definitely not the same bug. Sorry for invading this thread. I subscribed to the bug reports in bugzilla. From what I saw, dnf will still be able to updates packages, notwithstanding the alarming messages.

Similar Threads

  1. Upgrade Fedora 26 > 27 Beta?
    By fossiili in forum F27 Development Forum
    Replies: 23
    Last Post: 7th November 2017, 11:45 AM
  2. Want to test the beta (upgrade Fedora 22)
    By lsatenstein in forum F23 Development Forum
    Replies: 7
    Last Post: 5th October 2015, 08:30 PM
  3. Question about in place upgrade from f19-> f20
    By alphacrucis in forum F-20 Development Forum
    Replies: 3
    Last Post: 27th October 2013, 11:02 AM
  4. upgrade to Fedora 13 Beta
    By irvy in forum Fedora 13 Development Branch
    Replies: 8
    Last Post: 10th May 2010, 11:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •