[SOLVED] gnome-boxes crashes on launch
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 8 of 8
  1. #1
    Join Date
    Jul 2018
    Location
    SF Bay Area
    Posts
    12
    Linux (Fedora) Chrome 69.0.3497.81

    gnome-boxes crashes on launch

    Boxes worked great when I first installed Fedora 28. I didn't use it for a few weeks, but when I now try to launch the program immediately crashes again.

    When I try to launch from the terminal I get the following errors:
    Code:
    (gnome-boxes:3877): Gtk-WARNING **: 16:45:27.763: GtkFlowBox with a model will ignore sort and filter functions
    
    (gnome-boxes:3877): Gtk-WARNING **: 16:45:27.764: GtkListBox with a model will ignore sort and filter functions
    
    (gnome-boxes:3877): Libvirt.GObject-CRITICAL **: 16:45:28.864: gvir_storage_vol_get_info: assertion 'GVIR_IS_STORAGE_VOL(vol)' failed
    Segmentation fault (core dumped)
    A search suggested it might be a saved virtual machine that got corrupted, so I tried deleting ~/.config/gnome-boxes/sources/'QEMU Session' but that didn't make any difference.

    Any suggestions appreciated!

    My system info, if it helps:
    Code:
    System:
      Host: magnus-7370 Kernel: 4.17.19-200.fc28.x86_64 x86_64 bits: 64 
      compiler: gcc v: 8.1.1 Desktop: Gnome 3.28.3 
      Distro: Fedora release 28 (Twenty Eight) 
    Machine:
      Type: Laptop System: Dell product: Latitude 7370 v: N/A serial: <filter> 
      Mobo: Dell model: 077G26 v: A00 serial: <filter> UEFI: Dell v: 1.15.3 
      date: 12/11/2017 
    Battery:
      ID-1: BAT0 charge: 11.0 Wh condition: 40.5/43.0 Wh (94%) 
      model: SMP DELL N3KPR58 status: Discharging 
    CPU:
      Topology: Dual Core model: Intel Core m7-6Y75 bits: 64 type: MT MCP 
      arch: Skylake rev: 3 L2 cache: 4096 KiB 
      flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 12096 
      Speed: 700 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 709 2: 742 
      3: 726 4: 749 
    Graphics:
      Device-1: Intel HD Graphics 515 driver: i915 v: kernel bus ID: 00:02.0 
      Display: wayland server: Fedora Project X.org 11.0 driver: i915 
      resolution: 1536x864~60Hz 
      OpenGL: renderer: Mesa DRI Intel HD Graphics 515 (Skylake GT2) 
      v: 4.5 Mesa 18.0.5 direct render: Yes 
    Audio:
      Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel v: kernel 
      bus ID: 00:1f.3 
      Sound Server: ALSA v: k4.17.19-200.fc28.x86_64 
    Network:
      Device-1: Intel Wireless 8260 driver: iwlwifi v: kernel bus ID: 6c:00 
      IF: wlp108s0 state: up mac: <filter> 
      IF-ID-1: virbr0 state: down mac: <filter> 
      IF-ID-2: virbr0-nic state: down mac: <filter> 
    Drives:
      Local Storage: total: 119.24 GiB used: 15.65 GiB (13.1%) 
      ID-1: /dev/sda vendor: SK Hynix model: SC311 SATA 128GB size: 119.24 GiB 
      temp: 34 C 
    Partition:
      ID-1: / size: 48.97 GiB used: 9.80 GiB (20.0%) fs: ext4 dev: /dev/dm-1 
      ID-2: /boot size: 975.9 MiB used: 195.4 MiB (20.0%) fs: ext4 
      dev: /dev/sda2 
      ID-3: /home size: 59.20 GiB used: 5.64 GiB (9.5%) fs: ext4 dev: /dev/dm-3 
      ID-4: swap-1 size: 7.64 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-2 
    Sensors:
      System Temperatures: cpu: 44.0 C mobo: 28.0 C 
      Fan Speeds (RPM): N/A 
    Info:
      Processes: 284 Uptime: 2d 8h 11m Memory: 7.52 GiB used: 3.99 GiB (53.1%) 
      Init: systemd runlevel: 5 Compilers: gcc: 8.1.1 Shell: bash v: 4.4.23 
      inxi: 3.0.21

  2. #2
    Join Date
    Jul 2018
    Location
    SF Bay Area
    Posts
    12
    Windows NT 10.0 Chrome 68.0.3440.106

    Re: gnome-boxes crashes on launch

    Bump!

    I guess nobody has a solution for this. Is anyone also experiencing this issue though?

    Any suggestions for addition Boxes config files that I should try deleting to reset the application?

  3. #3
    Join Date
    Nov 2016
    Location
    Russia
    Posts
    3
    Linux Chrome 69.0.3497.100

    Re: gnome-boxes crashes on launch

    rename libvirt ?

  4. #4
    Join Date
    Jul 2018
    Location
    SF Bay Area
    Posts
    12
    Windows NT 10.0 Chrome 69.0.3497.100

    Re: gnome-boxes crashes on launch

    Quote Originally Posted by Reinhard Gehlen
    rename libvirt ?
    I did a search for libvirt, and there are a lot (A LOT) of files including "libvirt". I didn't see any in my user directory though, so I confess I'm not sure which file(s) I should rename..

  5. #5
    Join Date
    Nov 2016
    Location
    Russia
    Posts
    3
    Linux Chrome 69.0.3497.100

    Re: gnome-boxes crashes on launch

    I can be wrong: ~/.cache/libvirt

  6. #6
    Join Date
    Jul 2018
    Location
    SF Bay Area
    Posts
    12
    Linux (Fedora) Chrome 69.0.3497.92

    Re: gnome-boxes crashes on launch

    Quote Originally Posted by Reinhard Gehlen
    I can be wrong: ~/.cache/libvirt
    I tried renaming .cache/libvirt and .cache/gnome-boxes. Neither made a difference.

    Hmm, much as I like the simplicity of Boxes, I think at this point I may give up an try Virtualbox. [EDIT: tried VirtualBox. It installs, but fails to run with an error about lacking modules, missing kernel headers, bla bla bla. This is getting really old.]

  7. #7
    Join Date
    Nov 2016
    Location
    Russia
    Posts
    3
    Linux Chrome 69.0.3497.100

    Re: gnome-boxes crashes on launch

    /home/.config/libvirt?

  8. #8
    Join Date
    Jul 2018
    Location
    SF Bay Area
    Posts
    12
    Linux (Fedora) Chrome 69.0.3497.100

    Re: gnome-boxes crashes on launch

    Quote Originally Posted by Reinhard Gehlen
    /home/.config/libvirt?
    That did it! Thanks so much!

Similar Threads

  1. Bioshock crashes upon launch
    By L3l00 in forum Gamers' Lounge
    Replies: 1
    Last Post: 5th July 2012, 11:19 PM
  2. Fontmatrix 0.9.99 crashes on launch
    By JohnJasonJordan in forum Using Fedora
    Replies: 0
    Last Post: 26th November 2011, 06:48 AM
  3. open office crashes at launch fedora 12
    By leadtungstate in forum Using Fedora
    Replies: 14
    Last Post: 25th May 2011, 07:03 PM
  4. OpenOffice crashes on launch
    By dw5533 in forum Using Fedora
    Replies: 1
    Last Post: 14th April 2009, 03:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •