Can't connect to the internet after upgrade to Fedora 28
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 11 of 11
  1. #1
    Join Date
    Aug 2018
    Location
    CES?T
    Posts
    3
    Windows 7 Firefox 61.0

    Can't connect to the internet after upgrade to Fedora 28

    Hello,

    my internet connection doesn't work. When I ping any public IP, i just get connect: Network is unreachable. The network wizard shows the wireless configuration I have been using on Fedora 27 just as it used to be, and it also seems to detect the router, which is marked as active connection.

    It should be noted that there was another now solved problem after the upgrade, which consisted of always getting back to the login screen after entering the correct passwort when trying to use GNOME. Other WMs worked. The solution was to change a few folder and file permissions, because the upgrade has messed heavily with existing permissions. I would like to avoid to just chmod 777 everything, although that currently sounds promising.

    Any ideas?
    Thanks in advance!

  2. #2
    Join Date
    Dec 2017
    Location
    USA
    Posts
    21
    Windows 7 Firefox 63.0

    Re: Can't connect to the internet after upgrade to Fedora 28

    So I'll ask the "no duh" question - you're sure your router has access to the Internet through whatever ISP you use?

    I.E. is there internet access to be had? Your cable modem (or whatever) lights are blinking normally? Router is connected properly to the modem?

  3. #3
    Join Date
    May 2005
    Posts
    26
    Linux (Fedora) Firefox 61.0

    Re: Can't connect to the internet after upgrade to Fedora 28

    I have had the same issue with all my wireless units after upgrading to fedora 28, even though they worked with fedora 27.
    What I found was that there is an issue with protected management frames. I don't know where on your router the option hides.
    If you turn off PMF on the router the wireless comes back to life. Give it a try, it should work for you too.
    Granted, it's not the ideal solution, but it works here.
    (It's a hobby, but I like it)

  4. #4
    Join Date
    Aug 2018
    Location
    CES?T
    Posts
    3
    Windows 7 Firefox 61.0

    Re: Can't connect to the internet after upgrade to Fedora 28

    Quote Originally Posted by gmach24
    you're sure your router has access to the Internet
    Yes, I'm currently on the same machine booted to Windows. That's why I also rule out any hardware defect.
    Quote Originally Posted by DaleDonofrio
    If you turn off PMF on the router the wireless comes back to life.
    According to the support pages, my current router doesn't even support PMF. That's backed up by the fact that the option doesn't show up where more recent models are supposed to show it.

  5. #5
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    6,512
    Linux (Ubuntu) Firefox 61.0

    Re: Can't connect to the internet after upgrade to Fedora 28

    what network adaptor model are you using? it helps to be more verbose with details when asking for help

  6. #6
    Join Date
    Apr 2011
    Posts
    21
    Linux (Fedora) Chrome 68.0.3440.106

    Re: Can't connect to the internet after upgrade to Fedora 28

    Please return
    ip a
    or
    ifconfig -a

  7. #7
    Join Date
    Dec 2017
    Location
    USA
    Posts
    21
    Windows 7 Firefox 61.0

    Re: Can't connect to the internet after upgrade to Fedora 28

    "Other WMs worked."

    So, you are running Fedora 28 as a virtual machine?

    If so, it always helps to specify what vm software you're using and what is the base OS of the machine it's installed upon.

    I echo the admin who said more information is needed. e.g. it would have helped if you had made it clear you knew your Internet connection/router/etc work because you run Windows on this machine and can get access to the Internet.

    Also, you do not specify what - if any - steps you've taken to solve the problem - and how / why they failed.

    Doing so would help prevent duplicating steps you've already taken.

  8. #8
    Join Date
    Feb 2005
    Location
    London, UK
    Posts
    724
    Windows 7 Chrome 68.0.3440.106

    Re: Can't connect to the internet after upgrade to Fedora 28

    Quote Originally Posted by gmach24
    "Other WMs worked."

    So, you are running Fedora 28 as a virtual machine?
    Window Managers.

  9. #9
    Join Date
    Dec 2017
    Location
    USA
    Posts
    21
    Linux Firefox 64.0

    Re: Can't connect to the internet after upgrade to Fedora 28

    Ah, right. My mistake. Apologies.

  10. #10
    Join Date
    Aug 2018
    Location
    CES?T
    Posts
    3
    Windows 7 Firefox 61.0

    Re: Can't connect to the internet after upgrade to Fedora 28

    Quote Originally Posted by antikythera
    what network adaptor model are you using? it helps to be more verbose with details when asking for help
    Code:
    03:00.0 Ethernet controller: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet (rev c0)
    07:00.0 Network controller: Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express) (rev 01)
    Quote Originally Posted by fedotix
    Please return
    ip a
    or
    ifconfig -a
    ip a
    Code:
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host 
           valid_lft forever preferred_lft forever
    2: enp3s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
        link/ether XX:XX:XX:XX:XX:XX brd ff:ff:ff:ff:ff:ff
    3: wlp7s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
        link/ether YY:YY:YY:YY:YY:YY brd ff:ff:ff:ff:ff:ff
        inet 10.42.0.1/24 brd 10.42.0.255 scope global noprefixroute wlp7s0
           valid_lft forever preferred_lft forever
        inet6 fe80::bcf1:19a5:9b3e:258/64 scope link noprefixroute 
           valid_lft forever preferred_lft forever
    4: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
        link/ether ZZ:ZZ:ZZ:ZZ:ZZ:ZZ brd ff:ff:ff:ff:ff:ff
        inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
           valid_lft forever preferred_lft forever
    5: virbr0-nic: <BROADCAST,MULTICAST> mtu 1500 qdisc fq_codel master virbr0 state DOWN group default qlen 1000
        link/ether ZZ:ZZ:ZZ:ZZ:ZZ:ZZ brd ff:ff:ff:ff:ff:ff
    ifconfig -a
    Code:
    enp3s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
            ether XX:XX:XX:XX:XX:XX  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
            inet 127.0.0.1  netmask 255.0.0.0
            inet6 ::1  prefixlen 128  scopeid 0x10<host>
            loop  txqueuelen 1000  (Local Loopback)
            RX packets 184  bytes 14960 (14.6 KiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 184  bytes 14960 (14.6 KiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    virbr0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
            inet 192.168.122.1  netmask 255.255.255.0  broadcast 192.168.122.255
            ether ZZ:ZZ:ZZ:ZZ:ZZ:ZZ  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    virbr0-nic: flags=4098<BROADCAST,MULTICAST>  mtu 1500
            ether ZZ:ZZ:ZZ:ZZ:ZZ:ZZ  txqueuelen 1000  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    wlp7s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
            inet 10.42.0.1  netmask 255.255.255.0  broadcast 10.42.0.255
            inet6 fe80::bcf1:19a5:9b3e:258  prefixlen 64  scopeid 0x20<link>
            ether YY:YY:YY:YY:YY:YY  txqueuelen 1000  (Ethernet)
            RX packets 265  bytes 25504 (24.9 KiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 171  bytes 24416 (23.8 KiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    I took the liberty to censor the MAC address octets with XX, YY or ZZ. The same MAC adresses have been replaced with the same placeholder, respectively.

    Quote Originally Posted by gmach24
    I echo the admin who said more information is needed. e.g. it would have helped if you had made it clear you knew your Internet connection/router/etc work because you run Windows on this machine and can get access to the Internet.

    Also, you do not specify what - if any - steps you've taken to solve the problem - and how / why they failed.
    Apologies, it seems I have simply forgotten how to ask for help on forums. As for the steps, I admittedly haven't tried anything, because I didn't know where to start in this situation, and my research only led to people who had static IPs, while I have (or at least should have) DHCP.

    By the way, /etc/sysconfig/network is empty and has only one comment: "Created by anaconda". Shouldn't there be at least some kind of network configuration? I'm not familiar with Fedora's internals.

  11. #11
    Join Date
    Dec 2017
    Location
    USA
    Posts
    21
    Linux Firefox 64.0

    Re: Can't connect to the internet after upgrade to Fedora 28

    Did you resolve the problem?

    If not, can you sign in to your router via your wireless connection?

    Did you check your wireless configuration to make sure DHCP is enabled? (re: your comment "while I have (or at least should have) DHCP."]

    I assume you've checked the router to make sure DHCP is enabled there.

    Have you tried connecting with a cable to see if you can connect to the Internet running Fedora?

    [My /etc/sysconfig/network is the same as yours on Fedora 28 and I am connected.]

    There is a post on another fedora forum; some steps in here might help you figure out where your connection dies.

    https://ask.fedoraproject.org/en/que...i-no-internet/
    Last edited by gmach24; 14th September 2018 at 04:52 PM.

Similar Threads

  1. fedora does not connect to internet
    By vomfelsen in forum Servers & Networking
    Replies: 3
    Last Post: 3rd July 2013, 02:53 PM
  2. cant connect to internet via fedora 11
    By sanjiv in forum Servers & Networking
    Replies: 2
    Last Post: 3rd November 2009, 06:47 PM
  3. Connect internet on fedora 9
    By hitlar in forum Servers & Networking
    Replies: 0
    Last Post: 10th January 2009, 11:31 PM
  4. fedora 8 will not connect to internet
    By gatliffe in forum Servers & Networking
    Replies: 29
    Last Post: 15th January 2008, 03:15 PM
  5. Replies: 3
    Last Post: 16th October 2004, 03:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •