Boot displays just one dot and hangs - Page 2
FedoraForum.org - Fedora Support Forums and Community
Page 2 of 2 FirstFirst 1 2
Results 16 to 20 of 20
  1. #16
    Join Date
    Aug 2007
    Posts
    290
    Linux Firefox 52.0

    Re: Boot displays just one dot and hangs

    I do have a couple of questions. First there is a UUID that supposedly can't be found.

    Code:
    kern/disk.c:295: Closing `ahci0'.
    error: no such device: 3788f526-875a-4ca1-938c-56aa45c213d8.
    It would help greatly if we knew what this partition was. Please post the output of
    $ ls -l /dev/disk/by-uuid/
    when run from the live environment.

    Second why are you installing to the in-memory temporary file system ?

    grub2-install --debug --debug-image=all --boot-directory=/run/media/liveuser/_boot/ /dev/sda

  2. #17
    Join Date
    Mar 2009
    Posts
    105
    Linux (Fedora) Chrome 69.0.3497.100

    Re: Boot displays just one dot and hangs

    That UUID refers to the /boot partition of the new SSD. This is what blkid shows:

    /dev/sda1 3788f526-875a-4ca1-938c-56aa45c213d8 ext4 /boot

    When running the Live USB stick, I have mounted the /boot partition of the new SSD via the file manager. It uses /run/media/liveuser/_boot/ as the mount point.

  3. #18
    Join Date
    Mar 2009
    Posts
    105
    Linux (Fedora) Chrome 69.0.3497.100

    Re: Boot displays just one dot and hangs

    When I use ata.mod or pata.mod as the disk module for Grub, I get more debug output on booting - but the system hangs. For example, if I use command

    Code:
    grub2-install --debug --debug-image=all --disk-module=ata --boot-directory=/run/media/liveuser/_boot/ /dev/sda
    Then the system hangs at boot with this display:

    Click image for larger version. 

Name:	FJIMG_20181105_224322.jpg 
Views:	7 
Size:	248.0 KB 
ID:	29898

    So on booting, Grub can read the new SSD up to some point, but then it hangs???

  4. #19
    Join Date
    Jun 2011
    Location
    Thailand
    Age
    69
    Posts
    349
    Windows NT 10.0 Chrome 70.0.3538.77

    Re: Boot displays just one dot and hangs

    buy a new laptop easy fix
    ASRock model: X470 Taichi,AMD Ryzen 7 2700X Eight-Core,fedora28,64GB ram,asrock amd rx580

  5. #20
    Join Date
    Mar 2009
    Posts
    105
    Linux (Fedora) Chrome 69.0.3497.100

    Re: Boot displays just one dot and hangs

    Seems that when Grub is booting from the new SSD, it can read MBR and core.img from sector 1. So I made yet another experiment and embedded modules gzio.mod and normal.mod into core.img:

    Code:
    grub2-install --debug --debug-image=all --modules=gzio --modules=normal --disk-module=ata --boot-directory=/run/media/liveuser/_boot/ /dev/sda
    The system still hangs on booting. I think Grub is now reading grub.cfg:

    Click image for larger version. 

Name:	screenshot.jpg 
Views:	2 
Size:	149.3 KB 
ID:	29904

    The old version of Grub (Grub legacy or Grub 0.9x) had option --force-lba but I can't find it in Grub2??? I'm using Grub 2.02.

    I tested RAM of the laptop by running Memtest86+ 5.01 - the laptop passed the test.

Page 2 of 2 FirstFirst 1 2

Similar Threads

  1. Replies: 11
    Last Post: 30th December 2010, 03:16 PM
  2. Replies: 5
    Last Post: 25th March 2009, 12:26 AM
  3. F8 very slow to boot, hangs; Hangs on reinstall, too!
    By juanzo007 in forum Installation, Upgrades and Live Media
    Replies: 13
    Last Post: 19th January 2008, 09:17 AM
  4. boot hangs after fstab, shutdown hangs too (FC6 only)
    By Justincase in forum Using Fedora
    Replies: 5
    Last Post: 25th September 2006, 11:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •