Fedora 28 - Kernel 4.17.7 - Display immediately goes into powersave logging in gnome
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2018
    Location
    US
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Fedora 28 - Kernel 4.17.7 - Display immediately goes into powersave logging in gnome

    I have 3 displays, one in Landscape configuration, the other two in "Portrait Right" configuration on either side of it.

    This combination has worked well until just recently, after rebooting following a kernel upgrade to 4.17.7. The Gnome login screen appeared as normal on all three displays, but immediately after a successful log in the two displays configured "Portrait Right" immediately turn themselves off (go into power saving mode).

    Playing around with the settings I discovered that configuring all three displays to "Landscape" works correctly (all 3 stay on, work correctly), but I really need 2 of them in the portrait orientation.

    This is new behavior with 4.17.7.

    Any ideas how to resolve this?

  2. #2
    Join Date
    Jan 2017
    Location
    Posts
    101
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 28 - Kernel 4.17.7 - Display immediately goes into powersave logging in gn

    Quote Originally Posted by browseria
    I have 3 displays, one in Landscape configuration, the other two in "Portrait Right" configuration on either side of it.

    This combination has worked well until just recently, after rebooting following a kernel upgrade to 4.17.7. The Gnome login screen appeared as normal on all three displays, but immediately after a successful log in the two displays configured "Portrait Right" immediately turn themselves off (go into power saving mode).

    Playing around with the settings I discovered that configuring all three displays to "Landscape" works correctly (all 3 stay on, work correctly), but I really need 2 of them in the portrait orientation.

    This is new behavior with 4.17.7.

    Any ideas how to resolve this?

    This seems to be a bug in the latest version of mutter (3.28.3-1). If you have a look in the error logs you will find the following entry

    Code:
    Failed to set CRTC mode 1920x1080: No space left on device

    There's already a bug report for that issue: Error with screen rotate: Failed to set CRTC mode 1920x1080: No space left on device


    I had to downgrade mutter (3.28.1-1) in order to fix this issue temporarily.

    Code:
    dnf downgrade mutter

  3. #3
    Join Date
    Jul 2018
    Location
    US
    Posts
    2
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Re: Fedora 28 - Kernel 4.17.7 - Display immediately goes into powersave logging in gn

    Yes! Downgrading mutter restored the portrait monitor functionality! Thank you so much for you quick, courteous, detailed reply! It is much appreciated!

Similar Threads

  1. Replies: 0
    Last Post: 26th May 2018, 05:55 PM
  2. get logged out immediately gnome
    By Dandee in forum Using Fedora
    Replies: 8
    Last Post: 11th September 2014, 10:02 AM
  3. Fedora 16 - GNOME won't display with ATI 5450
    By Veeshush in forum Installation, Upgrades and Live Media
    Replies: 2
    Last Post: 9th November 2011, 11:49 PM
  4. Audio powersave in Fedora 11 bothering
    By rhoekstra in forum Using Fedora
    Replies: 0
    Last Post: 24th September 2009, 08:38 PM
  5. lost display when logging in FC-3
    By rswitzer in forum EOL (End Of Life) Versions
    Replies: 3
    Last Post: 31st December 2004, 06:40 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •