Pulling my hair out trying to get the Broadcom BCM94322HM8L card working
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 2 of 2
  1. #1
    Join Date
    Jul 2018
    Location
    Norway
    Posts
    1
    Linux Firefox 62.0

    Question Pulling my hair out trying to get the Broadcom BCM94322HM8L card working

    Hey!

    I bought this card off eBay and recieved it a few days ago. I wanted to try out a hackintosh, so I decided to install Mac OS alongside Fedora 28 on my laptop (Thinkpad X220). I had to get a new card to get wireless working on Mac OS, and this one seemed as good as any. I know the card works properly, as I am able to connect to wireless networks on Mac OS and I am getting the proper speeds I was expecting. Fedora on the other hand is a no-go The old card was an Intel Centrino Advanced-N 6205.

    In Gnome settings i only get a "No Wi-Fi adapter found" when I go to the Wi-Fi tab. I have quadruple checked the hardware switch is not the problem.

    I know the card is detected, since if I run lspci in the terminal, it shows up:
    Code:
     
    x220 ~ $ lspci | egrep -i network
    00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (Lewisville) (rev 04)
    03:00.0 Network controller: Broadcom Limited BCM4322 802.11a/b/g/n Wireless LAN Controller (rev 01)
    Running lshw gives me even more information about the card:
    Code:
    x220 ~ $ sudo lshw -class network
      *-network                 
           description: Ethernet interface
           product: 82579LM Gigabit Network Connection (Lewisville)
           vendor: Intel Corporation
           physical id: 19
           bus info: pci@0000:00:19.0
           logical name: enp0s25
           version: 04
           serial: f0:de:f1:f0:ca:33
           size: 1Gbit/s
           capacity: 1Gbit/s
           width: 32 bits
           clock: 33MHz
           capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
           configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k duplex=full firmware=0.13-3 ip=192.168.1.83 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
           resources: irq:27 memory:f2500000-f251ffff memory:f252b000-f252bfff ioport:5080(size=32)
      *-network
           description: Network controller
           product: BCM4322 802.11a/b/g/n Wireless LAN Controller
           vendor: Broadcom Limited
           physical id: 0
           bus info: pci@0000:03:00.0
           version: 01
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress bus_master cap_list
           configuration: driver=b43-pci-bridge latency=0
           resources: irq:17 memory:f2400000-f2403fff
      *-network:0 DISABLED
           description: Ethernet interface
           physical id: 2
           logical name: virbr0-nic
           serial: 52:54:00:0c:64:8a
           size: 10Mbit/s
           capabilities: ethernet physical
           configuration: autonegotiation=off broadcast=yes driver=tun driverversion=1.6 duplex=full link=no multicast=yes port=twisted pair speed=10Mbit/s
      *-network:1
           description: Ethernet interface
           physical id: 3
           logical name: virbr0
           serial: 52:54:00:0c:64:8a
           capabilities: ethernet physical
           configuration: broadcast=yes driver=bridge driverversion=2.3 firmware=N/A ip=192.168.122.1 link=no multicast=yes
    I have removed the packages I remember installing regarding the old Intel card with dnf.
    I have also tried installing broadcom-wl kmod-wl akmod-wl and other packages I have come over in old threads trying to solve this. Nothing has worked for me.
    Force loading the wl driver with modprobe does nothing either.

    By now I have tried so many different things I bet it's all just a mess, and this is my last restort. I hope someone on here has any experience with this and is able to give a helping hand.

  2. #2
    Join Date
    Dec 2013
    Location
    United Kingdom
    Posts
    6,390
    Linux Chrome 68.0.3440.75

    Re: Pulling my hair out trying to get the Broadcom BCM94322HM8L card working

    take a look at this, the same should work for Fedora 28, of course after any such driver changes you'll need to restart the PC to see any effect:

    https://www.tekbyte.net/install-broa...for-fedora-27/

Similar Threads

  1. If I had enough hair left on my head I'd be pulling it out about now..
    By AnotherUser in forum Reviews, Rants & Things That Make You Scream
    Replies: 8
    Last Post: 22nd July 2018, 01:21 PM
  2. Fedora 17 as router; pulling my hair out.
    By rcongdon in forum Servers & Networking
    Replies: 1
    Last Post: 9th September 2012, 08:40 AM
  3. PULLING OUT MY HAIR - NDISWRAPPER Broadcom Driver
    By ysbordain in forum Servers & Networking
    Replies: 20
    Last Post: 10th September 2007, 09:50 AM
  4. Linksys WMP54GS - Pulling my hair out
    By spc337 in forum Hardware & Laptops
    Replies: 11
    Last Post: 3rd May 2005, 04:35 PM
  5. pulling my hair out- kernel update
    By Scottiedog in forum Installation, Upgrades and Live Media
    Replies: 3
    Last Post: 3rd March 2005, 08:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •