FedoraForum.org - Fedora Support Forums and Community
Results 1 to 1 of 1
  1. #1
    Join Date
    Jul 2018
    Location
    NSW, Australia
    Posts
    1
    Windows 7 Firefox 61.0

    Lost Plymouth boot screen with kernels later than 4.17.3-200.fc28.i686

    Hi

    On an old laptop (Toshiba Tecra), using nouveau driver with onboard Nvidia display (has never had proprietary Nvidia drivers installed)

    Kernels 4.17.4-200.fc28.i686 and 4.17.5-200.fc28.i686 do not show Plymouth boot screen theme, defaulting to "text" fallback (3 little 'progress' bars)

    Plymouth boot screen theme worked (and still works) just fine on all kernels up to and including 4.17.3-200.fc28.i686

    I've tried "obvious" troubleshooting like recreating initrd with dracut, and forcing vga=xxx modes in grub, but no joy - this has me stumped.

    What's weird is 2 things:
    [1] It has worked fine prior to these kernel updates
    [2] With the newer kernels, very occasionally, only if the laptop is not properly shut down, it will sometimes show plymouth boot correctly one time only, but reverting to 'broken' on subsequent reboots... (bizarre...)

    Point [2] leads me to suspect somehow plymouth does not have nouveau DRM mode settings drivers, or framebuffer available, because maybe the "boot order" of modules/services has altered in some way, but I don't know how to troubleshoot this. I generated a /var/log/plymouth-debug.log (attached), but can't pinpoint the issue. It has:
    Code:
    [ply-device-manager.c:924]         ply_device_manager_activate_renderers:activating renderers
    [ply-boot-splash.c:479]                          ply_boot_splash_show:showing splash screen
    [./plugin.c:1610]                            show_splash_screen:loading logo image
    [./plugin.c:1614]                            show_splash_screen:loading star image
    [./plugin.c:1618]                            show_splash_screen:loading planet images
    [./plugin.c:1636]                            show_splash_screen:loading lock image
    [./plugin.c:1640]                            show_splash_screen:loading box image
    [./plugin.c:1645]                            show_splash_screen:couldn't load views
    [ply-boot-splash.c:485]                          ply_boot_splash_show:can't show splash: Success
    (this is attempting to use the "solar" theme, but default "charge" (the 'f' and filling the white 'pear' shape) doesn't work either)

    I can't figure out what is going wrong - particularly as it works fine on all but the 2 latest kernels.

    Any hints/pointers are very welcome.
    Attached Files Attached Files
    Last edited by Jim D; 14th July 2018 at 10:35 AM. Reason: fix typo

Similar Threads

  1. Replies: 0
    Last Post: 20th October 2016, 06:19 PM
  2. A start job is running for wait for plymouth boot screen to quit!!
    By wcurtiss75 in forum F22 Development Forum
    Replies: 0
    Last Post: 28th April 2015, 08:30 PM
  3. Starting Wait for Plymouth Boot Screen to quit
    By demetris in forum Using Fedora
    Replies: 9
    Last Post: 19th October 2011, 07:09 PM
  4. kernels following 2.6.27.12-170.2.5.fc10.i686 failing to boot on IBM Thinkpad 600E
    By WNorfleet in forum Installation, Upgrades and Live Media
    Replies: 0
    Last Post: 18th August 2009, 02:35 PM
  5. Plymouth Animated Boot Screen
    By freakystylie in forum Using Fedora
    Replies: 2
    Last Post: 9th February 2009, 02:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •