Fedora 27 - Can't install vim or vim-enahnced
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    May 2013
    Location
    Killroy1971
    Posts
    2
    Linux (Fedora) Firefox 61.0

    Angry Fedora 27 - Can't install vim or vim-enahnced

    Unless there was some massive change in the *nix world, only masochists want to use vi or vi-minimal. Yet the vim-minimal package is tied to the protected sudo package.

    Is there a way around this obviously incorrect dependency? The vi and vim editors have lived side by side on *nix systems for decades. Why start this non-sense up now?

  2. #2
    Join Date
    May 2013
    Location
    Killroy1971
    Posts
    2
    Linux (Fedora) Firefox 61.0

    Re: Fedora 27 - Can't install vim or vim-enahnced

    Workaround: But I don't like it

    I cobbled together a workaround, but it shouldn't have to be this way.

    First, remove the vim-minimal package the hard way:
    rpm -qa vim-minimal | xargs rpm -e --nodeps
    dnf -y install vim vim-enhanced
    dnf -y install vim-minimal

  3. #3
    Join Date
    Dec 2007
    Location
    Australia
    Posts
    1,857
    Linux Pale Moon 27.9.3

    Re: Fedora 27 - Can't install vim or vim-enahnced

    the vim-minimal package is tied to the protected sudo package.
    vim-minimal and sudo are default installations on my f28 machines, but dnf doesn't appear to show dependency of sudo on vim-minimal, or any vim, if that's what you mean.
    Code:
    [root@owl ~]# dnf deplist vim-minimal
    Last metadata expiration check: 0:01:57 ago on Sat 14 Jul 2018 09:54:36 AEST.
    package: vim-minimal-2:8.0.1704-1.fc28.x86_64
      dependency: libacl.so.1()(64bit)
       provider: libacl-2.2.53-1.fc28.x86_64
      dependency: libacl.so.1(ACL_1.0)(64bit)
       provider: libacl-2.2.53-1.fc28.x86_64
      dependency: libc.so.6(GLIBC_2.15)(64bit)
       provider: glibc-2.27-19.fc28.x86_64
      dependency: libselinux.so.1()(64bit)
       provider: libselinux-2.8-1.fc28.x86_64
      dependency: libtinfo.so.6()(64bit)
       provider: ncurses-libs-6.1-5.20180224.fc28.x86_64
      dependency: rtld(GNU_HASH)
       provider: glibc-2.27-19.fc28.i686
       provider: glibc-2.27-19.fc28.x86_64
    
    package: vim-minimal-2:8.1.177-1.fc28.x86_64
      dependency: libacl.so.1()(64bit)
       provider: libacl-2.2.53-1.fc28.x86_64
      dependency: libacl.so.1(ACL_1.0)(64bit)
       provider: libacl-2.2.53-1.fc28.x86_64
      dependency: libc.so.6(GLIBC_2.15)(64bit)
       provider: glibc-2.27-19.fc28.x86_64
      dependency: libselinux.so.1()(64bit)
       provider: libselinux-2.8-1.fc28.x86_64
      dependency: libtinfo.so.6()(64bit)
       provider: ncurses-libs-6.1-5.20180224.fc28.x86_64
      dependency: rtld(GNU_HASH)
       provider: glibc-2.27-19.fc28.i686
       provider: glibc-2.27-19.fc28.x86_64
    And dnf deplist sudo doesn't show vim as a dependency.

    I would think also that if you install vim-enhanced without having vim-minimal installed, that dnf would have vim-enhanced pull in vim-minimal as a dependency. However, all that being said, it's not unknown to me (and some others) for dnf to work in mysterious ways.
    Last edited by nsnbm; 14th July 2018 at 01:12 AM.

Similar Threads

  1. [SOLVED]
    Fresh install ofd Fedora 20 and having package install problems
    By kelean in forum Installation, Upgrades and Live Media
    Replies: 1
    Last Post: 24th December 2013, 08:18 AM
  2. Replies: 33
    Last Post: 6th May 2010, 12:23 PM
  3. Replies: 7
    Last Post: 28th May 2009, 07:20 AM
  4. Fedora 10 default install fails with ATI 4850 graphics card (but text install works)
    By Jeff72 in forum Installation, Upgrades and Live Media
    Replies: 1
    Last Post: 20th January 2009, 06:27 PM
  5. Trying to install Fedora 9, can't enter GUI install + no driver found
    By Adamantus in forum Installation, Upgrades and Live Media
    Replies: 9
    Last Post: 9th November 2008, 05:23 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •