FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    Jan 2012
    Location
    Amsterdam
    Posts
    3
    Linux (Fedora) Chrome 67.0.3396.99

    Fedora 28 suspend issues on Thinkpad X1 Yoga

    I have recently installed Fedora 28 workstation on my brand new X1 Yoga ( 3rd generation). Everything works pretty well, besides suspending when I close the lid, which is quite important when working from a laptop. The little red light that's part of the ThinkPad logo starts blinking, which seems to indicate suspend mode is on. When I reopen the lid though I notice that the battery is suprisingly quite warm, and it lost quite some charge while it was in suspend mode. Also, the time goes forward by two hours, which I think has to do with my timezone given that I am in GMT+2. To fix the time problem I need to either restart the laptop or fiddle with Date/Time settings by disabling and re-enabling back NTP and automatic timezone.

    I read about similar issues, yet not quite the same as in many of those cases the laptop does not even enter suspend mode when the lid is closed, while in my case everything "seems" to work. And the time problem, I couldn't find anybody with this problem yet. I read about having to fiddle to active S3 deep sleep, but I am wondering if I need to do that. The first thing that was suggested in those instructions was to modify some option in the BIOS which ended up slowing down the boot time by 10 minutes, so I immediately reverted that.

    What do you think I could try?

  2. #2
    Join Date
    May 2015
    Location
    USA
    Posts
    2
    Linux (Fedora) Firefox 61.0

    Re: Fedora 28 suspend issues on Thinkpad X1 Yoga

    Lenovo's BIOS does not include S3 suspend, instead it has S0i3 version needed by newer Windows. It seems that Lenovo says the two are incompatible and refuses to create a BIOS that allows a choice between the two. There is a patch for DSDT tables that allows for S3 sleep at the following link
    https://delta-xi.net/#056
    The post also has a link to a shorter patch (that may or may not be specific for Yoga).
    There is also a thread with discussion here: https://bbs.archlinux.org/viewtopic.php?id=234913&p=1
    The original patch gave me some compiling errors, the shorter one may work right away, but I am not sure which version worked in the end (one of the reasons for linking the whole discussion).

    With the patch, the sleep works but I have one issue: when the laptop wakes up, it does not see stylus or finger touch devices. It works better (maybe even reliably) with "systemctl hybrid-sleep" instead of "systemctl suspend". If you loose your touch/stylus devices and don't want to reboot, there is an ugly workaround: as root (sudo did not work for me) run "sudo echo s2idle > /sys/power/mem_sleep", suspend, wake the laptop up, run sudo echo deep > /sys/power/mem_sleep" to restore S3 suspend. I'm sure there is a better way to find the devices but I don't know what it is.

    Quote Originally Posted by lucacavanna
    I have recently installed Fedora 28 workstation on my brand new X1 Yoga ( 3rd generation). Everything works pretty well, besides suspending when I close the lid, which is quite important when working from a laptop. The little red light that's part of the ThinkPad logo starts blinking, which seems to indicate suspend mode is on. When I reopen the lid though I notice that the battery is suprisingly quite warm, and it lost quite some charge while it was in suspend mode. Also, the time goes forward by two hours, which I think has to do with my timezone given that I am in GMT+2. To fix the time problem I need to either restart the laptop or fiddle with Date/Time settings by disabling and re-enabling back NTP and automatic timezone.

    I read about similar issues, yet not quite the same as in many of those cases the laptop does not even enter suspend mode when the lid is closed, while in my case everything "seems" to work. And the time problem, I couldn't find anybody with this problem yet. I read about having to fiddle to active S3 deep sleep, but I am wondering if I need to do that. The first thing that was suggested in those instructions was to modify some option in the BIOS which ended up slowing down the boot time by 10 minutes, so I immediately reverted that.

    What do you think I could try?

  3. #3
    Join Date
    Jan 2012
    Location
    Amsterdam
    Posts
    3
    Linux (Fedora) Chrome 67.0.3396.99

    Re: Fedora 28 suspend issues on Thinkpad X1 Yoga

    Thanks a lot for the pointers, that was really useful. I managed to make S3 deep sleep work on my Yoga. I have the same problem as you with touch devices, I am not too concerned about that at the moment though. I have written a summary of the steps I followed as I had to make some adjustments: https://gist.github.com/javanna/38d0...c784597bc7ec73 .

Similar Threads

  1. ThinkPad Yoga 11e Touchpad not working
    By baberaham in forum Hardware & Laptops
    Replies: 2
    Last Post: 27th May 2018, 12:56 AM
  2. Almost there with a Thinkpad X1 Yoga
    By flagre in forum Hardware & Laptops
    Replies: 0
    Last Post: 15th January 2017, 08:02 AM
  3. Thinkpad YOGA S1 F22 woes
    By Cygn in forum Using Fedora
    Replies: 5
    Last Post: 13th August 2015, 11:54 PM
  4. thinkpad yoga clickpad
    By backman in forum Hardware & Laptops
    Replies: 0
    Last Post: 22nd January 2015, 08:41 PM
  5. Suspend issues on Thinkpad X300
    By jasonw522 in forum Hardware & Laptops
    Replies: 3
    Last Post: 1st December 2008, 05:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •