[SOLVED] login window not starting on boot
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2018
    Location
    Canada
    Posts
    10
    Linux (Fedora) Chrome 66.0.3359.181

    login window not starting on boot

    Hi there!

    I have messed up something
    TL;DR:
    On boot, I am not getting login window, just console. I am able to login into console and type 'sudo init 5' and it all goes fine. How do put it back to normal so I can see login window during boot time automatically ?


    If that helps - a back story of how i messed up:
    I was running F27 with Nvidia drivers from rpm fusion and just installed cuda from Nvidia website. It was all good, but one day when updating system, i got message of cuda-driver being in conflict. Blindly i have chosen '--best --allowerasing' and from that moment i could not turn on my system. In console I've tried to remove all cuda\* and nvidia \* drivers to reinstall them, but something was blocking me from doing so, as i still had nvidia-drm modules and i could not remove them (something was blocking it from removal)
    From one website I saw a suggestion to run 'sudo systemctl stop system-logind' and indeed that help, i was able to 'rmmod nvidia_drm, nvidia and nvidia_modeset'
    I've reinstalled nvidia driver from Nvidia website and run 'sudo systemctl start systemd-logind' after but still I was not able to open X.
    After that point login window was not showing up and even worse - when I typed 'sudo init 5' I was getting message 'something went wrong, please restart'...
    After few more attempts of reinstalling nvidia drivers from different sources I gave up and decided to to stupid (?) move, hoping that it may overwrite messed up configs:
    I have updaged from F27 -> F28 .. no biggie, all went smoothish(some issues with nss-pem but i found workaround).
    Now, I'm writing this message from F28 so update went good. But unfortunately, still, when I am logging in, login window is not starting up. I am not getting any error, so I guess I just need to enable something ?

    Code:
     >  systemctl status systemd-logind
    ● systemd-logind.service - Login Service
       Loaded: loaded (/usr/lib/systemd/system/systemd-logind.service; static; vendor preset: disabled)
       Active: active (running) since Sun 2018-07-08 10:47:17 PDT; 22min ago
         Docs: man:systemd-logind.service(8)
               man:logind.conf(5)
               https://www.freedesktop.org/wiki/Software/systemd/logind
               https://www.freedesktop.org/wiki/Software/systemd/multiseat
     Main PID: 1300 (systemd-logind)
       Status: "Processing requests..."
        Tasks: 1 (limit: 4915)
       Memory: 6.4M
       CGroup: /system.slice/systemd-logind.service
               └─1300 /usr/lib/systemd/systemd-logind
    
    Jul 08 10:47:16 tmwork systemd-logind[1300]: Watching system buttons on /dev/input/event0 (Power Button)
    Jul 08 10:47:17 tmwork systemd-logind[1300]: Watching system buttons on /dev/input/event2 (Logitech Logitech Illuminated Keyboard)
    Jul 08 10:47:17 tmwork systemd-logind[1300]: Watching system buttons on /dev/input/event3 (Logitech Logitech Illuminated Keyboard)
    Jul 08 10:47:17 tmwork systemd[1]: Started Login Service.
    Jul 08 10:52:29 tmwork systemd-logind[1300]: New session 1 of user ats.
    Jul 08 10:52:38 tmwork systemd-logind[1300]: Removed session 1.
    Jul 08 10:52:38 tmwork systemd-logind[1300]: New session c1 of user gdm.
    Jul 08 10:52:39 tmwork systemd-logind[1300]: Removed session c1.
    Jul 08 10:52:39 tmwork systemd-logind[1300]: New session c2 of user gdm.
    Jul 08 10:52:51 tmwork systemd-logind[1300]: New session 5 of user ats.
    Code:
     cat /var/log/Xorg.0.log
    [   329.628] (--) Log file renamed from "/var/log/Xorg.pid-2439.log" to "/var/log/Xorg.0.log"
    [   329.630] 
    X.Org X Server 1.19.6
    Release Date: 2017-12-20
    [   329.630] X Protocol Version 11, Revision 0
    [   329.630] Build Operating System:  4.15.3-300.fc27.x86_64 
    [   329.630] Current Operating System: Linux tmwork 4.17.3-200.fc28.x86_64 #1 SMP Tue Jun 26 14:17:07 UTC 2018 x86_64
    [   329.630] Kernel command line: BOOT_IMAGE=/vmlinuz-4.17.3-200.fc28.x86_64 root=/dev/mapper/fedora-root ro rd.driver.blacklist=nouveau rd.lvm.lv=fedora/root rd.lvm.lv=fedora/swap rhgb quiet rd.driver.blacklist=nouveau LANG=en_US.UTF-8
    [   329.630] Build Date: 23 April 2018  06:16:50PM
    [   329.630] Build ID: xorg-x11-server 1.19.6-8.fc28 
    [   329.630] Current version of pixman: 0.34.0
    [   329.630] 	Before reporting problems, check http://wiki.x.org
    
    ...
    
    [   335.673] (--) NVIDIA(GPU-0): 
    [   335.673] (--) NVIDIA(GPU-0): DFP-7: disconnected
    [   335.673] (--) NVIDIA(GPU-0): DFP-7: Internal TMDS
    [   335.673] (--) NVIDIA(GPU-0): DFP-7: 165.0 MHz maximum pixel clock
    [   335.673] (--) NVIDIA(GPU-0): 
    [   341.998] (**) Option "fd" "33"
    [   341.998] (II) event1  - Power Button: device removed
    [   341.998] (**) Option "fd" "36"
    [   341.998] (II) event0  - Power Button: device removed
    [   341.999] (**) Option "fd" "37"
    [   341.999] (II) event2  - Logitech Logitech Illuminated Keyboard: device removed
    [   341.999] (**) Option "fd" "38"
    [   342.001] (**) Option "fd" "41"
    [   342.001] (II) event6  - Wacom Intuos5 touch M Finger: device removed
    [   342.001] (**) Option "fd" "38"
    [   342.001] (II) event3  - Logitech Logitech Illuminated Keyboard: device removed
    [   342.317] (II) systemd-logind: got pause for 13:68
    [   342.317] (II) systemd-logind: got pause for 13:70
    [   342.317] (II) systemd-logind: got pause for 13:64
    [   342.317] (II) systemd-logind: got pause for 13:66
    [   342.317] (II) systemd-logind: got pause for 13:65
    [   342.317] (II) systemd-logind: got pause for 13:69
    [   342.317] (II) systemd-logind: got pause for 13:67

    Code:
    >  cat /var/log/boot.log 
    
    ....
    
    [   66.967311] dnf[1129]: Running transaction
    [  OK  ] Created slice User and Session Slice.
             Starting Login Service...
    [  OK  ] Started Login Service.
    [  OK  ] Started Login Service.
    [  OK  ] Started firewalld - dynamic firewall daemon.
    [  OK  ] Reached target Network (Pre).
             Starting Network Manager...
    [  OK  ] Started Builds and install new kernel modules through DKMS.
    [  OK  ] Started Network Manager.
    [  OK  ] Reached target Network.
    [  OK  ] Started Logout off all iSCSI sessions on shutdown.
             Starting MySQL Server...
    [  OK  ] Reached target Remote File Systems (Pre).
    [  OK  ] Reached target Remote File Systems.
             Starting Virtualization daemon...
             Starting Permit User Sessions...
             Starting OpenSSH server daemon...
             Starting Network Manager Wait Online...
             Starting Network Manager Script Dispatcher Service...
    [  OK  ] Started Permit User Sessions.
    [  OK  ] Started Command Scheduler.
             Starting Terminate Plymouth Boot Screen...
             Starting Hold until boot process finishes up...
    [  OK  ] Started Job spooling tools.
    [  OK  ] Started Network Manager Script Dispatcher Service.
    [  OK  ] Started OpenSSH server daemon.
             Starting Network Manager Script Dispatcher Service...
    [  OK  ] Started Permit User Sessions.
    [  OK  ] Started Job spooling tools.
             Starting Terminate Plymouth Boot Screen...
    [  OK  ] Started Command Scheduler.
             Starting Hold until boot process finishes up...
    [  OK  ] Started Network Manager Script Dispatcher Service.
    [  OK  ] Started OpenSSH server daemon.

  2. #2
    Join Date
    Apr 2018
    Location
    Finland
    Posts
    102
    Linux (Fedora) Chrome 67.0.3396.79

    Re: login window not starting on boot

    I don't know anything about this stuff, but have you tried 'init --unit=5' (or something like that), in man that looks like what you are looking for.
    Last edited by keikari; 8th July 2018 at 08:03 PM.

  3. #3
    Join Date
    Jul 2018
    Location
    Canada
    Posts
    10
    Linux (Fedora) Chrome 66.0.3359.181

    Re: login window not starting on boot

    Thanks @keikari!

    After your post I did some more digging in that direction and I solved my problem with:

    Code:
    >  systemctl get-default 
    multi-user.target
     >  systemctl set-default graphical.target
    Removed /etc/systemd/system/default.target.
    Created symlink /etc/systemd/system/default.target → /usr/lib/systemd/system/graphical.target.
    Found here: https://www.tecmint.com/change-runle...ts-in-systemd/

Similar Threads

  1. [SOLVED]
    can i get a root login option on login window
    By davec33 in forum Using Fedora
    Replies: 4
    Last Post: 20th January 2011, 07:12 PM
  2. login window "can i change my login screen in fedora 10
    By oshan1991 in forum Using Fedora
    Replies: 15
    Last Post: 31st October 2009, 12:11 PM
  3. Replies: 1
    Last Post: 8th June 2009, 04:27 PM
  4. login background loaded, but no login window!
    By netweblogic in forum Using Fedora
    Replies: 0
    Last Post: 6th October 2008, 12:26 PM
  5. Not able to boot(No login window)
    By sharathkumaru in forum Installation, Upgrades and Live Media
    Replies: 14
    Last Post: 13th September 2008, 11:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •