[SOLVED] F28 update-grub does not pick up full openSUSE command line
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 12 of 12
  1. #1
    Join Date
    Jan 2006
    Posts
    160
    Linux (Android 7.0) Chrome 67.0.3396.87

    F28 update-grub does not pick up full openSUSE command line

    Starting from F28 grub2 does not pick up the full openSUSE command line. To get USB3 to function on my PC I need to add "iommu=soft". Therefor I have to add openSUSE to the /etc/grub.d/40_Custom file. With openSUSE the full Fedora command line is picked up.

    For about 2 years I have had the same problem with Kubuntu and Linux Mint, that update-grub does not pick up the full command line for Fedora and openSUSE. What is happening??

  2. #2
    Join Date
    Jan 2006
    Posts
    160
    Linux (Android 7.0) Chrome 67.0.3396.87

    Re: F28 update-grub does not pick up full openSUSE command line

    Am I really the only one to have experienced this dual boot problem??

  3. #3
    Join Date
    Jun 2005
    Location
    Montreal, Que, Canada
    Posts
    5,480
    Linux (Fedora) Firefox 61.0

    Re: F28 update-grub does not pick up full openSUSE command line

    My primary boot is Fedora 28, but I dual boot with Tumbleweed, both gnome and kde. I have no problems.

    Perhaps you need to try, using openSUSE

    sudo grub2-install /dev/sdx where x is the openSuse disk drive.
    You may have chosen to not install the boot loader into the mbr.
    Last edited by lsatenstein; 13th July 2018 at 07:37 PM.
    Leslie in Montreal

    Interesting web sites list
    http://forums.fedoraforum.org/showth...40#post1697840

  4. #4
    Join Date
    Jan 2006
    Posts
    160
    Linux (Android 7.0) Chrome 67.0.3396.87

    Re: F28 update-grub does not pick up full openSUSE command line

    Thanks Leslie! My Linux partitions are on a GPT disk, and when I get away with (usually nowadays) I upgrade rather than fresh install. I am not quite sure but I think I installed the openSUSE boot loader to /dev/sdb7 rather than to /dev/sdb

    Anyway did "sudo grub2-install /dev/sdb" which seemed successful. Reboted to Fedora 28 to do "update-grub" but the kernel command line still does not contain "iommu=soft"

  5. #5
    Join Date
    Jan 2006
    Posts
    160
    Linux (Android 7.0) Chrome 67.0.3396.87

    Re: F28 update-grub does not pick up full openSUSE command line

    In Opensuse I tried hashing the entry: #GRUB_USE_LINUXEFI="true" in etc/default/grub. After update-grub the commands linuxefi and initrdefi were replaced by linux and initrd. With this Kubuntu and Linux Mint (after update-grub) show the full Opensuse command line!

    Tried the same with Fedora which did not have an entry to hash, so instead entered GRUB_USE_LINUXEFI="false" but this did not change the commands linuxefi and initrdefi. Replaced them manually. Kubuntu, Linux Mint and Opensuse (after update-grub) now show the full Fedora command line. But update-grub in Fedora changes back to linuxefi and initrdefi. What to do?

  6. #6
    Join Date
    Jan 2006
    Posts
    160
    Windows NT 10.0 Chrome 68.0.3440.106

    Re: F28 update-grub does not pick up full openSUSE command line

    Have struggled further with this issue, and documented it here https://goo.gl/c9zqpF What surprises me as that noone else seem to experience this issue - which makes me suspect that I have done something wrong. Anyway, will probably change default to the openSUSE bootmenu

  7. #7
    Join Date
    Dec 2017
    Location
    Sosnowiec, PL
    Age
    36
    Posts
    43
    Linux Firefox 61.0

    Re: F28 update-grub does not pick up full openSUSE command line

    If I understand correctly OpenSUSE resides on another HDD and has it's own /boot/grub2/grub.cfg file which is updated on every kernel update / change, etc.

    If yes, then in Fedora's /etc/grub.d/40_custom you can point out / indicate for SUSE's grub.cfg file without any additional tuning changes. Fedora's Grub2 will fire up SUSE Grub2 configuration with its own stock and desired parametres, etc.

    Example for Fedora's Grub2 config file on Arch Linux Grub2 /etc/grub.d/40_custom file:
    Code:
    menuentry "Fedora 28" {
      insmod ext2
      insmod part_gpt
      search --set=root --label fedora --hint hd1,gpt3
      configfile /boot/grub2/grub.cfg
    }
    Last edited by marcin82; 10th August 2018 at 12:15 PM.
    marcin82

  8. #8
    Join Date
    Jan 2006
    Posts
    160
    Linux (Android 7.0) Chrome 68.0.3440.91

    Re: F28 update-grub does not pick up full openSUSE command line

    Thanks Marcin82 OpenSUSE, Fedora and Kubuntu have a partition each on the same HDD, GPT drive, and each has its own grub.cfg and I can choose which one to use to boot (yes the options are the same in all three). As I explained in the blog (link above) I have used 40_Custom for 18 months, but am fed up of having to edit 40_Custom on three distros as soon as one of them has a kernel upgrade. So I was hoping to do away with 40_Custom editing.

    But your suggestion does away with having to edit the three 40_Customs files. Will try it! And try the GRUB_OS_PROBER_SKIP_LIST=UUID@/dev/sdbx for the redundent entries. Thanks!

  9. #9
    Join Date
    Dec 2017
    Location
    Sosnowiec, PL
    Age
    36
    Posts
    43
    Linux Firefox 61.0

    Re: F28 update-grub does not pick up full openSUSE command line

    Just set up one for all in every Grub's /etc/default/grub file:
    Code:
    GRUB_DISABLE_OS_PROBER=true
    Last edited by marcin82; 10th August 2018 at 04:54 PM.
    marcin82

  10. #10
    Join Date
    Jan 2006
    Posts
    160
    Linux (Android 7.0) Chrome 68.0.3440.91

    Re: F28 update-grub does not pick up full openSUSE command line

    It worked very well! Have yet to decide on which of the options to use to skip partitions from the os probe (both work). Thank you Marcin82!

  11. #11
    Join Date
    Jun 2005
    Location
    Montreal, Que, Canada
    Posts
    5,480
    Linux (Fedora) Firefox 61.0

    Re: F28 update-grub does not pick up full openSUSE command line

    with open SUSE, I ran the grub-install /dev/sdx and then from the primary boot
    I ran grub2-mkconfig /boot/grub2/grub.cfg

    Thereafter, everything was OK either way.
    Leslie in Montreal

    Interesting web sites list
    http://forums.fedoraforum.org/showth...40#post1697840

  12. #12
    Join Date
    Jan 2006
    Posts
    160
    Linux (Android 7.0) Chrome 68.0.3440.91

    Re: F28 update-grub does not pick up full openSUSE command line

    My problem was not with openSUSE but that the other distros did not pick up its kernel parameters

Similar Threads

  1. [SOLVED]
    GRUB :: menu.lst :: GRUB starts in command line
    By cinsevarg in forum Using Fedora
    Replies: 4
    Last Post: 3rd December 2010, 08:21 PM
  2. GRUB Command Line
    By splattice in forum Using Fedora
    Replies: 17
    Last Post: 20th June 2009, 03:18 PM
  3. Booting to a GRUB command line ??
    By Focal in forum Using Fedora
    Replies: 6
    Last Post: 27th November 2006, 08:25 AM
  4. grub only a command line now after fc3 to fc5
    By storlied in forum EOL (End Of Life) Versions
    Replies: 9
    Last Post: 22nd March 2006, 12:25 PM
  5. Replies: 4
    Last Post: 3rd March 2006, 09:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •