[SOLVED] How to disable the time limit for password typing in tty terminal ?
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 4 of 4
  1. #1
    Join Date
    Aug 2016
    Location
    Iraq
    Posts
    934
    Linux (Fedora) Firefox 61.0

    How to disable the time limit for password typing in tty terminal ?

    Hi.

    By default, when I use tty terminal, it give me 60 second waiting time to enter my password for account. If time limit exceeded, then it will ask me to re-enter user name. I like to disable this behavior making tty terminal do exactly like GUI terminal: waiting me for ever till I complete typing the password.

    I run:

    man login

    & read page carefully. It said:
    man login


    CONFIG FILE ITEMS
    login reads the /etc/login.defs(5) configuration file. Note that the
    configuration file could be distributed with another package (e.g.
    shadow-utils). The following configuration items are relevant for
    login(1):

    ...

    LOGIN_TIMEOUT (number)
    Max time in seconds for login. The default value is 60.

    LOGIN_RETRIES (number)
    Maximum number of login retries in case of a bad password. The
    default value is 3.
    But when I run:

    $ vi /etc/login.defs

    to inspect contents of this file before run command as sudo, but I did not find the above 2 entries ! I did not find "LOGIN_TIMEOUT 60" !

    Any help, kindly ?
    Fedora 28 X64 bit Cinnamon edition on Lenovo ThinkPad e550 with Intel core i7 5500 CPU @ 2.40 GH X 2, RAM = 8 GB, HHD = 1 TB, Hybrid VGA (Intel Corporation HD Graphic 5500 + Radeon R7 M265 2GB)

  2. #2
    Join Date
    Dec 2007
    Location
    Australia
    Posts
    1,840
    Linux Pale Moon 27.9.3

    Re: How to disable the time limit for password typing in tty terminal ?

    Perhaps you could add the configuration: LOGIN_TIMEOUT 120, to the login.defs files and see if it gives you 2 minutes to enter the password.

  3. #3
    Join Date
    Aug 2016
    Location
    Iraq
    Posts
    934
    Linux (Fedora) Firefox 61.0

    Re: How to disable the time limit for password typing in tty terminal ?

    Hi. Issue solved ! Just few minutes ago I got the enough courage to touch system file & edit it, after confirming the solution in many web sites. I'm very conservative with system file editing ......

    Fix as following:

    Code:
    sudo vi /etc/login.defs
    then add the following line at the end of file:

    LOGIN_TIME 0
    The end of my file became as following:

    Code:
    # Login timeout.
    LOGIN_TIMEOUT 0
    I just put a comment (blue color) before option line. This is totally optional.

    The confusion was due to that "LOGIN_TIMEOUT 60" (which is the default value) not written within the file ! The developer make this equivalent to the case when "LOGIN_TIMEOUT 60" is written in the file !

    The behavior of tty terminal completely changed
    now as following: it will ask you to enter user name. When you enter it, it will ask you to enter password for that user. It will wait you for infinite time till you type password then hit enter.

    BUT BE WARE: if you enter wrong password, it will never ask you to re-type it again ! But, it will ask you to re-enter a user name again ! So, please, in the last case, do not make a mistake & enter your password again. If you do so it will be entered decrypted & this will be risky & you should change password. Fortunately, I escape this mistake. I enter password wrongly, then I started to re-type password, but fortunately, I saw 1st 2 characters of it decrypted & at this time I realized that tty terminal resking me user name not password, so undo 1st 2 character of password & never hit enter unless after re-type my user name, then entered correct password.

    One my ask: why all this ? This will be very useful if you like me set your root password (su) by 70 characters (upper+lower cases+numbers+special characters). Who of you set such long complex su password?
    Fedora 28 X64 bit Cinnamon edition on Lenovo ThinkPad e550 with Intel core i7 5500 CPU @ 2.40 GH X 2, RAM = 8 GB, HHD = 1 TB, Hybrid VGA (Intel Corporation HD Graphic 5500 + Radeon R7 M265 2GB)

  4. #4
    Join Date
    Jul 2018
    Location
    NSW, Australia
    Posts
    24
    Windows 7 Firefox 61.0

    Re: How to disable the time limit for password typing in tty terminal ?

    Quote Originally Posted by User808
    The confusion was due to that "LOGIN_TIMEOUT 60" (which is the default value) not written within the file ! The developer make this equivalent to the case when "LOGIN_TIMEOUT 60" is written in the file !
    Well, that's what a default value is - a value which the software will use if you don't supply an alternative in a config file, command line or otherwise... Sure, some config files are installed with most of the defaults detailed, or commented, but by no means all are installed this way - that's when you need to RTFM, or google if you're unlucky and even the manual doesn't document it. We live in an imperfect world...

Similar Threads

  1. How to disable touchpad while typing?
    By RavanH in forum Hardware & Laptops
    Replies: 18
    Last Post: 26th April 2012, 09:34 AM
  2. Disable touchpad when typing
    By Akaly in forum Hardware & Laptops
    Replies: 2
    Last Post: 29th October 2010, 09:39 AM
  3. Disable whilst typing
    By yeleek in forum Using Fedora
    Replies: 2
    Last Post: 9th April 2009, 01:16 PM
  4. Disable trackpad while typing?
    By ggulik in forum Hardware & Laptops
    Replies: 2
    Last Post: 15th June 2007, 05:15 AM
  5. Disable touchpad while typing
    By mitchell2345 in forum Hardware & Laptops
    Replies: 8
    Last Post: 1st March 2007, 09:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •