"Starting WPA supplicant..." error on install F28
FedoraForum.org - Fedora Support Forums and Community
Results 1 to 6 of 6
  1. #1
    Join Date
    Jul 2018
    Location
    Johannesburg
    Posts
    2
    Windows NT 10.0 Chrome 67.0.3396.99

    "Starting WPA supplicant..." error on install F28

    I'm surely a newbee on linux and I want to install Fedora on HP ZBook G3. I downloaded Fedora Media Write and Fedora-Workstation-Live-x86_64-28-1.1 and made a usb stick to install. However I face a problem on every try with a message "Starting WPA supplicant...". I tried to disable all extra devices and then tried to install again. That time installation stuck at the same point without that error message.

    After waiting for a little bit long time, watchdog messages started to rain with [libvirtd:1649].

    Please help me? How can I install fedora on that notebook?

  2. #2
    Join Date
    Jan 2013
    Location
    Ventura, CA
    Posts
    421
    Linux (Fedora) Firefox 61.0

    Re: "Starting WPA supplicant..." error on install F28

    First of all, verify the checksum of your iso: https://getfedora.org/verify

    If it checks out okay, I would recommend that you install the iso onto your usb drive using dd: "# dd if=/path/to/iso of=/path/to/usb/drive BS=4M". Double check the path to your usb drive before running this command by using: "# fdisk -l". If you place the wrong path in of=/path/to/usb/drive, you could erase another install or lose some data, so be very careful with dd.

  3. #3
    Join Date
    Jul 2018
    Location
    Johannesburg
    Posts
    2
    Windows NT 10.0 Chrome 67.0.3396.99

    Re: "Starting WPA supplicant..." error on install F28

    Thank you donatom

    I've tried what you advised however I encountered the same problem.

  4. #4
    Join Date
    Apr 2009
    Location
    central NY, USA
    Posts
    1,119
    Linux Firefox 52.0

    Re: "Starting WPA supplicant..." error on install F28

    In my experience, the "of=" has to be the /dev/{device}. Mine turned out to be "of=/dev/sdb" though yours may vary. You have to give the install the entire stick as the image also contains the boot record and other internal references.

    If you have info on the stick that you want, copy it somewhere. Create your install stick, install, then re-format the stick & copy back the saved info. Every time I tried to "of={some path}" it failed for me.
    Change - the only constant.

  5. #5
    Join Date
    Jan 2013
    Location
    Ventura, CA
    Posts
    421
    Linux Firefox 61.0

    Re: "Starting WPA supplicant..." error on install F28

    Before you reinstall, disable secure-boot and fast-boot (if it exists) in BIOS and also change Hybrid Graphics to Discrete Graphics. Before reinstalling, I would try (if you haven't already) to boot the live Fedora iso and run it without installing. If you have problems running the live iso, please list any errors and also what works and what doesn't work. If Fedora live runs well on your machine, then try installing it again.

  6. #6
    Join Date
    Jan 2013
    Location
    Ventura, CA
    Posts
    421
    Linux Firefox 61.0

    Re: "Starting WPA supplicant..." error on install F28

    If you still have the freezing when starting newly installed Fedora, you might try to modify the grub.cfg file after starting up on the install iso (and choosing "Try Fedora"). First make a copy of the file and send it to your email account or copy it to a usb device (# cp /boot/grub2/grub.cfg /home/liveuser). Then add acpi_osi=! acpi_osi="Windows 2009" (with quotation marks) to the linux16 (or linux) line.

    Notice I placed the line right before "ro" in the grub.cfg file. You might have to do this after each iteration of linux or linux16. When done, save this file and exit (you can do the above with gedit which you will have to install: "# dnf install gedit"). If gedit doesn't work then use vi or text-editor to modify the file.

    It should look similar to this:
    Code:
    linux16 /boot/vmlinuz-4.17.3-200.fc28.x86_64 root=UUID=d76404dd-82ec-4db0-ba71-15b8de9e03d6 acpi_osi=! acpi_osi="Windows 2009" ro resume=UUID=3c424b0d-6273-4f73-b066-9a95f513d640 rhgb quiet LANG=en_US.UTF-8
    Note: I gleaned the information listed above from the Archlinux wiki: https://wiki.archlinux.org/index.php/HP_Zbook_Studio_G3

    Restart and then try to boot your Fedora installation.
    Last edited by donatom; 5th July 2018 at 07:14 PM.

Similar Threads

  1. Replies: 3
    Last Post: 27th October 2011, 12:37 AM
  2. Folding@Home says "Error starting client thread" in FC10 PreUpgrade
    By quantumburnz in forum Alpha, Beta & Snapshots Discussions (Fedora 10 Only)
    Replies: 0
    Last Post: 13th October 2008, 11:42 PM
  3. Fedora Core 8 hangs at "Starting udev" after install
    By thucnh in forum Installation, Upgrades and Live Media
    Replies: 7
    Last Post: 21st November 2007, 03:22 AM
  4. New FC4 Install Fails to Boot "Starting PCMCIA Services"
    By richardnz in forum Hardware & Laptops
    Replies: 5
    Last Post: 19th March 2006, 05:14 AM
  5. Replies: 0
    Last Post: 23rd May 2005, 04:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •