FedoraForum.org - Fedora Support Forums and Community
Results 1 to 1 of 1
  1. #1
    Join Date
    Dec 2012
    Location
    santa barbara, CA
    Posts
    888
    Linux (Fedora) Firefox 60.0

    The RAID thread #1 - MegaRAID SAS 8704EM2

    OK guys,

    rebuilding my old servers so they can continue to serve the next 5 years at least. I don't have a battery backup, but of course my datacenter does have good UPSs which haven't failed in at least 20 years (with planned upgrades though).

    Question to the brainiacs in the community here, are CACHE SETTINGS.

    Now, one server has been upgraded, and the "storcli64 /c0 show" command shows:
    Product Name = MegaRAID SAS 8704EM2 (cache: 128MB 667MHz DDRII from the product spec sheet)
    Host Interface = PCI-E
    Device Interface = SAS-3G
    Code:
    DG/VD TYPE   State Access Consist Cache  Cac sCC      Size Name 
    ----------------------------------------------------------------
    0/0   RAID1  Optl  RW     Yes     NRAWBD -   OFF  1.817 TB      
    1/2   RAID0  Optl  RW     Yes     NRAWBD -   OFF  1.817 TB      
    2/1   RAID10 Optl  RW     Yes     NRAWBD -   OFF 10.908 TB
    [All disks are 2TB SAS, I have one hot-spare drive just in case, and the "raid0" drive is just used as scratch space. The "raid1" is the OS boot drive.]

    Question to you is this: NRAWBD . My cache settings.
    USAGE: I am using these servers basically as file servers (no database). The file system (in the RAID10) is being written say 10/second, files range from 10KB to 2MB (html and JPEGS), but is being read 100/second at least.

    According to the legend, I've got:
    NR=No Read Ahead
    AWB=Always WriteBack
    D=Direct IO

    There are of course other options:
    R=Read Ahead Always
    WB=WriteBack
    WT=WriteThrough
    C=Cached IO

    What do you guys think I should use ?
    EDIT: take into consideration, that I am talking about a gazillion files read and written basically randomly.
    Last edited by bobx001; 26th June 2018 at 08:00 AM.
    "monsters John ... monsters from the ID..."
    "ma vule teva maar gul nol naya"

Similar Threads

  1. F20 does not detect RAID virtual drive on MegaRaid SAS 9420-8i
    By nikhilxp64 in forum Hardware & Laptops
    Replies: 4
    Last Post: 17th January 2015, 12:20 AM
  2. Replies: 2
    Last Post: 3rd December 2009, 12:54 AM
  3. Installation problems on an LSI Megaraid 1600 SCSI Raid card
    By miguelon in forum Installation, Upgrades and Live Media
    Replies: 4
    Last Post: 20th December 2005, 07:35 PM
  4. megaraid: Detecting RAID disk failures
    By galesteven in forum Hardware & Laptops
    Replies: 4
    Last Post: 14th July 2005, 07:09 AM
  5. Replies: 2
    Last Post: 12th April 2005, 12:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •