FedoraForum.org - Fedora Support Forums and Community
Results 1 to 10 of 10
  1. #1
    Join Date
    Aug 2008
    Posts
    30

    Fedora 29 dnf issue with docs

    Anyone spot a fix for this please? Can't figure out how I got into this muddle, but it's stopping a regular dnf update now.

    dnf reinstall --allowerasing sqlite-libs
    Last metadata expiration check: 0:43:04 ago on Fri 15 Jun 2018 16:19:25 BST.
    Dependencies resolved.
    ================================================== ================================================== ================================================== =========
    Package Arch Version Repository Size
    ================================================== ================================================== ================================================== =========
    Reinstalling:
    sqlite-libs x86_64 3.24.0-1.fc29 rawhide 553 k
    replacing sqlite-libs.x86_64 3.22.0-4.fc29

    Transaction Summary
    ================================================== ================================================== ================================================== =========

    Total size: 553 k
    Is this ok [y/N]: y
    Downloading Packages:
    [SKIPPED] sqlite-libs-3.24.0-1.fc29.x86_64.rpm: Already downloaded
    Running transaction check
    Transaction check succeeded.
    Running transaction test
    The downloaded packages were saved in cache until the next successful transaction.
    You can remove cached packages by executing 'dnf clean packages'.
    Error: Transaction check error:
    file /usr/share/doc/sqlite-libs/README.md from install of sqlite-libs-3.24.0-1.fc29.x86_64 conflicts with file from package sqlite-libs-3.22.0-4.fc29.i686

    Error Summary
    -------------

  2. #2
    Join Date
    Dec 2017
    Location
    Sosnowiec, PL
    Age
    35
    Posts
    20

    Re: Fedora 29 dnf issue with docs

    You can just remove conflicting files - "docs" aren't key component of the package:
    Code:
    #   rm -rf /usr/share/doc/sqlite-libs
    marcin82

  3. #3
    Join Date
    Jun 2004
    Location
    Maryland, US
    Posts
    7,300

    Re: Fedora 29 dnf issue with docs

    Or remove that sqlite-libs for i686, you probably don't need it. Or it might be available in that rawhide repo you seem to have added

  4. #4
    Join Date
    Aug 2008
    Posts
    30
    Windows 7 Chrome 67.0.3396.87

    Re: Fedora 29 dnf issue with docs

    Quote Originally Posted by bill.damage
    Anyone spot a fix for this please? Can't figure out how I got into this muddle, but it's stopping a regular dnf update now.

    dnf reinstall --allowerasing sqlite-libs
    Last metadata expiration check: 0:43:04 ago on Fri 15 Jun 2018 16:19:25 BST.
    Dependencies resolved.
    ================================================== ================================================== ================================================== =========
    Package Arch Version Repository Size
    ================================================== ================================================== ================================================== =========
    Reinstalling:
    sqlite-libs x86_64 3.24.0-1.fc29 rawhide 553 k
    replacing sqlite-libs.x86_64 3.22.0-4.fc29

    Transaction Summary
    ================================================== ================================================== ================================================== =========

    Total size: 553 k
    Is this ok [y/N]: y
    Downloading Packages:
    [SKIPPED] sqlite-libs-3.24.0-1.fc29.x86_64.rpm: Already downloaded
    Running transaction check
    Transaction check succeeded.
    Running transaction test
    The downloaded packages were saved in cache until the next successful transaction.
    You can remove cached packages by executing 'dnf clean packages'.
    Error: Transaction check error:
    file /usr/share/doc/sqlite-libs/README.md from install of sqlite-libs-3.24.0-1.fc29.x86_64 conflicts with file from package sqlite-libs-3.22.0-4.fc29.i686

    Error Summary
    -------------
    Thanks! However ...

    [root@tiger ~]# rm -rf /usr/share/doc/sqlite-libs
    [root@tiger ~]# dnf reinstall --allowerasing sqlite-libs
    Last metadata expiration check: 1:41:21 ago on Mon 18 Jun 2018 08:17:31 BST.
    Dependencies resolved.
    ================================================== ================================================== ================================================== =========================================
    Package Arch Version Repository Size
    ================================================== ================================================== ================================================== =========================================
    Reinstalling:
    sqlite-libs x86_64 3.24.0-1.fc29 rawhide 553 k
    replacing sqlite-libs.x86_64 3.22.0-4.fc29

    Transaction Summary
    ================================================== ================================================== ================================================== =========================================

    Total download size: 553 k
    Is this ok [y/N]: y
    Downloading Packages:
    sqlite-libs-3.24.0-1.fc29.x86_64.rpm 2.1 MB/s | 553 kB 00:00
    -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    Total 403 kB/s | 553 kB 00:01
    Running transaction check
    Transaction check succeeded.
    Running transaction test
    The downloaded packages were saved in cache until the next successful transaction.
    You can remove cached packages by executing 'dnf clean packages'.
    Error: Transaction check error:
    file /usr/share/doc/sqlite-libs/README.md from install of sqlite-libs-3.24.0-1.fc29.x86_64 conflicts with file from package sqlite-libs-3.22.0-4.fc29.i686

    Error Summary
    -------------

  5. #5
    Join Date
    Aug 2008
    Posts
    30
    Windows 7 Chrome 67.0.3396.87

    Re: Fedora 29 dnf issue with docs

    Quote Originally Posted by marcin82
    You can just remove conflicting files - "docs" aren't key component of the package:
    Code:
    #   rm -rf /usr/share/doc/sqlite-libs
    Thanks! However...

    [root@tiger ~]# dnf remove sqlite-libs
    Error:
    Problem: The operation would result in removing the following protected packages: dnf
    [root@tiger ~]#

  6. #6
    Join Date
    Aug 2008
    Posts
    30
    Windows 7 Chrome 67.0.3396.87

    Re: Fedora 29 dnf issue with docs

    Quote Originally Posted by marcin82
    You can just remove conflicting files - "docs" aren't key component of the package:
    Code:
    #   rm -rf /usr/share/doc/sqlite-libs
    Thanks! However ...
    [root@tiger ~]# rm -rf /usr/share/doc/sqlite-libs
    [root@tiger ~]#
    [root@tiger ~]# dnf reinstall --allowerasing sqlite-libs
    Last metadata expiration check: 1:41:21 ago on Mon 18 Jun 2018 08:17:31 BST.
    Dependencies resolved.
    ================================================== ================================================== ================================================== =========================================
    Package Arch Version Repository Size
    ================================================== ================================================== ================================================== =========================================
    Reinstalling:
    sqlite-libs x86_64 3.24.0-1.fc29 rawhide 553 k
    replacing sqlite-libs.x86_64 3.22.0-4.fc29

    Transaction Summary
    ================================================== ================================================== ================================================== =========================================

    Total download size: 553 k
    Is this ok [y/N]: y
    Downloading Packages:
    sqlite-libs-3.24.0-1.fc29.x86_64.rpm 2.1 MB/s | 553 kB 00:00
    -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    Total 403 kB/s | 553 kB 00:01
    Running transaction check
    Transaction check succeeded.
    Running transaction test
    The downloaded packages were saved in cache until the next successful transaction.
    You can remove cached packages by executing 'dnf clean packages'.
    Error: Transaction check error:
    file /usr/share/doc/sqlite-libs/README.md from install of sqlite-libs-3.24.0-1.fc29.x86_64 conflicts with file from package sqlite-libs-3.22.0-4.fc29.i686

    Error Summary

  7. #7
    PabloTwo's Avatar
    PabloTwo is offline "Registered User" T-Shirt Winner
    Join Date
    Mar 2007
    Location
    Seville, FL
    Posts
    7,716
    Linux Chrome 67.0.3396.87

    Re: Fedora 29 dnf issue with docs

    As already suggested in post#3 above, you should use dnf to remove the 32 bit package of sqlite-libs-3.22.0-4.fc29.i686. The conflict arises from the 32 and 64 bit versions of the same package trying to install the same file to the same location, thus the "conflict". It's possible that removing the 32 bit package of sqlite-libs will want to remove other 32 bit packages, so do not use "-y" in the "dnf erase...." line so you can review what is going to happen first and bail out if you feel that is necessary.

  8. #8
    Join Date
    Aug 2008
    Posts
    30
    Windows 7 Chrome 67.0.3396.87

    Re: Fedora 29 dnf issue with docs

    Quote Originally Posted by PabloTwo
    As already suggested in post#3 above, you should use dnf to remove the 32 bit package of sqlite-libs-3.22.0-4.fc29.i686. The conflict arises from the 32 and 64 bit versions of the same package trying to install the same file to the same location, thus the "conflict". It's possible that removing the 32 bit package of sqlite-libs will want to remove other 32 bit packages, so do not use "-y" in the "dnf erase...." line so you can review what is going to happen first and bail out if you feel that is necessary.
    Hi Pablo,

    Hey thanks for your help. I did see the message regarding using dnf to remove just the 32 bit package, and despite Googling how to do this exactly, whilst leaving the 64 bit ones present, in order to prevent my noobiness showing, failed miserably ;-( How do you refine the dnf arg such that this is done please?

  9. #9
    Join Date
    Oct 2011
    Posts
    1,798
    Linux Chrome 66.0.3359.170

    Re: Fedora 29 dnf issue with docs

    Just removing the files from the filesystem wont solve package manager conflicts. Providing that you gave a 64-bit Fedora installed and not 32-bit, and also you have both versions installed currently, remove the 32-bit version.

    Code:
    $ sudo dnf remove sqlite-libs.i686
    Or try and see what you have installed currently, in particular what sqlite-libs packages:

    Code:
    $ rpm -q sqlite-libs

  10. #10
    Join Date
    Aug 2008
    Posts
    30
    Windows 7 Chrome 67.0.3396.87

    Re: Fedora 29 dnf issue with docs

    Quote Originally Posted by srakitnican
    Just removing the files from the filesystem wont solve package manager conflicts. Providing that you gave a 64-bit Fedora installed and not 32-bit, and also you have both versions installed currently, remove the 32-bit version.

    Code:
    $ sudo dnf remove sqlite-libs.i686
    That was it! All clean now, thanks very much!

Similar Threads

  1. Fedora docs. Module list?
    By dknation in forum Fedora Focus
    Replies: 1
    Last Post: 18th February 2011, 12:29 AM
  2. translating fedora docs
    By Orkan in forum Using Fedora
    Replies: 1
    Last Post: 23rd May 2006, 04:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •