Boot Problem: Mount Point Changed to /dev/ - Fedora Support Forums and Community
Results 1 to 2 of 2
  1. #1
    Join Date
    Jun 2018

    Boot Problem: Mount Point Changed to /dev/

    During a google search I was doing an in attempt to fix a qemu problem I ran across someone who suggested going into gnome-disk-utility and changing my mount point to /dev/ instead of /mnt/.

    The system's response was to immediately freeze up and force a hard reboot, to which I'm now entirely unable to get past the loading fedora icon. I can press F1, F2, etc and CTRL + ALT + 1/2/etc. The first time I did this I saw checks all coming back ok, but it was hanging on "switch root". The times I restarted the system after that I didn't get anything.

    I've tried running the recovery disk and doing fsck on the drive, going into grub I didn't see many options, and now I'm wondering if I should just re-install the system again. I'd really like to avoid doing that if possible, so I resorted to digging around the forum to see if anyone could help. I'd appreciate anything right now.

  2. #2
    Join Date
    Jun 2018

    Re: Boot Problem: Mount Point Changed to /dev/

    Well I ended up fixing(maybe?) it myself so I wanted to post the fix up here for others just in case anyone else is unfortunate enough to encounter this problem. No re-install is necessary.

    The problem is essentially your fstab file.

    You're going to need a rescue disk/usb. Boot into it and open a terminal, run these commands:

    Mkdir /mnt/sysimage
    Mount /dev/dm-4 /mnt/sysimage
    Mount -o remount, rw /
    Cd etc/
    Gedit fstab
    (Chroot tends to throw back errors that tell you to try chroot -t proc proc /proc, but it's not necessary. That's why we ls afterwards to make sure we're inside the drive location. You should see your root files)

    Gedit will shoot back some errors saying it couldn't make changes, ignore this. The file should be editable. The trick now is finding the drive. Example below:

    # /etc/fstab
    # Created by anaconda on Sat Jun 9 20:43:13 2018
    # Accessible filesystems, by reference, are maintained under '/dev/disk'
    # See man pages fatab(5), findfs(8), mount(8) and/or blkid(8) for more info
    /dev/mapper/fedora_localhost--live-root / Etc4 Default 1 1
    UUID=12Abc345-1fj6-6283-j265-9h4gk6diag0n /boot Ext4 Defaults 1 2
    There should be more in the file but just so you get the picture here, it's showing the drive first, then where it's mounted, followed by the filesystem, followed by drive settings, followed by idk (maybe someone else could explain that).

    What you want to do here is find the drive you mounted incorrectly. Since I set it to mount in /dev/ and it was named something I'd remember I found it quickly at the bottom line and changed '/dev/' to '/mnt/'

    Save the file, exit out of the terminal, and reboot. The system should now boot.

    It's important to note I had random freezing issues afterward that forced a hard restart. Happened twice so far, still troubleshooting. Did a dnf clean all and upgrade, reinstalled my browser (all freezing instances happened with multiple browsers open), quickly went into gnome-disks and switched mount options for the drive i placed on /dev/ before back to default with no mount at system startup enabled, and so far it's been an hour with no fail.
    Last edited by K0NIG; 11th June 2018 at 11:32 PM.

Similar Threads

  1. Replies: 1
    Last Post: 10th March 2009, 03:33 AM
  2. Problem mounting a drive via mount point under home
    By CelticBlues in forum Using Fedora
    Replies: 6
    Last Post: 18th June 2008, 12:34 AM
  3. Changed access point: can't connect anymore
    By gioacchinomauri in forum Servers & Networking
    Replies: 2
    Last Post: 18th June 2007, 08:13 AM
  4. non-root cannot mount user cifs mount point
    By rgladwell in forum Servers & Networking
    Replies: 2
    Last Post: 6th August 2006, 05:50 PM
  5. smbfs/cifs mount point in fstab not mounting on boot
    By rgladwell in forum Servers & Networking
    Replies: 5
    Last Post: 15th January 2006, 11:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts