FedoraForum.org - Fedora Support Forums and Community
Results 1 to 3 of 3
  1. #1
    PabloTwo's Avatar
    PabloTwo is offline "Registered User" T-Shirt Winner
    Join Date
    Mar 2007
    Location
    Seville, FL
    Posts
    7,647

    F27 > F28 upgrade - graphical mode fails due to pango problem.

    Yeah, lots of f27 > f28 upgrade "I can't login" threads, but I can't find anything that fits my issue. During the upgrade process I happened to catch some error about libpango, but that went by too fast to jot anything down. Upgrade finished normally, final boot to F28 went OK until it was time for the graphical lightdm login screen to come up. Hung there, stalled at "[OK] Started Light Display Manager."

    On fresh boot, it hangs at:
    Code:
    [ OK ]   Started Light Display Manager
    [ *** ] A start job is running for Hold until boot process finishes up (36s / no limit)
    CTL-ALT-F2 to a cli login is fine. A "startx" command fails, giving me an error about ligpango.

    Code:
    xfce4-session: symbol lookup error: /lib64/libpangoft2-1.0.so.0: undefined symbol: hb_variation_from_string
    
      xinit: connection to X server lost
    One error message prior to the pango thing on a fresh boot and the first instance of running startx is:
    Code:
    xf86EnableIOPorts failed to set IOPL for I/0 (Operation not permitted)
    That message is not repeated on subsequent startx tries.

    libpangoft2-1.0.so.0 symlinks to libpangoft2-1.0.so.0.4200.1. Those are installed by the current pango-1.42.1-2.fc28.x86_64 package.

    I tried a "dnf downgrade pango" and downgraded to pango-1.42.1-1fc28.x86_64 package. Rebooted with same result and same error trying a startx again. Checked in updates-testing for a newer pango package. Nada.

    Seeking suggestions for a remedy. This is on my desktop PC system: Asrock MB, Nvidia graphics card using nouveau driver. Xfce DE and no Wayland here.

    Hoping I will not have to resort to a "dnf distro-sync --allowerasing --best --releasever 27" to get out of this.
    Last edited by PabloTwo; 9th June 2018 at 02:22 AM. Reason: added additional info

  2. #2
    PabloTwo's Avatar
    PabloTwo is offline "Registered User" T-Shirt Winner
    Join Date
    Mar 2007
    Location
    Seville, FL
    Posts
    7,647

    Re: F27 > F28 upgrade - graphical mode fails due to pango problem.

    Update: Not "solved", but I found a workaround and now booting into graphical mode on the desktop PC with F28.

    I checked the version of pango on F27 (my laptop) to find it to be 1.40.14-1.fc27. So I went to koji and found a version for pango and pango-devel of 1.40.14-2.fc28 and used wget to download them to the desktop PC from the console login. Then used dnf to "downgrade" the two pango packages. It did so without any dependency complaints. Rebooted and got to the lightdm login screen and the Xfce desktop and I was happy. Currently have pango* excluded from updating on the F28 PC now.

    Edit: A couple of weeks or so prior to doing the 27 > 28 upgrade I had downloaded and burned to a USB stick the F28-Xfce-Live spin iso. It booted up into the graphical desktop just fine. Decided to boot it up now to check which version of pango was onboard. It was 1.42.1-1, the same version I had first downgraded to to try out and which didn't solve my problem.

    Which leads me to recall a somewhat recent thread here on the forum about fresh installs vs upgrades. And makes me wonder if a fresh install from Live iso would or would not have produced the same issue after the install? I'm not going to try it to find out.
    Last edited by PabloTwo; 9th June 2018 at 02:39 PM.

  3. #3
    PabloTwo's Avatar
    PabloTwo is offline "Registered User" T-Shirt Winner
    Join Date
    Mar 2007
    Location
    Seville, FL
    Posts
    7,647

    Re: F27 > F28 upgrade - graphical mode fails due to pango problem.

    Update: "SOLVED'

    By chance, doing an "ldd /user/lib64/libpangoft2-1.0.so.0.4000.13" file on my laptop computer, showed me it was linked to a harfbuzz object file.

    libharfbuzz.so.0 => /lib64/libharfbuzz.so.0 (0x00007f20acfa9000)

    Ding! From another issue some time back with harfbuzz, on my desktop PC, I had to install an earlier version of it to resolve the issue and then put harfbuzz* (3 packages) in my dnf.config exclude= line. Fired up the desktop PC, commented out the exclude= line which had harbuzz*, pango* and moc entries, saved the file, did a dnf upgrade which installed the current pango and harfbuzz packages and rebooted. Yes, that was it. The pango object file needed the current version of the harfbuzz (love that name) object file. All working as it should now.

Similar Threads

  1. Fedup from F20 to F21 fails to deliver. Graphical mode doesnt work. Black screen.
    By zimon in forum Installation, Upgrades and Live Media
    Replies: 5
    Last Post: 2nd March 2015, 10:16 PM
  2. Installation problem with graphical mode
    By cola in forum Installation, Upgrades and Live Media
    Replies: 1
    Last Post: 27th April 2009, 08:27 PM
  3. Booting in commandline mode versus graphical mode
    By DanSandberg in forum Using Fedora
    Replies: 4
    Last Post: 21st December 2007, 03:53 PM
  4. Booting fails - problem with graphical greeter:
    By The Thing in forum Using Fedora
    Replies: 7
    Last Post: 17th November 2005, 08:43 AM
  5. Graphical problem in single mode
    By zarkann in forum Using Fedora
    Replies: 0
    Last Post: 17th June 2005, 05:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •